Jump to content

Win 7 - Fehler beim Upgrade auf Windows 10 2004


Go to solution Solved by Squire,

Recommended Posts

Hallo zusammen,

ich scheitere derzeit am Upgrade von Windows 7 SP1 (Windows Updates sind aktuell) auf Windows 10 (2004). Im Log "setuperr.log" finde ich (sorry für die schlechte Formatierung):

 

##############################################################################################################################################

2020-08-06 14:36:31, Error                 MOUPG  CSystemHelper::CheckConnectedStandby(642): Result = 0x80070057
2020-08-06 14:36:43, Error                        CallPidGenX: PidGenX function failed on this product key. (hr = 0x8a010101)
2020-08-06 14:36:43, Error                 MOUPG  CDlpActionProductKeyValidate::ReportDownlevelInstallChannel(3274): Result = 0x8A010101
2020-08-06 14:36:43, Error                 MOUPG  ProductKey: Failed to report Host OS channel to telemetry.
2020-08-06 14:36:55, Error                        CallPidGenX: PidGenX function failed on this product key. (hr = 0x8a010101)
2020-08-06 14:36:56, Error                        CallPidGenX: PidGenX function failed on this product key. (hr = 0x8a010001)
2020-08-06 14:37:17, Error                 CSI    00000001 (F) STATUS_OBJECT_NAME_NOT_FOUND #10# from Windows::Rtl::SystemImplementation::DirectRegistryProvider::SysQueryValueKey(flags = 0, key = 6c0 ('\REGISTRY\MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion'), vn = [l:25 ml:26]'CurrentMajorVersionNumber', kvic = 2, kvi = 2, disp = 0)[gle=0xd0000034]
2020-08-06 14:37:17, Error                 CSI    00000002 (F) STATUS_OBJECT_NAME_NOT_FOUND #9# from Windows::Rtl::SystemImplementation::CKey::QueryValue(flags = 0, kn = [l:63]'\Registry\Machine\SOFTWARE\Microsoft\Windows NT\CurrentVersion\', vn = [l:25 ml:26]'CurrentMajorVersionNumber', ic = KeyValuePartialInformation, info = {l:0 b:}, disp = 0)[gle=0xd0000034]
2020-08-06 14:37:17, Error                 CSI    00000003 (F) STATUS_OBJECT_NAME_NOT_FOUND #38# from Windows::Rtl::SystemImplementation::DirectRegistryProvider::SysQueryValueKey(flags = 0, key = 6c0 ('\REGISTRY\MACHINE\SYSTEM\Setup'), vn = [l:7 ml:8]'Compact', kvic = 2, kvi = 2, disp = 0)[gle=0xd0000034]
2020-08-06 14:37:17, Error                 CSI    00000004 (F) STATUS_OBJECT_NAME_NOT_FOUND #37# from Windows::Rtl::SystemImplementation::CKey::QueryValue(flags = 0, kn = [l:31]'\Registry\Machine\SYSTEM\Setup\', vn = [l:7 ml:8]'Compact', ic = KeyValuePartialInformation, info = {l:0 b:}, disp = 0)[gle=0xd0000034]
2020-08-06 14:37:17, Error                 CSI    00000005 (F) STATUS_OBJECT_NAME_NOT_FOUND #45# from Windows::Rtl::SystemImplementation::DirectRegistryProvider::SysQueryValueKey(flags = 0, key = 698 ('\REGISTRY\MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion'), vn = [l:11 ml:12]'BuildBranch', kvic = 2, kvi = 2, disp = 0)[gle=0xd0000034]
2020-08-06 14:37:17, Error                 CSI    00000006 (F) STATUS_OBJECT_NAME_NOT_FOUND #44# from Windows::Rtl::SystemImplementation::CKey::QueryValue(flags = 0, kn = [l:63]'\Registry\Machine\SOFTWARE\Microsoft\Windows NT\CurrentVersion\', vn = [l:11 ml:12]'BuildBranch', ic = KeyValuePartialInformation, info = {l:0 b:}, disp = 0)[gle=0xd0000034]
2020-08-06 14:37:23, Error                 CSI    00000007 (F) STATUS_OBJECT_NAME_NOT_FOUND #78# from Windows::Rtl::SystemImplementation::DirectRegistryProvider::SysQueryValueKey(flags = 0, key = 6b0 ('\REGISTRY\MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts'), vn = [l:21 ml:22]'Arial Nova (TrueType)', kvic = 2, kvi = 2, disp = 0)[gle=0xd0000034]
2020-08-06 14:37:23, Error                 CSI    00000008 (F) STATUS_OBJECT_NAME_NOT_FOUND #77# from Windows::Rtl::SystemImplementation::CKey::QueryValue(flags = 0, kn = [l:69]'\Registry\Machine\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts\', vn = [l:21 ml:22]'Arial Nova (TrueType)', ic = KeyValuePartialInformation, info = {l:0 b:}, disp = 0)[gle=0xd0000034]

##############################################################################################################################################

 

Es ist eine einzelne HP Workstation Z2230 mit aktiviertem Windows 7 Professional. Das Upgrade versuche ich über ein frisch geladenes Windows 10 ISO, welches ich mit dem Media Creation Tool von MS geladen habe.

 

Was habe ich bisher versucht:

 

- Kaspersky deinstalliert

- Msconfig und alles was nicht OS-relevant ist deaktiviert

- Autostart ist leer

- sfc /scannow

- dism soweit unter Win7 möglich

- BIOS-Update

- Installation als lokaler "Administrator"

- Unnötige Dienste (SQL-Server,...) deaktiviert

 

Leider ist die Kiste voll mit Software die ich nicht unbedingt neu installieren will ;-) Aber diese Basis ist sicher auch irgendwo die Ursache für das Verhalten.

 

Derzeit bin ich ratlos. Was meint ihr?

 

Grüße

Samoth

Edited by Samoth
Link to post

Keine Ahnung, zumindest offiziell soll das ja schon geraume Zeit nicht mehr funktionieren.

 

Meiner Meinung nach wird klar der Produkt-Key angemeckert.

Kam der Rechner mit W7 installiert, was für eine Version ist das? (Home, Pro, Ultimate...)


Image hast du für den Fall der Fälle?

 

Mal mit der 1909 versucht?

 

Hmmmm

Link to post
vor 29 Minuten schrieb Nobbyaushb:

Keine Ahnung, zumindest offiziell soll das ja schon geraume Zeit nicht mehr funktionieren.

 

Meiner Meinung nach wird klar der Produkt-Key angemeckert.

Kam der Rechner mit W7 installiert, was für eine Version ist das? (Home, Pro, Ultimate...)


Image hast du für den Fall der Fälle?

 

Mal mit der 1909 versucht?

 

Hmmmm

Ja hallo :-),

 

mit deinem ersten Satz bringst du mich auf eine Idee! Am Ende geht es deswegen nicht? Die Maschine kam vorinstalliert mit Windows 7 Professional, ja. Und es ist das Image von HP. Ich habe von der Maschine noch eine DB-Sicherung und ein Image mit Acronis gezogen.

 

1909 haben wir auch schon gestestet - erfolglos. Wobei ich erst seit heute tiefer in die Analyse gestiegen bin. Evtl. versuche ich es auch noch mal mit dem Image... oder einem noch älteren?

 

Ich würde das gerne mal komplett offline machen, aber da ich das Upgrade im Moment leider nur per TeamViewer machen kann, geht das nicht. Habe deswegen mal die ausführende "SetupHost.exe" in der Windows Firewall geblockt und einen weiteren Lauf gestartet. Jetzt findet sich zusätzlich im Log noch die Info, dass keine Internetverbindung aufgebaut werden konnte. Die Meldung mit der Lizenz ist dennoch vorhanden.

Edited by Samoth
Link to post

Mit welchem Datenträger willst Du denn Upgraden?  Auch dürfte das "kostenlose" Upgrade nur mit einer Internetverbindung funktionieren, da für die Hardware eine digitale Lizenz eingespielt wird.

Im Prinzip müsste es damit weiterhin gehen:  https://support.microsoft.com/de-de/help/3159635/windows-10-update-assistant Wenn die PC noch Windows 7-Keys gelabelt haben, sollte es mit dem Key und der  ISO als Neuinstallation klappen. Eventuell fragt der Installer auch nach keinem Key.

Link to post

Ich habe das Media Creation Tool von Microsoft geladen und darüber das 2004-ISO erzeugt. Das entpacke ich und führe daraus die Setup.exe aus, um ein bestehendes Windows zu aktualisieren. Ist das in dem Fall, also Basis Windows 7, die falsche Vorgehensweise?

Link to post

Upgrades müssen  nicht immer funktionieren. Hast Du (nach einer Sicherung)  mal eine Neuinstallation vom USB-Stick  probiert? Dabei die HDD/SSD  formatieren. Wie gesagt: Falls auf dem Geräten ein  Auskleber mit  einem Windows 7-Key ist, gibst Du den ein. Vielleicht wird aber auch nicht nach gefragt. Den Key aus der Windows 7-Installation zu extrahieren bringt nichts, da das ein  OEM-Key ist mit dem Du nichts  anfangen kannst.

 

Ansonsten:  

2020-08-06 14:36:43, Error                 MOUPG  ProductKey: Failed to report Host OS channel to telemetry.
2020-08-06 14:36:55, Error                        CallPidGenX: PidGenX function failed on this product key. (hr = 0x8a010101)
2020-08-06 14:36:56, Error                        CallPidGenX: PidGenX function failed on this product key. (hr = 0x8a010001)

 

Hattest Du wirklich am PC Internetzugriff ohne Proxy und irgendwelche PI-Holes ?

Link to post

Der OEM Key, der bei der (Image-) Installation von HP verwendet wird ist, wie bei allen großen anderen OEM's auch, ein generischer und kann durchaus für ein Upgrade unbrauchbar sein, da bei Windows 7 nicht nur der Key sondern auch ein spezielles Zertifikat bzw eine Zertifikatsdatei benötigt wird, damit das OS denkt es sei aktiviert.

 

Üblicherweise findet sich auf dem Gerät selbst (oftmals  auch unter dem Akku) ein Key mit dem sich auch jetzt noch eine sogar frisch auf leerem Datenträger installierte Windows 10 Edition die zum Key passen muss (Pro für Professional/Ultimate, Home für Home) aktivieren. Der Zeitraum des kostenlosen Upgrades ist zwar offiziell vorbei, die Funktion selbst wurde bisher allerdings nicht aus Windows 10 entfernt und man befindet sich rechtlich wohl in einer Grauzone die Microsoft zudem jederzeit deaktivieren und/oder sperren kann.

 

Grüsse

 

Gulp

Edited by Gulp
Typo
Link to post

Bei neueren Windows 7-Geräten ist eben kein Aufkleber auf dem Gerät. Dann sollte aber die digitale Lizenz im Bios reichen. MS hat das irgendwann geändert, als zu viele Aufkleber mit  den Keys kopiert worden sind. Ein BIOS-Update vorher kann auch nicht schaden.

Edited by zahni
Link to post
vor 28 Minuten schrieb Samoth:

Ich habe das Media Creation Tool von Microsoft geladen und darüber das 2004-ISO erzeugt. 

Wozu? Einfach für diesen PC jetzt ausführen, die ISO braucht man nicht erstellen, habe ich immer nur für Rechner ohne Internetzugang gebaut - und dann von dem Stick gebootet

 

So meine Erfahrungen...

Link to post
vor 19 Stunden schrieb zahni:

Im Prinzip müsste es damit weiterhin gehen:  https://support.microsoft.com/de-de/help/3159635/windows-10-update-assistant 

Habe mir das gestern noch mal angesehen und über den Link lande ich letztlich auch beim Media Creation Tool.

 

vor 19 Stunden schrieb zahni:

mal eine Neuinstallation vom USB-Stick  probiert?

Nein. Denke aber das würde schon funktionieren. Die Neuinstallation (dann mit Win10) ist die letzte Lösung, da ich ich dann (eine nicht unerhebliche Anzahl) Programme neu installieren und Daten migrieren müsste... muss ;-)

 

vor 19 Stunden schrieb Gulp:

Üblicherweise findet sich auf dem Gerät selbst (oftmals  auch unter dem Akku) ein Key mit dem sich auch jetzt noch eine sogar frisch auf leerem Datenträger installierte Windows 10 Edition

Da schau ich noch mal nach. Evtl. ist der Lizenzkey auf dem Rechner anders als der im Windows. Wie dem auch sei: Ich vergleiche mal.

 

vor 19 Stunden schrieb Nobbyaushb:

Wozu? Einfach für diesen PC jetzt ausführen, die ISO braucht man nicht erstellen, habe ich immer nur für Rechner ohne Internetzugang gebaut

Hm, mache ich immer so, weil ich angenommen habe, dass er dann bei jedem Run neu Daten aus dem Netz lädt. So habe ich die 4 GB einmal und kann Ruckzuck einen neuen Anlauf starten. Ich denke das Ergebnis wird letztlich das gleiche sein.

 

Bin heute noch nicht dazu gekommen weiter an der Sache zu forschen. Gibts denn iwo noch konkrete Infos zu den Ursachen dieser Meldungen:

 

MOUPG  ProductKey: Failed to report Host OS channel to telemetry.

CallPidGenX: PidGenX function failed on this product key.

 

Kann man das Upgrade-Tool auch in einer Art Verbose-Modus starten?

 

Ja, es hat wohl was mit dem Key zu tun und das ist eben ist "gefailed". Aber was ist die Ursache? :-D

 

Sofern sich da nichts mehr tut, wird es wohl eine Neuinstallation auf einer neuen SSD werden.

 

Dankeschön an euch mal wieder! :-)


Samoth

Link to post

Ich bin mir nicht sicher, aber schau doch mal nach ob der W7 Telemetrie Dienst, falls W7 einen hat, laufen kann oder ob er deaktiviert ist. Wie sieht die HOSTS Datei aus? Sind irgendwelche Einträge in Sachen MSFT vorhanden? Falls ja, leeren und nochmal probieren.

Link to post
vor 4 Minuten schrieb Sunny61:

Wie sieht die HOSTS Datei aus?

Gestern gecheckt, keinerlei Einträge :-/ Habe auch noch ein bisschen Malware-Prüfung gemacht - erfolglos.

 

Telemetrie prüfe ich noch. Muss mir wieder Zugang auf die Maschine verschaffen.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...