Jump to content
Sign in to follow this  
herakles99

SBS mit SP1 und massig vielen Fehlermeldungen - Lahmer Zugriff bis Stillstand

Recommended Posts

Hi zusammen,

wurde letzte Woche zu einem SBS mit SP1 gerufen, der 5 Jahre in Betrieb ist.

Kunde schilderte folgendes:

1. Von jetzt auf gleich wird der Zugriff auf Server lahm un lahmer

2. Alle 4-6 Wochen ist dann überhaupt kein Zugriff mehr auf den SBS möglich

3. Neustart bringt nicht immer eine Änderung: manchmal muss auch

2 mal neu gestartet werden.

(Switch und Router sind ebenfalls meist ohne Funktion wurden aber

bereits getauscht - ohne Änderung)

4. Login auf Server dauert dann teilweise 15 Minuten

5. Auf den Clients kann dann auch kein Mail mehr aufgerufen werden

6. Netzwerkkarte des Servers ist dann weg (DNs Fehler).

7. Nach Neustart läuft es wieder so ziemlich gut, bis oben genanntes wieder

von vorrne los geht.

Auf dem Server laufen eine Reihe von Anwendungen. Als AV Software ist F-Secure im Einsatz (Version 8)

Fehler:

1. SRV ID 2019 - Poolspeicher

2. SAM ID 12294 - Konto Administrator konnte nicht gesperrt werden

3. NTFRS ID 13568 - JRN_WRAP_ERROR

4. USERENV ID 1053 - Compütername oder Benutzer konnte nicht...

5. SECURITY ID 537 - Kerberos Fehler

6. NTDS Replikation ID 2089 - Die Verzeichnispartition wurde x Tage nicht

gesichert

Die Ereignisse treten dann z.T. 20x pro Minute auf. Nach dem Neustart, wie gesagt, läuft der Server dann 4-6 Wochen tadellos.

Sonderbar ist auch der Zeitpunkt des Auftretens: immer Sonntagabend gegen 21 Uhr!?

Ich finde das sind zu viele Ereignisse, um nach einem spezifischen Fehler zu suchen.

Hinweise habe ich seit Gestern genügend gesichtet (RAID Controller, Software- Fehler, Hardware Fehler, Viren und Trojaner und vieles mehr.

Update auf SP2 will ich mal vorerst nicht machen (Controller und mannigfache Software) weil ich da mal sicher gehen möchte.

Es ist mir bewusst, dass dieser Problemserver nicht mit zwei Klicks geheilt wird und eventuell neu gemacht werden sollte, möchte aber mal einige fundierte Stimmen dazu hören.

Vielleicht hat jemand schon ähnliches mitgemacht.

Danke.

Rolf

Share this post


Link to post

Hallo Rolf,

 

liegt mit an Sicherheit grenzender Wahrscheinlichkeit am Virenscanner. Hast Du im F-Secure alle relevanten Verzeichnisse ausgeschlossen? Wichtig ist z.B. das Verzeichnis: "System Volume Information" oder auch das Sysvol-Verzeichnis.

 

Der 1. Fehler

1. SRV ID 2019 - Poolspeicher

ist auch gleich der Entscheidende. Alles andere werden Folgefehler sein, denn wenn der Poolspeicher voll ist, kann keine andere Anwendung mehr auf den Speicher zugreifen.

 

Hier noch ein KB-Artikel, der in etwa Dein Problem beschreibt: Ein Windows Server 2003-Computer reagiert möglicherweise nicht mehr, wenn eine Anwendung häufig den Mount Manager Abfrage Datenträgerinformationen verwendet

 

Wenn Du die Verzeichnisse wie oben beschrieben ausschließt, wirst Du das dort vorkommenden Hotfix nicht brauchen.

 

Gruß

 

iDiddi

Share this post


Link to post

@Norbert: Hast ja recht, aber das weiß er ja auch selbst

Update auf SP2 will ich mal vorerst nicht machen

 

Ich hab allerdings auch nicht richtig gelesen :o . Ist ja ein Exchange-Server mit von der Partie. Also muss das Verzeichnis natürlich unbedingt mit ausgeschlossen werden.

Share this post


Link to post

Würd mich am WE hinsetzen und das Ding einfach neuinstallieren, wenn du jetzt noch 3 oder 4 stunden nach dem Fehler suchst. hast du einen SBS 2 mal in der Zeitspanne neuinstalliert. ist manchmal wirtschaftlicher für kleine Firmen.

Share this post


Link to post
Würd mich am WE hinsetzen und das Ding einfach neuinstallieren, wenn du jetzt noch 3 oder 4 stunden nach dem Fehler suchst. hast du einen SBS 2 mal in der Zeitspanne neuinstalliert. ist manchmal wirtschaftlicher für kleine Firmen.

 

also ich bezweifel dass du innerhalb von 4 Stunden einen 2003er SBS neuinstallierst mit allen SP´s Updates etc. und die Software die er drauf laufen hat....

 

Ich würde versuchen den Fehler zu beheben und dann vielleicht auf den 2008er zu migrieren...

 

Grüße

Share this post


Link to post

Herzlichen Dank für die Antworten.

@iDiddi -> Verzeichnisse sind ausgeschlossen. Habe auch mal den Virenscanner komplett deaktiviert und alle Dienste geschlossen. Nada!

SP2: Da muss ich mich erst mal schlau machen. Wenn das bisher nie upgedatet wurde und der bisherige Dienstleister nichts gemacht hat (Rest ist jedoch aktualisiert), dann lasse ich mal meine Finger weg.

Exchange Server. Nee, ist ein Tobit David 9.

RobDust: Neunistallation ist schwierig. Der Kunde will das vorerst nicht, muss das so vorläufig akzeptieren.

Außerdem sind bei einer Neuinstallation einige Hersteller mit im Boot, das müsste erst mal koordiniert werden, weil wir das allein leider nicht hinbekommen.

iDiddi: Das mit dem Hotfix schaue ich mir mal genauer an.

Ich nehme gerne noch weitere Vorschläge mit größtem Interesse entgegen.

Danke mal vorerst

Rolf

Share this post


Link to post

Was hast Du denn für eine Sicherungssoftware drauf? BackupExec, NTBackup oder eine Andere?

 

Sonderbar ist auch der Zeitpunkt des Auftretens: immer Sonntagabend gegen 21 Uhr!?

Gibt es denn irgendein Programm, das genau am Sonntag gegen 21 Uhr irgendwas macht?

Share this post


Link to post
Was hast Du denn für eine Sicherungssoftware drauf? BackupExec, NTBackup oder eine Andere?

Gibt es denn irgendein Programm, das genau am Sonntag gegen 21 Uhr irgendwas macht?

Also drauf ist Symantec 10.5 mit dem Agenten für SQL Server.

Das rennt auch ohne Zucken.

Das mit dem Programm ist einfach zu erklären: nein, da wird nichts gestartet (das haben wir diesen Sonntag mal getestet mit process Esxplorer und mit Wireshark). Punkt 21.x Uhr geht das einfach los.

Mit Boot CD bereits auf Viren etc. getestet. Mit Avira und Kaspersky nichts gefunden.

Gruß Rolf

Share this post


Link to post

Dann prüfe doch einfach, welche Anwendung nun genau den Poolspeicher voll haut und ob es der Paged- oder der Non-Paged-Pool ist. Unter Feldstudie.net - Leaklogger - Kaspersky, Security, Malware, Tutorials, Microsoft, Windows, Linux, Geek findest Du das Tool Leaklogger. Damit kannst Du Dir schön grafisch anzeigen lassen, welcher Prozess sich wieviel Speicher einverleibt. Lade es Dir herunter. Damit alle benötigten Daten gesammelt werden können, ist die Installation der Windows Debugging Tools erforderlich. Diese findest Du unter: Driver Developer Resources: Debugging Tools for Windows

 

Bitte auch diese Installieren (mach den Haken bei allem Anderen raus. Du brauchst nur die Debugging-Tools)

 

Den Process-Explorer hast Du ja bereits installiert.

 

So. Nun den Leaklogger starten und die erforderliche Symbol-Datei im Installationsorder der Debugging-Tools auswählen. Als 2. einen Speicherordner Deiner Wahl auswählen und das Loggen starten.

 

Nach ein paar Sekunden sollte er fertig sein. Nun das erstellte Archiv extrahieren und die HTML-Datei öffnen.

 

Dort sind die Prozesse aufgelistet.

 

Warte ein paar Stunden und führe den Leaklogger nochmals aus.

 

Kannst Du den Schuldigen ausmachen?

 

Gruß

 

iDiddi

Share this post


Link to post

Hallo iDiddi,

vielen Dank für diese info.

Habe das mal alles heruntergeladen, läßt sich jedoch nur installieren mit Framwork 4.x und die - bekomme ich nicht drauf. Abbruch bei der Installation mit der meldung "die angegebene Datei kann nicht gefunden werden".

Auch 3.5 bricht mit Fehlermeldung ab.

Habe auch noch gesehen, dass alle Updates mit netFramework allesamt vom Admin zuvor schon gestrichen wurden, weil die wohl nicht drauf gingen.

Was nun?

Gruß Rolf

Share this post


Link to post

Oh. Mit dem Framework wusste ich nicht. Hat er bei mir auch nie angezeigt. Hast aber auch ein Pech. Und Du hast wirklich nur die Debugging-Tools ausgewählt? Falls Dir hier im Board keiner helfen kann, versuch doch mal die Anleitung auf dieser Seite:

 

Error 0×80070643 bei Windows Updates (.Net Framework) » Framework, Installation, Windows, Update, Updates, Fehler » Windows FAQ

 

Leider müssen die Debugging-Tools irgendwie drauf, da die "dbghelp.dll" benötigt wird, um den Non-Paged-Pool-Speicherverbrauch auszulesen.

Share this post


Link to post

Nur mal so in den Raum geworfen:

Viele RAID-Controller haben in den Factory-Defaults ein Verify irgendwann am Wochenende eingeplant. Vielleicht ist das ja noch ein Ansatz....

Share this post


Link to post

Habe das mal alles heruntergeladen, läßt sich jedoch nur installieren mit Framwork 4.x und die - bekomme ich nicht drauf. Abbruch bei der Installation mit der meldung "die angegebene Datei kann nicht gefunden werden".

Auch 3.5 bricht mit Fehlermeldung ab.

 

Wenn kein Einspruch der SBS-Spezialisten kommt, würde ich mit dem .Net Framework CleanUp Tool alle Net Framework Versionen deinstallieren. Anschließend wieder sauber bei 2.0 beginnen. Und wirklich nur eines nach dem anderen installieren.

Share this post


Link to post
Oh. Mit dem Framework wusste ich nicht. Hat er bei mir auch nie angezeigt. Hast aber auch ein Pech. Und Du hast wirklich nur die Debugging-Tools ausgewählt? Falls Dir hier im Board keiner helfen kann, versuch doch mal die Anleitung auf dieser Seite:

Error 0×80070643 bei Windows Updates (.Net Framework) » Framework, Installation, Windows, Update, Updates, Fehler » Windows FAQ

Leider müssen die Debugging-Tools irgendwie drauf, da die "dbghelp.dll" benötigt wird, um den Non-Paged-Pool-Speicherverbrauch auszulesen.

Hallo iDiddi,

Ich mach das mal so am WE. Danke für den Einsatz.

Übrigens komme ich schon gar nicht so weit die Tools auszuwählen, weil er vorher die Net 4 will.

SFHE

Nur mal so in den Raum geworfen:

Viele RAID-Controller haben in den Factory-Defaults ein Verify irgendwann am Wochenende eingeplant. Vielleicht ist das ja noch ein Ansatz....

Ist mir nicht bekannt, muss ich checken, jedoch gebe ich mal zu bedenken, weshalb der Server fast 5 Jahre rennt und erst seit 4-5 Monaten Faxen macht.

Sunny61

Wenn kein Einspruch der SBS-Spezialisten kommt, würde ich mit dem .Net Framework CleanUp Tool alle Net Framework Versionen deinstallieren. Anschließend wieder sauber bei 2.0 beginnen. Und wirklich nur eines nach dem anderen installiere

Habe mir schon mal vorsorglich das Cleanup Toll herunter geladen. Wenn von den SBS Spezialisten nix mehr kommt, gehe ich dran, ansonsten bitte gerne jeden Einwand hier posten. Bin dankbar dafür.

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...