Zum Inhalt wechseln


Foto

NAS01 ist unter HYPERV superlangsam


  • Bitte melde dich an um zu Antworten
12 Antworten in diesem Thema

#1 magicpeter

magicpeter

    vollkommen Ahnungsloser

  • 1.412 Beiträge

 

Geschrieben 09. Oktober 2017 - 17:46

Moin,
ich habe das ein kleines Phänomen.. ;) 

Ich habe folgende Umgebung:

Hyperv 2012 R2
64 GB 

120 GB SSD System
1000 GB SSD VMs

1 x GB Netzwerkkarte - Management LAN gleiches IP-Segemnt wie das Produktiv LAN
1 x  1 GB Produktiv LAN Aktiv , 1 x 10 GB Produktiv LAN Standby für die VMs im Team

 

2 x VMs (ServerDC, ServerEX)

 

1 x NAS mit 1 GB LAN ( 4 x 1 TB HDD Raid 5), Jumbo Frame (MTU 1500)

Wenn ich jetzt eine Datei vom HyperV direkt auf die NAS kopiere ist das super langsam 10 - 30  MB/s
DAS fällt auf denn die Datensicherung (Veeam B&R 9.5) die VMs auf die NAS sichert.

Dauert super lange.

 

Jetzt das Wunder:

Wenn ich jetzt eine Datei vom einer VM direkt auf die NAS kopiere ist die Geschwindigkeit 120 MB/s. Also völlig OK

 

Hat jemand eine Idee wo das daran liegen kann?

Ich brauche den schnellen Zugriff vom HyperV auf die NAS für die Datensicherung.


 


Bearbeitet von magicpeter, 10. Oktober 2017 - 07:02.

Gruss

Der Peter


#2 tesso

tesso

    Board Veteran

  • 2.251 Beiträge

 

Geschrieben 09. Oktober 2017 - 20:11

Mach mal die Jumboframes aus.



#3 magicpeter

magicpeter

    vollkommen Ahnungsloser

  • 1.412 Beiträge

 

Geschrieben 09. Oktober 2017 - 20:26

Die kann man leider nicht abschalten.
Es handelt sich um eine QNAP(TS-469 Pro)

Mann kann nur den MTU-Wert ändern.

1500
4074
7418
9000

Mehr geht nicht...


Gruss

Der Peter


#4 magheinz

magheinz

    Newbie

  • 1.376 Beiträge

 

Geschrieben 09. Oktober 2017 - 20:36

google doch mal nach "jumbo-frame"

#5 magicpeter

magicpeter

    vollkommen Ahnungsloser

  • 1.412 Beiträge

 

Geschrieben 09. Oktober 2017 - 20:39

Bin schon dabei.... 1500 ist kein Jumbo Frame sondern ein Standard. Alles über 1500 ist Jumbo Frame. Also ist bei 1500 kein Jumbo Frame aktiv.


Bearbeitet von magicpeter, 10. Oktober 2017 - 04:40.

Gruss

Der Peter


#6 muenster

muenster

    Newbie

  • 41 Beiträge

 

Geschrieben 10. Oktober 2017 - 08:54

Moin,

 


Wenn ich jetzt eine Datei vom HyperV direkt auf die NAS kopiere ist das super langsam 10 - 30  MB/s

DAS fällt auf denn die Datensicherung (Veeam B&R 9.5) die VMs auf die NAS sichert.

Dauert super lange.

 

Jetzt das Wunder:

Wenn ich jetzt eine Datei vom einer VM direkt auf die NAS kopiere ist die Geschwindigkeit 120 MB/s. Also völlig OK

 

Hat jemand eine Idee wo das daran liegen kann?

Ich brauche den schnellen Zugriff vom HyperV auf die NAS für die Datensicherung.

 

Also, ich verstehe das jetzt so:

 

Veeam braucht recht lange mit der Sicherung, Kopieren geht flott.

 

1. Wo ist Veeam installiert? Der Proxy von Veeam braucht auch Ressourcen, ist er außerhalb angesiedelt und nut 1 x NIC hat dann steht nur die halbe Bandbreite zur Verfügung.

2. Ist Veeam auf einer der Hyper-V gehosteten Maschienen installiert könnt die Last beim "sich selbst" Sichern erhöht sein. In der Übersicht von Veeam erkennt man schön die Netzwerklast im Verlauf der Sicherung.

3. QNAP hat 4 x NIC, 2 im Team auf dem NAS beschleunigen ungemein.

 

 

 



#7 djmaker

djmaker

    Board Veteran

  • 3.477 Beiträge

 

Geschrieben 10. Oktober 2017 - 08:59

Wie ist die Sicherung in Veeam eingerichtet? Welche Sicherungseinstellungen verwendest du? Dort sollte das Problem liegen.


Thomas

K.Y.S.S. - Keep Your Signatur Short :)

#8 Jim di Griz

Jim di Griz

    Board Veteran

  • 830 Beiträge

 

Geschrieben 10. Oktober 2017 - 17:53

Hallo,

nur als idee ohne das ich etwas sicher weiss:

wieviel freien speicher haben hyper-v und vm im taskmanager und wie aendert sich die belegung beim kopieren?

wieviel platz frei auf C: bei beiden?

nachdem ichs nochmal lese glaube ich an Ursache bei Switch, warum 10 gb nic standby?

Viele Moeglichkeiten bei den Konfigs mal nen Haken uebersehen zu haben.

und, edit, ist zwar nicht ganz deine Richtung mit Hyper-v aber ein Bekannter installierte zu seinem asus Board die Asus-Monitoring-Tools welche seine Netzgeschwindigkeit der boardeigen NIC reproduzierbar auf 1 Mbit reduzierten


Bearbeitet von Jim di Griz, 10. Oktober 2017 - 21:55.

2152 MCP 2000 Server, 70-410, 70-411, 70-412, 70-413, 70-414, 70-

Lizenzen : vse msdn abo


#9 magicpeter

magicpeter

    vollkommen Ahnungsloser

  • 1.412 Beiträge

 

Geschrieben 11. Oktober 2017 - 05:13

 

Moin,

 


Wenn ich jetzt eine Datei vom HyperV direkt auf die NAS kopiere ist das super langsam 10 - 30  MB/s

DAS fällt auf denn die Datensicherung (Veeam B&R 9.5) die VMs auf die NAS sichert.

Dauert super lange.

 

Jetzt das Wunder:

Wenn ich jetzt eine Datei vom einer VM direkt auf die NAS kopiere ist die Geschwindigkeit 120 MB/s. Also völlig OK

 

Hat jemand eine Idee wo das daran liegen kann?

Ich brauche den schnellen Zugriff vom HyperV auf die NAS für die Datensicherung.

 

Also, ich verstehe das jetzt so:

 

Veeam braucht recht lange mit der Sicherung, Kopieren geht flott.

 

1. Wo ist Veeam installiert? Der Proxy von Veeam braucht auch Ressourcen, ist er außerhalb angesiedelt und nut 1 x NIC hat dann steht nur die halbe Bandbreite zur Verfügung.

2. Ist Veeam auf einer der Hyper-V gehosteten Maschienen installiert könnt die Last beim "sich selbst" Sichern erhöht sein. In der Übersicht von Veeam erkennt man schön die Netzwerklast im Verlauf der Sicherung.

3. QNAP hat 4 x NIC, 2 im Team auf dem NAS beschleunigen ungemein.

 

 

 

 

Das kopieren einer großen Datei vim HYPERV-Host auf die NAS ist sehr langsam.
Das kopieren einer großen Datei aus einer VM auf die NAS geht super schnell.

Zu 1. Veeam und der Proxy sind auf dem HYPERV-Host installiert. Das ist so vom Support freigegeben und läuft beim 2 anderen Kunden einwandfrei.
Zu 2. Nein VEEAM ist auf keiner VM installiert. Ist auf nicht notwendig.
Zu 3. Diese QNAP hat nur 2 LAN Ports, aber das könnte man noch mal probieren

 

 
 


Wie ist die Sicherung in Veeam eingerichtet? Welche Sicherungseinstellungen verwendest du? Dort sollte das Problem liegen.

 

Veeam und der Proxy sind auf dem HYPERV-Host installiert. Das ist so vom Support freigegeben und läuft beim 2 anderen Kunden einwandfrei.
Es werden die kompletten beiden VMs gesichert.


Hallo,

nur als idee ohne das ich etwas sicher weiss:

wieviel freien speicher haben hyper-v und vm im taskmanager und wie aendert sich die belegung beim kopieren?

wieviel platz frei auf C: bei beiden?

nachdem ichs nochmal lese glaube ich an Ursache bei Switch, warum 10 gb nic standby?

Viele Moeglichkeiten bei den Konfigs mal nen Haken uebersehen zu haben.

und, edit, ist zwar nicht ganz deine Richtung mit Hyper-v aber ein Bekannter installierte zu seinem asus Board die Asus-Monitoring-Tools welche seine Netzgeschwindigkeit der boardeigen NIC reproduzierbar auf 1 Mbit reduzierten

Ja, der Switch könnte auch das Problem sein.
Aber die NAS und der Management Port sind am gleichen Switch.

HYPERV-Host

Festspeicher: System-Speicher: 250 GB SSD - Raid 1

Performance-Speicher: 1 TB SSD - Raid 1
SAN-Speicher:  4 TB HDD - Raid 1
 

Netzwerkkarten: Karte 1 - 1 GB - Management
Karte 2 - 1 GB - Backup
Karte 3 - IPMI
Karte 4 - 10 GB - Produktiv

Stromversorgung: 2 x 800W Netzteil


2 Switche:

netgear 10 GB - 5 Ports
- HYPERV Karte 2 - 1 GB - Backup
- Uplink in die 2 Etage und dann das LAN

TP-Link 1 GB - 5 Ports
- NAS 1 GB
- HYPERV - Karte 1 - 1 GB - Management
- HYPERV - Karte 2 - 1 GB - Backup

- HYPERV - Karte 3 - IPMI

- Uplink an das LAN
 


Gruss

Der Peter


#10 magheinz

magheinz

    Newbie

  • 1.376 Beiträge

 

Geschrieben 11. Oktober 2017 - 05:37

qieso machst du die backups über die 1GB-Schnittstelle wenn du 10GB zue Verfügung hast?

#11 magicpeter

magicpeter

    vollkommen Ahnungsloser

  • 1.412 Beiträge

 

Geschrieben 11. Oktober 2017 - 07:53

Weil der Kunde keine NAS mit 10 GB bezahlen wollte. ;) 


Gruss

Der Peter


#12 mwiederkehr

mwiederkehr

    Junior Member

  • 156 Beiträge

 

Geschrieben 11. Oktober 2017 - 08:51

Wenn auch das Kopieren einer Datei vom Host langsam ist, kann man Veeam wohl ausschliessen. (Aber Du solltest damit dann trotzdem keine 130 MB/s erwarten, der muss ja komprimieren, deduplizieren etc.)

 

Würde den Fehler deshalb bei der Netzwerkkarte des Hyper-V vermuten, welche für den Zugriff aufs NAS verwendet wird. Hat ein Ping vom Hyper-V auf das NAS eine ungewöhnlich hohe Latenz? Hatte mal das Problem bei einem HP Server, dort war die Lösung dann ein Update des Treibers und der Firmware der Netzwerkkarte.

 

Gehen die Daten über die richtige Netzwerkkarte oder nehmen sie evtl. den Umweg über ein Gateway, welches nicht schnell genug ist?



#13 Jim di Griz

Jim di Griz

    Board Veteran

  • 830 Beiträge

 

Geschrieben 11. Oktober 2017 - 13:23

vielleicht ist auch nur die C:-SSD langsamer. Die swapped, meine ich, bei windows immer bei dateitransfers.

Supertalent SSDs sind bei mir auch merklich langsamer als Samsung 940.

Wie ist denn die Kopiergeschwindigkeit C: auf VM / VMSSD und umgedreht?


Bearbeitet von Jim di Griz, 11. Oktober 2017 - 14:04.

2152 MCP 2000 Server, 70-410, 70-411, 70-412, 70-413, 70-414, 70-

Lizenzen : vse msdn abo