Jump to content
Light

Anmeldeskript wird zu spät ausgeführt

Recommended Posts

Moin Leute,

 

ich habe folgende Umgebung:

 

AD; W2k12 Server, Win7 Clients

 

Folgendes Problem tritt auf:

 

Ein Benutzer hat ein Anmeldeskript.

Das wird aber leider erst nach der Anmeldung ausgeführt.

Da in dem Skript auch die Drucker verbunden werden, führt das zu Problemen.

Ich habe testweise bereits die GPO "Auf das Netzwerk warten" aktiviert.

Leider ohne Erfolg.

Habt ihr noch eine andere Idee?

 

LG

 

Light

Share this post


Link to post
vor 52 Minuten schrieb Light:

Ein Benutzer hat ein Anmeldeskript.

Das wird aber leider erst nach der Anmeldung ausgeführt.

Wie lange nach der Anmeldung wird das Script ausgeführt? Wie bekommt der User das Script? Per GPO? Per GPP oder liegt das Script im Netlogon Verzeichnis?

Share this post


Link to post

Das Script wird ca eine Minute nach Anmeldung ausgeführt.

Das Script liegt im Netlogon Verzeichnis.

...und danke, dass Du hilfst!

 

Light

Share this post


Link to post
vor 37 Minuten schrieb Light:

Das Script wird ca eine Minute nach Anmeldung ausgeführt.

Das Script liegt im Netlogon Verzeichnis.

Und wo wird es aufgerufen? Als geplanter Task bei der Anmeldung oder als GPO-Einstellung?

Share this post


Link to post

Moin,

 

das Script wird als GPO aufgerufen.Verzögerung ist bereits aktiviert.

Ja, es ist eine SSD.

 

Light

Share this post


Link to post

Bein Windows 7 gab es meines Wissens noch nicht das Script Delay.

 

Hast du mal den Link zum Thema SSD verfolgt?

Share this post


Link to post
vor 1 Stunde schrieb Light:

das Script wird als GPO aufgerufen.

Wo genau in den Einstellungen hast Du das Script eingestellt? Betrifft das nur diesen 1 User oder alle User? Falls nur der eine User betroffen ist, ist das Problem auf allen Clients auf denen sich der User anmeldet doer nur auf dem einen Client?

Share this post


Link to post

Den Eintrag habe ich im Benutzerobjekt im AD eingetragen.

Es betrifft den Benutzer nur, wenn er sich an dem einen Computer anmeldet.

Da in dem gerät eine SSD Karte eingebaut ist, bin ich den bisherigen Hinweisen,

insbesondere den beiden Links von Tesso, nachgegangen.

Auch die Richtlinie "Anmeldeskripts gleichzeitig ausführen" habe ich angewendet.

Bisher leider ohne Erfolg.

 

Light 

Edited by Light

Share this post


Link to post
vor 1 Stunde schrieb Light:

Den Eintrag habe ich im Benutzerobjekt im AD eingetragen.

Es betrifft den Benutzer nur, wenn er sich an dem einen Computer anmeldet.

Also kein GPO sondern im Benutzerobjekt unter Anmeldescript? Hier unter Logon Script:

 

ad-w2k8-user-attributes-04.png

Bild ist von dieser Website: http://www.selfadsi.de/user-attributes-w2k8.htm

 

Du kannst dem User auf diesem Rechner ein neues Benutezrprofil verpassen oder das Script wirklich in einem GPO unterbringen, im AD-Objekt dann entfernen.

Share this post


Link to post

Ja, genau da ist das Skript angegeben.

Wenn das Eintragen des Skriptes in eine GPO das Problem löst, würde ich das gern tun.

Allerdungs verstehe ich den Unterschied leider nicht.

Edited by Light

Share this post


Link to post

Probier es doch einfach mal aus. Dauert ungefähr 5 Minuten. Natürlich streichst Du das Script zum Test aus dem AD Objekt raus. Weißt du denn wo in den GPO Einstellungen Du das Script angeben musst?

Share this post


Link to post

OMG - Finger weg von dem Logonskript-Eintrag im User-Objekt! Das ist ein Relikt aus NT-Zeiten, das wegen Backward Compatibility nie entfernt wurde... Vergiß am besten, daß das existiert :-)

Share this post


Link to post
Am 27.4.2020 um 10:37 schrieb Light:

Ein Benutzer hat ein Anmeldeskript.

Das wird aber leider erst nach der Anmeldung ausgeführt.

 

Moin

 

Ich verstehe es nicht, ein Ausführen eines Anmeldeskriptes nach der Anmeldung ist doch richtig. Wann soll es denn sonst ausgeführt werden.

 

Was funktioniert denn nicht? Wird das Skript wirklich ausgführt, vollständig? Oder hält es an, oder bricht es ab?

 

Eine Möglichkeit wäre es, den Aufruf des Skriptes in der Aufgabenplanung zu konfigurieren.

 

Wesentlich, erst nachdem der Client die Netzwerkverbindung zum Server, zu Netlogon hat, ist es sinnvoll das Skript auszuführen.

 

W10 startet sehr schnell bis zum Anmeldeformular, so das eine Anmeldung am Rechner möglich, bevor die Netzwerkverbindung zum Netlogon vorhanden ist. Versuchsweise mal ein, zwei, drei Minuten warten mit der Anmeldung.

 

 

 

Edited by lefg

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


Werbepartner:



×
×
  • Create New...