Jump to content

Empfohlene Beiträge

Hallo zusammen,

 

ich habe hier einen SBS2011 der sich mehr als seltsam verhält.

Der Server läuft schon seit Jahren wie ein Kätzchen. Ist gut gepflegt und gewartet und funktioniert sauber.

Jeder Client und jeder Server kann zugreifen, Netzlaufwerke, SQL, Web, Exchange alles tiptop.

ABER: Der Server kann nicht auf sich selbst zugreifen, per \\SERVERNAME, er kann auf keinen anderen Client oder Server zugreifen per \\SERVERNAME

Er ist voll pingbar, kann sich selber pingen, kann alles andere pingen. Nur der UNC Zugriff auf sich selbst und andere ist nicht möglich.

Ereignisprotokolle sehen gut aus (soweit wie das bei einem SBS halt gut aussieht). 

 

Er läuft als Hyper-V VM und wurde mal von einem Blech migriert.

 

Ich habe die Netzwerkkarte, entfernt und komplett neu eingerichtet. Mal den "großen" Reset gemacht

ipconfig /flushdns
nbtstat -R
nbtstat -RR
netsh int reset all
netsh int ipv4 reset
netsh int ipv6 reset
netsh winsock reset
 
Aber das ist kein IP Problem, das ist ein SMB/NETBIOS Problem?
 
Wobei ich auch per \\IP-ADRESSE\SHARE nicht zugreifen kann. Auch nicht per localhost ...
 
Netzwerkumgebung zeigt ihn selber nicht und keinen anderen PC/Server
Klicke ich in der Netzwerkumgebung auf den einzigen Server den ich sehe, ist ein Terminal Server, gibt es wie beim Zugriff auf sich selber, immer die Meldung: "Auf SERVER konnte nicht zugegriffen werden, vergewissern Sie sich ...."
Jetzt kommt das verrückte, ich habe in den Explorer Favoriten einige Schnellzugriffe auf Support Freigaben etc. auf den SBS2011 liegen. Die funktionieren!! 
Per net share sehe ich alle Freigaben, eben so in der Freigabe und Speicherverwaltung.
Der Server ist voll zugreifbar und funktionstüchtig er kann nur nicht auf sich selber und auf andere.
Es fühlt sich so an als wenn der Windows Datei Explorer nicht mehr klar kommt. Per Net Use kann ich aber auch kein Laufwerk auf ihn selbst verbinden.
Auf dem SBS läuft seit eh und je ein WINS Server, da habe ich auch mal leer gemacht und die IP aus der Netzwerkkarten Konfiguration genommen.
Firewall mal test weise aus und auf Durchlass gestellt.
Datei- und Drucker- Freigabe deaktiviert, aktiviert. Netzwerkkennung an. Profil ist Domänen-Netzwerk
AntiVirus / ESET ist komplett deinstalliert.
Anderes Admin Profil probiert.
 
Ob da jemand eine Idee haben oder eine Richtung wissen könnte?
Danke fürs lesen, der Path
bearbeitet von PathFinder

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Wieviel virtuelle Netzwerkkarten hat der Server? Wie ist das Netzwerk des Hyper-V Servers konfiguriert? Wie ist der virtuelle Switch konfiguriert? Hast du den physischen Switch mal stromlos gemacht?

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hallo Danke für die Antworten,

 

@lefg Ich habe nicht aktiv auf SMBv3 umgestellt, meinst du ob es danach passiert ist oder ob ich das machen soll?

@MurdocX Inwiefern es im Betrieb ein Problem ist ob ich vom Domänen Controller nicht auf ihn selber und / oder andere Maschinen zugreifen kann? ....?

@djmaker Der Server hat eine virtuelle Netzwerkkarte, Der Hyper-V Server ist im selben Netzwerkbereich und im Profil Domänennetzwerk, Domänenmitglied, weiß nicht genau was du meinst, der virtuelle Switch ist EXTERN und ohne gemeinsame Verwendung, der Hyper-V Server hat eine eigene Netzwerkkarte, die zweite ist exklusiv für die VM. Den physischen Switch konnte ich noch nicht stromlos machen, das ist sicher eine gute Idee.

bearbeitet von PathFinder

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

 

@lefg Ich habe nicht aktiv auf SMBv3 umgestellt, meinst du ob es danach passiert ist oder ob ich das machen soll?

 

Durch die automatischen Updates auf aktuellem Level wäre SMBv3 installiert. Es war nur ein Gedanke.

bearbeitet von lefg

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

 

@MurdocX Inwiefern es im Betrieb ein Problem ist ob ich vom Domänen Controller nicht auf ihn selber und / oder andere Maschinen zugreifen kann? ....?

 

Der Server läuft doch wie ein "Kätzchen"  ;)

 

Folgende Punkte würde ich abarbeiten

 

Server

  • Alte Netzwerkkarten über den Gerätemanager entfernen
  • Sind alle Dienste die auf "Automatisch" stehen auch gestartet?
  • Ist mehr als eine Netzwerkkarte vorhanden?
  • Welche SPNs sind gesetzt? ( setspn.exe -L SBS )
  • Sind die SMB-Regeln in der Firewall aktiv?
  • Welches Netzwerkprofil ist auf dem SBS aktiv? (domäne,privat oder öffentlich)

DNS am Server

  • Er hat sich selber IPv4 als DNS-Server eingetragen, keine Andere! (Ist ja nur ein Srv vorhanden)
  • Keine sonstigen IPv6 Adressen im DNS als DNS-Server ( Die Fritzbox verteilt gerne IPv6 Adressen im Netz )
  • Ist der SBS-Name ein CNAME?

 

DNS am Client

  • Keine IPv6 Adressen die nicht zum SBS passt ( ipconfig.exe /all )
  • Die richtige IPv4-Serveradresse eingetragen, kein Andere!

SMB-Zugriff-Test

  • vom Client auf den Server "\\domäne.fqdn\sysvol"

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

 

Der Server läuft doch wie ein "Kätzchen"  ;)

Naja dann liegt der Fokus jetzt wohl auf "lief" .. böse IT!

 

Folgende Punkte würde ich abarbeiten

 

Server

  • Alte Netzwerkkarten über den Gerätemanager entfernen

    check

  • Sind alle Dienste die auf "Automatisch" stehen auch gestartet?

    Ja

  • Ist mehr als eine Netzwerkkarte vorhanden?

    Nein

  • Welche SPNs sind gesetzt? ( setspn.exe -L SBS )

    Eine Menge, soll ich die hier mal listen oder auf etwas besonderes achten?

  • Sind die SMB-Regeln in der Firewall aktiv?

    Ja 

  • Welches Netzwerkprofil ist auf dem SBS aktiv? (domäne,privat oder öffentlich)

    Domäne

DNS am Server

  • Er hat sich selber IPv4 als DNS-Server eingetragen, keine Andere! (Ist ja nur ein Srv vorhanden)

    Ja

  • Keine sonstigen IPv6 Adressen im DNS als DNS-Server ( Die Fritzbox verteilt gerne IPv6 Adressen im Netz )

    Ja

  • Ist der SBS-Name ein CNAME?

    Nein

 

DNS am Client

  • Keine IPv6 Adressen die nicht zum SBS passt ( ipconfig.exe /all )

    Ja

  • Die richtige IPv4-Serveradresse eingetragen, kein Andere!

    Ja

SMB-Zugriff-Test

  • vom Client auf den Server "\\domäne.fqdn\sysvol"

    Kein Problem, geht

 

 

Der Server kann nicht auf sich selbst oder andere Windows Clients zugreifen ...

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Moin

 

Ob das Verhalten nach Umstellung auf SMBv3 auftritt?

Was genau meinst du?

 

Bye

Norbert

Durch die automatischen Updates auf aktuellem Level wäre SMBv3 installiert. Es war nur ein Gedanke.

Bist du dir da sicher? Wir reden hier doch vom sbs 2011, oder? Das wäre Windows 2008r2. Und da gibts kein smb3 afair. Und davon ab kann man smb3 immer nur kombiniert mit smb2 aktivieren oder deaktivieren und durch patches passiert da auch nichts automatisch.

 

Bye

Norbert

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Der Server kann nicht auf sich selbst oder andere Windows Clients zugreifen ...

 

Ansätze durchgearbeitet? Ich verstehe nicht was du mir damit sagen willst, weil das schon in deinem ersten Post stand.

 

Edit:

Ah, du hast das im Zitat bearbeitet. Ok

 

Wenn du eine andere Freigabe erstellst, können die Clients dann darauf zugreifen? Wie berechtigst du die Freigaben bzw. NTFS? Nutzt du IPSec zur Verschlüsselung der Kommunikation? In der FW konfigurierbar.

bearbeitet von MurdocX

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Kein IPSEC.

 

Erstelle ich eine Freigabe können alle Clients zugreifen, der SBS auf sich selber nicht!

 

Das muss ein Problem im Netzwerkclient des SBS sein, zugreifend nicht freigebend.

 

Ich mache gerade einen Call bei MS auf was ich noch nie musste, mal gucken wie sowas läuft.

 

Wenn ich etwas finde berichte ich hier natürlich. 

 

Danke für eure Mühe

bearbeitet von PathFinder

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Interessanter Fall. Die Netzwerkkonfiguration passt, sonst würde kein Zugriff auf eine Freigabe möglich sein, wie z.B. Sysvol. Ich vermute das veränderte Berechtigungen das Problem sind, welche genau kann ich aber auch nicht sagen.

 

Lass mal hören was bei dem Case dann raus kam.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hi,

 

ein anderer Ansatz: Schick den SBS in Rente.

 

Du hast vermutlich schon viel Zeit in den Fehler gesteckt und mit dem Call wirst du ja noch einiges mehr an Zeit da reinstecken. Ggfs. wäre es hier eine Überlegung wert, den SBS durch neue Software (und ggfs. auch Hardware) abzulösen.

 

Gruß

Jan

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Erstelle ein Benutzerkonto oder melde dich an, um zu kommentieren

Du musst ein Benutzerkonto haben, um einen Kommentar verfassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Es ist einfach!

Neues Benutzerkonto erstellen

Anmelden

Du hast bereits ein Benutzerkonto? Melde dich hier an.

Jetzt anmelden

×