Zum Inhalt wechseln


Foto

Anmeldeskript Problem

Windows 8.1 GPO

  • Bitte melde dich an um zu Antworten
13 Antworten in diesem Thema

#1 MurdocX

MurdocX

    Senior Member

  • 406 Beiträge

 

Geschrieben 23. März 2015 - 17:10

Hi Zusammen,

 

ich hab ein interessantes Startskript Verhalten bei der Anmeldung.

 

Umgebung

Client: Windows 8.1 Enterprise

DCs: Windows Server 2012 R2

GPO:

+ Computerkonfiguration, Loopbackverarbeitungsmodus aktiv (zusammenführen), Benutzer Anmeldeskript auf Batchdatei-Basis

+ Anmeldeskriptverzögerung, deaktiviert

+ Auf Netzwerk warten, aktiviert

+ Hybrider Standbymodus, deaktiviert

Keine Roaming Profiles !

 

Problematik

Bei einer erstmaligen Anmeldung an einem Rechner durch einen Benutzer (Benutzerprofil wird lokal angelegt) werden alle Gruppenrichtlinienobjekte angewendet, jedoch nicht das Anmeldeskript. Auch nicht mit einer Verzögerung von 5min. "gporesult /z" meldet das das Skript nicht ausgeführt wurde. Meldet sich der Benutzer jedoch AB und wieder AN, dann wird das Anmeldeskript einwandfrei ausgeführt. 

Dieses Verhalten hatten wir bei WIndows 7 Enterprise nicht. Dieser Fehler lässt auf allen Computern reproduzieren. 

 

Hat hierzu vielleicht jemand eine Idee oder schon ein ähnliches Verhalten festgestellt?

 

Grüße

Jan


Mit freundlicher Unterstützung
Jan


#2 lefg

lefg

    Expert Member

  • 20.311 Beiträge

 

Geschrieben 23. März 2015 - 17:45

Hallo,

 

mein Bauchgefühl liesse mich mal testweise Loopback deaktivieren.


Bearbeitet von lefg, 23. März 2015 - 17:48.

Das Messbare messen, das Nichtmessbare messbar machen. Galilei.

 

Diskutiere nicht mit ***en, denn sie ziehen dich auf ihr Niveau und schlagen dich dort mit Erfahrung! (Hab ich bei Tom abgeguckt)

 

Koinzidenz begründet keine Korrelation und ist kein Beweis für Kausalität. (Hab ich bei Daniel abgeguckt) https://de.wikipedia...rgo_propter_hoc

 

Absolutistischer“ Geschäftsführungs-Dogmatismus, der jedwede Empirie aus der „Werkstatt“ schlichtweg ignoriert , führt eben zumeist früher als später ….  (Hab ich von Klabautermann)


#3 NorbertFe

NorbertFe

    Expert Member

  • 30.273 Beiträge

 

Geschrieben 23. März 2015 - 17:57

Schau mal, ob das Erleuchtung bringt. ;)
https://sdmsoftware....in-windows-8-1/

Bye
Norbert

Make something i***-proof and they will build a better i***.


#4 daabm

daabm

    Expert Member

  • 2.066 Beiträge

 

Geschrieben 23. März 2015 - 18:19

Hast Du nach der ersten Anmeldung mal einen RSoP erstellt? Steht das Anmeldeskript da drin? Und was steht im Group Policy Eventlog möglicherweise Interessantes?

Greetings/Grüße, Martin

Mal ein gutes Buch über GPOs lesen? Oder ein kleines, aber feines Blog darüber?

Und wenn mir die IT mal auf die Nerven geht - coke bottle design refreshment (-:


#5 MurdocX

MurdocX

    Senior Member

  • 406 Beiträge

 

Geschrieben 23. März 2015 - 19:30

Hallo,

 

mein Bauchgefühl liesse mich mal testweise Loopback deaktivieren.

 

Danke. Werde ich am Mittwoch gleich testen und eine Rückmeldung geben. 

 

 

Schau mal, ob das Erleuchtung bringt. ;)
https://sdmsoftware....in-windows-8-1/

Bye
Norbert

 

Danke für den Hinweiß, jedoch schon deaktiviert ;)  (Siehe erster Post)

Ich weiß auch nicht ob man das wirklich als neues "Feature" betrachten kann, aber das ist denke ich eine andere Diskussion  :)

 

Hast Du nach der ersten Anmeldung mal einen RSoP erstellt? Steht das Anmeldeskript da drin? Und was steht im Group Policy Eventlog möglicherweise Interessantes?

 

Danke für deine Antwort.

 

1. Einen RSoP über die CMD mit "/Z". Unterhalb des Skripteintrags stand (ungefährer Wortlaut nach) "Wurde noch nicht ausgeführt.". Sobald ich Mittwoch wieder im Büro bin, kann ich den genauen Wortlaut gerne nachliefern. Die Gruppenrichtlinie wurde aber nicht gefiltert, sondern ohne Fehler angewandt.

 

2. Das Anmeldeskript setzt Variablen über "Setx" für die Benutzersitzung und über "reg.exe /import" werden auch nur für eine Anwendung in "HKCU" Standardeinstellungen importiert. Die *.reg-Datei liegt direkt mit im Sysvol in der Gruppenrichtlinie.

 

3. Bisher liefert die Ereignisanzeige keine Fehler für Gruppenrichtlinenprobleme. Ich könnte, falls gewünscht, das debugging der Gruppenrichtlinien mal aktivieren um genaueres zu erfahren. Hier habe ich mir gehofft etwas Arbeit sparen zu können, falls ich eine andere Möglichkeit übersehen habe  :)


Bearbeitet von MurdocX, 23. März 2015 - 19:33.

Mit freundlicher Unterstützung
Jan


#6 NilsK

NilsK

    Expert Member

  • 11.950 Beiträge

 

Geschrieben 24. März 2015 - 08:21   Lösung

Moin,

 

das, was dein Skript macht, bekommst du ja auch mit GPP hin. Dadurch löst du das Problem zwar nicht, erreichst das eigentliche Ziel aber durchaus "besser".

 

Gruß, Nils


Nils Kaczenski

MVP Cloud and Datacenter Management
... der beste Schritt zur Problemlösung: Anforderungen definieren!

Kostenlosen Support gibt es nur im Forum, nicht privat!


#7 lefg

lefg

    Expert Member

  • 20.311 Beiträge

 

Geschrieben 24. März 2015 - 08:28

Moin,

 

ich sags mal so:

 

Welch ein Aufwand für ein popiliges Netzlaufwerk, als wenn man als Administrator nichts anderes zu tun hat?

 

Der Benutzer soll das gefälligst selbst mit dem Explorer machen. Gibt es noch F1 für Hilfe? Hat Windows noch eine Hilfe? Gibt es die im Web?


Das Messbare messen, das Nichtmessbare messbar machen. Galilei.

 

Diskutiere nicht mit ***en, denn sie ziehen dich auf ihr Niveau und schlagen dich dort mit Erfahrung! (Hab ich bei Tom abgeguckt)

 

Koinzidenz begründet keine Korrelation und ist kein Beweis für Kausalität. (Hab ich bei Daniel abgeguckt) https://de.wikipedia...rgo_propter_hoc

 

Absolutistischer“ Geschäftsführungs-Dogmatismus, der jedwede Empirie aus der „Werkstatt“ schlichtweg ignoriert , führt eben zumeist früher als später ….  (Hab ich von Klabautermann)


#8 MurdocX

MurdocX

    Senior Member

  • 406 Beiträge

 

Geschrieben 25. März 2015 - 09:51

Hallo Zusammen,

 

das Problem mit den Benutzervariablen umgangen gelöst. Der Tipp von NilsK, die GPP für zu nehmen, war goldrichtig. Zwar nicht für meine Regfiles, aber für die Benutzervariablen  :) Problem mit dem nicht ausgeführten Anmeldeskript bei der ersten Anmeldung aber nicht gelöst.

 

Interessantes Verhalten

Die Gruppenrichtlinie wird fehlerfrei angewandt, jedoch das Skript nicht ausgeführt. RSOP zeigt in der MMC, sowie in der CMD das das Skript nicht angewendet/ausgeführt wurde. Fehler im Eventlog sind keine vorhanden.

Führe ich jedoch die CMD mit erhöhten Berechtigungen des gleichen Benutzer aus (nach der ersten Anmeldung), dann sind die Benutzervariablen gesetzt. Ohne erhöhte Berechtigung der CMD sind die Variablen nicht sichtbar  :confused: Übersehe ich hier was?

 

"SETX LM_LICENSE_FILE 28000@FQDN" lautet der Befehl

 

 

Moin,

 

das, was dein Skript macht, bekommst du ja auch mit GPP hin. Dadurch löst du das Problem zwar nicht, erreichst das eigentliche Ziel aber durchaus "besser".

 

Gruß, Nils

 

In dem Fall der Regfile sind 10000 Einstellungen vorhanden. Kennst du eine Möglichkeit die Reg-Einträge zu importieren außer über den Registrierungs-Assistenten?

 

 

Hallo,

 

mein Bauchgefühl liesse mich mal testweise Loopback deaktivieren.

 

Hat leider nicht zum Erfolg geführt. Ich hab´s mit einer separaten Benutzergruppenrichtlinie probiert, jedoch ist das Ergebnis gleich.

Bearbeitet von MurdocX, 25. März 2015 - 10:07.

Mit freundlicher Unterstützung
Jan


#9 Sunny61

Sunny61

    Expert Member

  • 21.888 Beiträge

 

Geschrieben 25. März 2015 - 10:25

das Problem mit den Benutzervariablen umgangen gelöst. Der Tipp von NilsK, die GPP für zu nehmen, war goldrichtig. Zwar nicht für meine Regfiles, aber für die Benutzervariablen  smile.gif Problem mit dem nicht ausgeführten Anmeldeskript bei der ersten Anmeldung aber nicht gelöst.
 
Interessantes Verhalten
Die Gruppenrichtlinie wird fehlerfrei angewandt, jedoch das Skript nicht ausgeführt. RSOP zeigt in der MMC, sowie in der CMD das das Skript nicht angewendet/ausgeführt wurde. Fehler im Eventlog sind keine vorhanden.
Führe ich jedoch die CMD mit erhöhten Berechtigungen des gleichen Benutzer aus (nach der ersten Anmeldung), dann sind die Benutzervariablen gesetzt. Ohne erhöhte Berechtigung der CMD sind die Variablen nicht sichtbar  confused.gif Übersehe ich hier was?
 
"SETX LM_LICENSE_FILE 28000@FQDN" lautet der Befehl


Spricht etwas dagegen, das schon in einem Computerstartupscript zu setzen?
 

 

In dem Fall der Regfile sind 10000 Einstellungen vorhanden. Kennst du eine Möglichkeit die Reg-Einträge zu importieren außer über den Registrierungs-Assistenten?


Mit Hilfe von http://www.reg2xml.com/ kannst Du ein REG-File in ein XML konvertieren, das XML per Drag and Drop in ein GPP-Registry Fenster ziehen, schon sind die 10.000 Werte und Schlüssel importiert.
Gruppenrichtlinien: http://www.gruppenrichtlinien.de/

#10 MurdocX

MurdocX

    Senior Member

  • 406 Beiträge

 

Geschrieben 25. März 2015 - 11:08

Spricht etwas dagegen, das schon in einem Computerstartupscript zu setzen?

 

Nein, spricht nichts dagegen. :wink2: Wir hatten nur keins konfiguriert und ich wollte das alles "kiss" halten  :) In der kommenden Image-Version der Schulungsplätze habe ich die schon integriert. 

 

 

Mit Hilfe von http://www.reg2xml.com/ kannst Du ein REG-File in ein XML konvertieren, das XML per Drag and Drop in ein GPP-Registry Fenster ziehen, schon sind die 10.000 Werte und Schlüssel importiert.

 

Vielen Dank für den Tipp! Das Tool habe ich gleich mal ausprobiert, jedoch macht er nur 2 Reg-Keys  :(  Geholfen hast du mir aber trotzdem. Ich denke ich werde mir ein PS-Skript schreiben, das mir die Einträge in XML-Code umwandelt. 


Mit freundlicher Unterstützung
Jan


#11 NorbertFe

NorbertFe

    Expert Member

  • 30.273 Beiträge

 

Geschrieben 25. März 2015 - 12:05

Vielen Dank für den Tipp! Das Tool habe ich gleich mal ausprobiert, jedoch macht er nur 2 Reg-Keys  :(  Geholfen hast du mir aber trotzdem. Ich denke ich werde mir ein PS-Skript schreiben, das mir die Einträge in XML-Code umwandelt.


http://www.reg2xml.com/download.html

The Trial version of reg2xml converts only the first 2 values inside the registry export file. There is no time limit. The Trial version of reg2xml is free for personal and commercial use. When starting reg2xml, it will always show a registration window, until you enter the serial number. The licenced version is limited to the use on one computer only. Any further installation needs a seperate licence. Please take a look at our EULA - End User Licence Agreement.


http://www.reg2xml.com/licence.html

Bye
Norbert

Make something i***-proof and they will build a better i***.


#12 Sunny61

Sunny61

    Expert Member

  • 21.888 Beiträge

 

Geschrieben 25. März 2015 - 12:15

Vielen Dank für den Tipp! Das Tool habe ich gleich mal ausprobiert, jedoch macht er nur 2 Reg-Keys  frown.gif  Geholfen hast du mir aber trotzdem. Ich denke ich werde mir ein PS-Skript schreiben, das mir die Einträge in XML-Code umwandelt.


Hmm, steht doch auch dabei:
 

The Trial version of reg2xml converts only the first 2 values inside the registry export file.


Und 59 EURO ist wirklich nicht viel Geld für das Tool. Wert ist es das allemal.


EDIT: Zu langsam, kommt davon wenn man nebenbei fleißig telefoniert. wink.gif

Bearbeitet von Sunny61, 25. März 2015 - 12:37.

Gruppenrichtlinien: http://www.gruppenrichtlinien.de/

#13 MurdocX

MurdocX

    Senior Member

  • 406 Beiträge

 

Geschrieben 27. März 2015 - 17:03

Das hab ich wohl im EIfer des Gefechts überlesen  ;)

 

@Alle

Danke für Eure Hilfe!

Das mit den nicht ausgeführten Skripten bei der ersten Anmeldung muss ich wohl dann so hin nehmen.... ;-)

 

Vielen Dank für den Tipp! Das Tool habe ich gleich mal ausprobiert, jedoch macht er nur 2 Reg-Keys  :(  Geholfen hast du mir aber trotzdem. Ich denke ich werde mir ein PS-Skript schreiben, das mir die Einträge in XML-Code umwandelt. 

 

Fall jemand auch keine 60€ zur Hand hat, habe ich eine gute Alternative. Ich habe, wie angekündigt, ein Powershell-Skript als Konverter geschrieben.

 

http://www.it-explor...erter-fuer-gpp/


Mit freundlicher Unterstützung
Jan


#14 MurdocX

MurdocX

    Senior Member

  • 406 Beiträge

 

Geschrieben 26. November 2015 - 11:04

Status-Update:

Ich kann vermelden, dass das Problem nicht mehr besteht. Beobachtet hab ich das Problem über die Zeit nicht, jedoch existiert es nicht mehr. Vermutlich hat ein Windows Update das Verhalten gefixt, denn an den Gruppenrichtlinien wurde, bis auf die GPP damals, nichts angepasst.


Mit freundlicher Unterstützung
Jan