Jump to content

Rechner werden in der Netzwerkumgebung nicht angezeigt


Recommended Posts

Hallo zusammen,

 

ich habe das Problem, dass in einem Domänennetzwerk alle Rechner nicht im Explorer in der Netzwerkumgebung angezeigt werden.

Komischerweise funktioniert es auf genau einem Rechner so wie es soll.
Alle anderen 29 Rechner zeigen immer genau die gleichen 3 Rechner an.
Folgende Test funktionieren:
Ping mit IP und Namen auf die Rechner
net use auf Resourcen auf die Rechner

net view zeigt auch die Freigaben auf den Rechnern an

 

Frage: was kann/muss ich tun, damit alle Rechner im Domänennetzwerk im Explorer angezeigt werden?

 


Follgende Massnahmen, die ich im Netz gefunden habe, habe ich bereits ergriffen:

 

  1. Ich habe den Vierenschutz deaktiviert
  2. Ich habe sfc /scannow ausgeführt
  3. Ich habe Dism /Online /Cleanup-Image /RestoreHealth ausgeführt. Keine Fehler.
    Neustart... Keine Verbesserung
  4. Ich habe die Netzwerkumgebung zurückgesetzt
    Neustart... Keine Verbesserung
  5. Ich habe in den erweiterten  Freigabeeinstellungen die Netzwerkerkennung deaktiviert und wieder aktiviert.
    Neustart... Keine Verbesserung
  6. Ich habe in den Services die Dienste "Funktionssuchanbieter-Host" und "Funktionssuche-Ressourcenveröffentlichung" auf Starttyp  automatisch (verzögert)
    gestellt und neu gestartet.
    Neustart... Keine Verbesserung
  7. Ich habe  in den "Windows-Features" SMB Direkt" aktiviert
    (Mir ist bekannt das das ein Sicherheitsrisiko darstellt)
  8. Ich habe  in den "Windows-Features" unter "Unterstützung für SMB1.0/CIFS-Dateifreigabe alles aktiviert
    (Mir ist bekannt das das ein Sicherheitsrisiko darstellt)
  9. Bei den Diensten
    NLA (Network Location Awareness),
    Netzwerkverbindungen,
    UPnP-Gerätehost,
    DNS-Client,
    SSDP-Suche
    habe ich den Starttyp “automatisch” eingestellt
  10. Ich habe den DNS-Cache gelöscht
    ipconfig /flushdns
     

Zur Umbegung:
Server: 2016 aktuellste Version
Clients: WINDOWS 10 aktuellste Version ( Die Installationen waren mal WIN 7 und wurden migriert!!!)

IP4 aktiviert

IP6 aktiviert

 

Beim Scan mit Advanced Port Scanner liefert der Rechner auf dem alles geht folgendes Ergebniss:

Dienst

Ausführlich

Port 135 (TCP)

Microsoft Windows RPC

Port 139 (TCP)

Microsoft Windows netbios-ssn

Port 445 (TCP)

 

 

Beim Scan mit Advanced Port Scanner liefern die Rechner auf denen die Rechner nicht angezeigt werden:

Dienst

Ausführlich

Port 135 (TCP)

Microsoft Windows RPC

Port 139 (TCP)

Microsoft Windows netbios-ssn

Port 445 (TCP)

Microsoft Windows 7 - 10 microsoft-ds workgroup: xxxxx


Interessant ist, dass manchmal ganz Kurz ein weiterer Rechner in der Liste auftaucht.
Der verschwindet dann aber sofort wieder.

 

Irgendwie glaube ich mich zu errinneren, dass ich mal was unter gpedit auf dem Rechner eingestellt habe auf dem alle Rechner angezeigt werden. Leider kann ich mich nicht mehr errinnern was ich da umgestellt habe.

 

 

 

 

Link to post

Vergiss es einfach. Der alte Browser-Dienst ist per default deaktiviert von und ist in Netzwerken mit mehr als einen Netzwerksegment vom WINS abhängig.

MS hat in Windows 10 irgendwas mit eingeführt, dass via IPv6 läuft. Allerdings auch nur im gleichen Segment.

Fazit: funktioniert i.d.R nicht mehr oder nur mit Einschränkungen.

  • Like 1
Link to post

Moin,

 

vergiss einfach die Netzwerkumgebung. Die hat noch nie so funktioniert, wie es dir vorschwebt. Ob ein Rechner dort angezeigt wird oder nicht, hat auch nichts damit zu tun, ob er erreichbar ist.

 

Gruß, Nils

 

  • Like 2
Link to post
vor 1 Minute schrieb NilsK:

Die hat noch nie so funktioniert

Nicht ganz. Mit WINS, einer Domäne und dem Browser-Dienst hat es mal funktioniert. In Windows 10 gibt es aber bisher keinen funktionierenden Ersatz.

  • Haha 1
Link to post

Hi,

 

irgendwo hatte ich hier in einem Beitrag mal ein wenig PowerShell Code zusammengetippt, was im Groben die "gute", "alte" Netzwerkumgebung "nachgebaut" hat. Finde den Beitrag aber leider nicht mehr. :)

 

Gruß

Jan

Link to post
vor 20 Minuten schrieb NilsK:

Ja, wir in der IT mögen eins wirklich nicht: Anforderungen.

Naja, deswegen haben wir uns ja auch angewöhnt, auf die Anforderung "because reasons" mit der Machbarkeitsaussage "it depends" zu reagieren ;-) 

  • Haha 2
Link to post

@info@vision4d.dehttps://www.mcseboard.de/topic/214493-netzwerkumgebung-nicht-alle-pcs-sichtbar/?do=findComment&comment=1368442

 

Die Google Suche ist da meistens hilfreicher. Wobei ich jetzt auch einiges probieren musste: "jan netzwerkumgebung inurl:mcseboard.de"

 

Aber generell, wäre es schon hilfreich über das "Warum?" zu sprechen. In der Regel gibt es bessere weitere Ansätze.

 

  • Confused 1
Link to post
vor 50 Minuten schrieb testperson:

@info@vision4d.dehttps://www.mcseboard.de/topic/214493-netzwerkumgebung-nicht-alle-pcs-sichtbar/?do=findComment&comment=1368442

 

Die Google Suche ist da meistens hilfreicher. Wobei ich jetzt auch einiges probieren musste: "jan netzwerkumgebung inurl:mcseboard.de"

Kann ich nicht bestätigen, die gleichen Stichworte und den passenden Operator ("AND") und das Ergebnis ist dabei ;-)

 

Link to post

SOOOOOdale :lool:

 

Jetzt habe ich die hoffentlich ultimative Lösung gefunden.

 

zu den ganz oben beschriebenen Punkten habe ich folgendes hinzugefügt:

 

  1.  Auf dem Domänencontroler habe ich die Rolle WINS-Server installier
  2. Auf allen Clients habe ich den Dienst "Computerbrowser" deaktiviert
    Vorraussetzung das der erscheint ist: Es muss in den "Windows-Features" unter "Unterstützung für SMB1.0/CIFS-Dateifreigabe
    die ersten zwei Einträge aktiviert sein.
     

Ich habe es jetz auf 7 Rechnern durchgeführt und auf 7 geht es jetzt.

Und das nachdem ich unzählige Seiten im Internet durchgearbeitet habe.

Danke für Eure Anregungen die in der Summe zum Erfolg geführt haben.

 

Gruß Ronald

 

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...