Jump to content

Empfohlene Beiträge

Hallo Zusammen,

ich habe Windows 2016 1607 (14393.2639) auf dem Wsus 10.0.14393.2007 läuft.

Seit dem 4.12 syncronisiert Wsus nicht mehr, siehe Fehlermeldung.

 

Fehler beim letzten Versuch zur Synchronisierung des Katalogs.

wsusservice und iis habe ich bereits neu gestartet, Speicherplatz ist auch ausreichend und es wurde auch kein Update oder so eingespielt.

 

Hat jemand eine Idee?

 

SoapException: Fault occurred
bei System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
   bei System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
   bei Microsoft.UpdateServices.ServerSyncWebServices.ServerSync.ServerSyncProxy.GetUpdateData(Cookie cookie, UpdateIdentity[] updateIds)
   bei Microsoft.UpdateServices.ServerSync.CatalogSyncAgentCore.WebserviceGetUpdateData(UpdateIdentity[] updateIds, List`1 allMetadata, List`1 allFileUrls, List`1& updatesWithSecureFileData, Boolean isForConfig)
   bei Microsoft.UpdateServices.ServerSync.CatalogSyncAgentCore.GetUpdateDataInChunksAndImport(List`1 neededUpdates, List`1 allMetadata, List`1 allFileUrls, Boolean isConfigData)
   bei Microsoft.UpdateServices.ServerSync.CatalogSyncAgentCore.GetAndSaveUpdateMetadata(List`1 updates)
   bei Microsoft.UpdateServices.ServerSync.CatalogSyncAgentCore.ExecuteSyncProtocol(Boolean

 

wsusutil checkhealth:

Protokollname: Application
Quelle:        Windows Server Update Services
Datum:         05.12.2018 09:45:24
Ereignis-ID:   10022
Aufgabenkategorie:7
Ebene:         Fehler
Schlüsselwörter:Klassisch
Benutzer:      Nicht zutreffend
Computer:      XXXXX
Beschreibung:
Fehler beim letzten Versuch zur Synchronisierung des Katalogs.
Ereignis-XML:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Windows Server Update Services" />
    <EventID Qualifiers="0">10022</EventID>
    <Level>2</Level>
    <Task>7</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2018-12-05T08:45:24.300347700Z" />
    <EventRecordID>7875</EventRecordID>
    <Channel>Application</Channel>
    <Computer>XXXXXXX</Computer>
    <Security />
  </System>
  <EventData>
    <Data>Fehler beim letzten Versuch zur Synchronisierung des Katalogs.</Data>
  </EventData>
</Event>

 

 

 

Liebe Grüße Goat

 

2018-12-05 08_36_00-MBKFRBU01 - MBKFRBU01 - Remotedesktopverbindung.jpg

bearbeitet von goat82
Fehlende Information

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

In der Datei SoftwareDistribution.log, die Datei liegt im Programmverzeichnis vom WSUS, findest Du weitere Informationen. Starte den kompletten Server doch mal durch.

 

Du kannst auch auf dem Server ein wsusutil checkhealth ausführen. Die EXE WSUSUTIL liegt im Tool Verzeichnis des Programmverzeichnisses vom WSUS. Gibt es Hinweise auf dem Gateway ins Internet zu dem Problem?

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Alles schon mehrmals gemacht.

  • wsusutil checkhealth -> Fehler 10022 siehe oben
  • Internet läuft einwandfrei.
  • Anbei die angeforderte Logdatei aus der ich auch nicht schlau werde: SoftwareDistribution.txt
  • Nach dem Versuch den Updatekatalog zu erreichen, erscheint die unten stehende Fehlermeldung CAPI2 im Log:

https://docs.microsoft.com/en-us/previous-versions/windows/it-pro/windows-server-2008-R2-and-2008/cc734021(v=ws.10)

  • Gemäß dem Link von MS oben ist hier alles richtig, siehe Log vss.txt

 

Hat hier jemand noch eine Idee?

 

 

Protokollname: Application
Quelle:        Microsoft-Windows-CAPI2
Datum:         04.12.2018 04:00:13
Ereignis-ID:   513
Aufgabenkategorie:Keine
Ebene:         Fehler
Schlüsselwörter:Klassisch
Benutzer:      Nicht zutreffend
Computer:      MeinServer
Beschreibung:
Fehler beim Kryptografiedienst während der Verarbeitung des "OnIdentity()"-Aufrufobjekts "System Writer".

Details:
AddLegacyDriverFiles: Unable to back up image of binary Microsoft-Verbindungsschichterkennungsprotokoll.

System Error:
Zugriff verweigert
.
Ereignis-XML:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Microsoft-Windows-CAPI2" Guid="{5bbca4a8-b209-48dc-a8c7-b23d3e5216fb}" EventSourceName="Microsoft-Windows-CAPI2" />
    <EventID Qualifiers="0">513</EventID>
    <Version>0</Version>
    <Level>2</Level>
    <Task>0</Task>
    <Opcode>0</Opcode>
    <Keywords>0x8080000000000000</Keywords>
    <TimeCreated SystemTime="2018-12-04T03:00:13.985934600Z" />
    <EventRecordID>7565</EventRecordID>
    <Correlation />
    <Execution ProcessID="1108" ThreadID="1824" />
    <Channel>Application</Channel>
    <Computer>Meinserver</Computer>
    <Security />
  </System>
  <EventData>
    <Data>

Details:
AddLegacyDriverFiles: Unable to back up image of binary Microsoft-Verbindungsschichterkennungsprotokoll.

System Error:
Zugriff verweigert
</Data>
  </EventData>
</Event>

 

bearbeitet von goat82

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
vor 30 Minuten schrieb goat82:

Alles schon mehrmals gemacht.

Danke für die Information im ersten Posting.

 

vor 30 Minuten schrieb goat82:

Anbei die angeforderte Logdatei aus der ich auch nicht schlau werde:

Falsch verstanden, ich hab die nicht angefordert, es war ein Hinweis für dich die Logdatei nach Fehlern abzusuchen. Gibt es Punkte in der Logdatei, die Du nicht verstehst? Falls ja, dann frag doch einfach.

 

vor 34 Minuten schrieb goat82:

Protokollname: Application
Quelle:        Microsoft-Windows-CAPI2
Datum:         04.12.2018 04:00:13
Ereignis-ID:   513
Aufgabenkategorie:Keine
Ebene:         Fehler
Schlüsselwörter:Klassisch
Benutzer:      Nicht zutreffend
Computer:      MeinServer
Beschreibung:
Fehler beim Kryptografiedienst während der Verarbeitung des "OnIdentity()"-Aufrufobjekts "System Writer".

Details:
AddLegacyDriverFiles: Unable to back up image of binary Microsoft-Verbindungsschichterkennungsprotokoll.

System Error:
Zugriff verweigert

https://support.microsoft.com/de-de/help/3209092/event-id-513-when-running-vss-in-windows-server

https://blog.blackseals.net/2017/11/30/capi2-meldet-513-zugriff-verweigert/

vor 37 Minuten schrieb goat82:

Internet läuft einwandfrei.

Danach hatte ich nicht gefragt.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
vor 2 Stunden schrieb Sunny61:

Gibt es Punkte in der Logdatei, die Du nicht verstehst?

1.)

2018-12-05 02:40:10.402 UTC    Info    WsusService.25    WsusTestKeys.PerformCheck    autest.cab signature is invalid
2018-12-05 02:40:10.402 UTC    Info    WsusService.25    WsusTestKeys.AreTestKeysAllowed    Server test key check: test keys are NOT allowed

2018-12-05 02:40:10.417 UTC    Info    WsusService.29    ServerCertificateValidator.ConfigChangedHandler    Update server configuration has changed. Sync against MU: True

 

Hier der Fehler, ich kann damit nichts anfangen:

2018-12-05 02:41:11.032 UTC    Error    WsusService.25    SoapUtilities.LogException    USS ThrowException: Actor = https://fe2.update.microsoft.com/v6/ServerSyncWebService/ServerSyncWebService.asmx, Method = "http://www.microsoft.com/SoftwareDistribution/GetUpdateData", ID=abb573d0-bc7d-4f22-ad23-ae1c0cad1743, ErrorCode=InternalServerError, Message=
   bei Microsoft.UpdateServices.Internal.SoapUtilities.LogException(SoapException e)

 

Habe diesen Workarround: https://support.microsoft.com/en-us/help/3209092/event-id-513-when-running-vss-in-windows-server

erfolgreich durchgeführt, die CAPI2 Meldung taucht beim Syncronisierungsversuch nun nicht mehr auf. Die Ursprüngliche Fehlermeldung 10022 Fehler bei der Synchronisierung ist aber leider weiterhin unverändert

 

bearbeitet von goat82

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Anscheinend kennt niemand das Problem?!

 

Ich bin nun einen Schritt weiter und hab das Problem seitens Microsoft gefunden .

Folgende Produkte habe ich angewählt: Windows 7,10, Office 2010-2013.

Folgende Klassifizierungen, siehe Bild.

Wähle ich alle Produkte außer Windows 7 ab, funktioniert es bestens.

Lasse ich alle 5 ursprünglichen Produkte aktiviert und wähle die 2 markierten Klassifizierungen ab, dann funktioniert es auch!

Alles andere endet im Fehler 10022.

Naja was nun? Ich habe nichts gemacht, und Wsus ohne die fehlenden 2 Klassifizierungen bringt ja auch nicht wirklich viel.

Immerhin weiß man nun woran es liegt, an Microdoof

 

image.png.5030cdb35b51e12a9b769fdcf9332afb.png

 

 

Hat jemand eine Idee, Biteeeeeee :-)

 

 

bearbeitet von goat82

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Da es auch noch viele andere betrifft, musst du warten bis es von MSFT eine Lösung gibt. Im englischen WSUS-Forum wurde das auch schon thematisiert. https://social.technet.microsoft.com/Forums/en-US/7c3e5c52-13b2-49db-a631-19e23ac7763c/wsus-2012r2-not-sycing?forum=winserverwsus

 

BTW: Es heißt immer noch Microsoft. Solches Bashing kannst Du dir hier komplett sparen.

bearbeitet von Sunny61

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Naja, sorry wenn ich mich von MS nicht blenden lasse. Die Produkte von MS finde ich größtenteils gut, doch MS ist unverschämt kundenunfreundlich.

Wer es als Marktführer nach ettlichen Anläufen es immer noch nicht hinbekommt ein Featureupdate erst zu testen, bevor es auf die Menschheit losgelassen wird und es beim nächsten Mal immernoch gleich macht, der tut mir leid. Ebenso wäre es von einem Marktführer zu erwarten, dass er bei der Produktentwicklung auch mal die Kundenwünsche/Akzeptanz abfrägt, bevor dem Kunden etwas aufdrängt nur damit er ein neues Produkt verkaufen kann und hinterher alles wierder rückgämgig macht. Ich hab das Gefühl das die Mitarbeiter extrem unter Druck stehen und alle 2 Jahre etwas neues liefern müssen, damit die Verkaufszahlen stimmen. Ob es dem Kunden passt oder vom Markt nicht richtig angenommen wird ist egal, hauptsache die Mitarbeiter bekommen ihren Boni :-)

Ich bin nicht gegen MS, da ich ja selbst "abhängig gemacht wurde" oder Teil der freiwilligen Abhängigkeit der Gewohnheit bin.

Kundenorientierung ist hier jedoch überhaupt nicht der Fall. (Zumindest nicht für den Endkunden ohne teuren "Gold" status/SLA).

Das zeigt die vielen Fehler auf (Vista, Windows 8 ohne Starmenu, IE, Edge, ettliche zu schnell freigegene Updates, undurchsichtiges Lizenzmodelle, selbst für Experten eine Herausforderung uvm.)

 

Und nun soll ich 3 Monate warten ohne jegliche Updatemöglichkeit. Wenn ich mir am Ende was einfange, dann haftet da auch niemand.

 

bearbeitet von goat82

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

In Ordnung, das verstehe ich. Den Link brauche ich nicht, da er sowierso nicht von MS beachtet wird.

 

Weißt du ob es bei MS eine Forum oder sowas gibt zu den großen Baustellen wo man sehen kann ob noch etwas getan wird, bzw. wo man den aktuellen Status einsehen kann ?

Meine berechtigte Angst ist ja, dass nur sehr wenige User von meinem Problem betroffen sind. In diesem Fall wird dann höchstwahrscheinlich nichts passieren oder auf ein Upgrade auf Server 2019 verwiesen.

 

Danke für den Beitrag im Link. Ich kann nun wieder Windows 7 erfolgreich syncronisieren. Dafür musste ich aber Office 2013 und Windows 10 aber komplett von Wsus abwählen. Immerhin haben wir nur 15 W10 Clients.....

Mal sehen ob und wann es wieder läuft :-)

bearbeitet von goat82

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
vor 2 Stunden schrieb goat82:

Weißt du ob es bei MS eine Forum oder sowas gibt zu den großen Baustellen wo man sehen kann ob noch etwas getan wird, bzw. wo man den aktuellen Status einsehen kann ?

Meine berechtigte Angst ist ja, dass nur sehr wenige User von meinem Problem betroffen sind. In diesem Fall wird dann höchstwahrscheinlich nichts passieren oder auf ein Upgrade auf Server 2019 verwiesen.

Steht alles im Link zu den Technet Foren. Je mehr sich dort darüber auslassen, desto mehr Druck wird aufgebaut. Es sind sehr viele von dem Problem betroffen.

 

Wenn Du Updates haben möchtest, die du über die Synchronisierung nicht kriegst, dann kannst Du sie ja auch importieren in den WSUS. Auf dem WSUS selbst die WSUS Konsole starten und den IE als Standard Browser machen. Jetzt in der WSUS-Konsole mit Rechts auf Updates klicken und Updates importieren auswählen. Schon kannst Du dir Updates aus dem Catalog downloaden und zur Installation freigeben.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hmm, trifft das nur auf Server 2016 zu? Bei 2012R2 hatte ich diese Probleme bis jetzt jedenfalls noch nie.

Falls 2012R2 nicht betroffen ist, wie wärs mit einem Downgrade auf Server 2012R2? Der ist ja noch bis fast ende 2023 supported.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Ich hatte das Problem auch bei unserem WSUS auf dem Server 2012R2. Eine Neuinstallation auf 2016-Basis und der WSUS funktioniert wieder ;-) Bin mal gespannt was bei Dir raus kommt.
 

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Erstelle ein Benutzerkonto oder melde dich an, um zu kommentieren

Du musst ein Benutzerkonto haben, um einen Kommentar verfassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Es ist einfach!

Neues Benutzerkonto erstellen

Anmelden

Du hast bereits ein Benutzerkonto? Melde dich hier an.

Jetzt anmelden

×