Jump to content
RobDust

Das Sicherheitszertifikat ist abgelaufen oder noch nicht gültig Exchange bei Outlook mit Exchange 2010 beim SBS 2011

Recommended Posts

Moin! 

 

Die Meldung bekomme ich oben... 

 

Im IIS habe ich dann unter "Serverzertifkate" ein neues Zertifikat mit dem selben Namen erstellt. (Das Alte abgelaufene ist noch vorhanden)

Leider schmeißt Outlook immer noch die Meldung raus. Wie krieg ich nun Outlook dazu, dass neue Zertifikat zu nutzen? Oder einfach nicht mehr die blöde Meldung anzuzeigen...

meldung.PNG

Share this post


Link to post
Share on other sites

Hi @Sunny61, habe ich genau so gemacht... leider keine Änderung. Der Fehler in Outlook kommt immer noch,.

 

Hab jetzt mal an dem Client die Zertifikate in der MMC Konsole anzeigen lassen... unter eigene Zertifikate und Stammzertfikate seh ich die neuen Zertifikate trozdem bemängelt das Outlook noch das alte Zertifikat... boar :thumb2:

Edited by RobDust

Share this post


Link to post
Share on other sites

Sag bloß nicht, was du gemacht hast und welche Informationen im Zertifikat stehen, oder welche Art von Zertifikat verwendest. Das könnte glatt dazu verführen, dir helfen zu wollen. ;)

Share this post


Link to post
Share on other sites
vor 1 Stunde schrieb NorbertFe:

Sag bloß nicht, was du gemacht hast und welche Informationen im Zertifikat stehen, oder welche Art von Zertifikat verwendest. Das könnte glatt dazu verführen, dir helfen zu wollen. ;)

Im IIS habe ich  unter "Serverzertifkate" ein neues Zertifikat mit dem selben Namen erstellt. (Das Alte abgelaufene ist nicht mehr vorhanden, warum es das gab weiß ich nicht, hat mein Vorgänger erstellt.) ... das sollte so ein selbsigniertes Zertikat glaub ich sein.

Wie krieg ich einfach das alte Zertifkat aus Outlook raus, welches sich da immer meldet?
 

Edited by RobDust

Share this post


Link to post
Share on other sites

Dazu gibt es beim SBS die Assistenten, Exchange kann das auch.

 

Was gibt denn die Exchange Poweshell bei Get-ExchangeCertificate aus?

 

Finger weg vom IIS

Share this post


Link to post
Share on other sites

Kann ich nur zustimmen. Finger weg vom IIS wenn man nicht weiß, wie und was man dort konfigurieren soll. Get-Exchangecertificate ist der richtige Weg. Dann schauen wir weiter.

Share this post


Link to post
Share on other sites

@NorbertFe

und @Nobbyaushb

 

PS C:\Users\administrator.Domain> Get-ExchangeCertificate


Die Benennung "Get-ExchangeCertificate" wurde nicht als Name eines Cmdlet, einer Funktion, einer Skriptdatei oder eines ausführbaren Programms erkannt. Überprüfen Sie die Schreibweise des Namens, oder ob der Pfad korrekt ist (sofern enthalten), und wiederholen Sie den Vorgang.

 

Bei Zeile:1 Zeichen:24
+ Get-ExchangeCertificate <<<<
    + CategoryInfo          : ObjectNotFound: (Get-ExchangeCertificate:String) [], CommandNotFoundException
    + FullyQualifiedErrorId : CommandNotFoundException

 

Das gibt es aus...

Share this post


Link to post
Share on other sites

Hi Rob,

hast du die Abfrage lokal auf deiner Kiste gestartet?
 

Starte die Abfrage mal direkt auf dem Exchange-Server in der entsprechenden PowerShell Konsole...

 

Gruß

Christian

Share this post


Link to post
Share on other sites

ok das ging nun, 

 

folgendes habe ich erhalten: Bringt euch die Ausgabe vom Befehl weiter?

 

Es geht um das erste remote.meinedomain.de Zertifikat... dies war abgelaufen, dann habe ich ein neues mit selben Namen erstellt, sowie das alte Zertifikat am Server gelöscht, und auch im "Zertifkatspeicher" des Clients - mmc -> Zertifikate (dort war es auch). Ich brauch das Zertifikat überhaupt nicht, meiner Einschätzung nach.... (Keine Ahnung was mein Vorgänger hier vor hatte)

 

Aaaaber in Outlook scheint immer noch das alte "verankert" zu sein, wie ihr unten erkennen könnt.
(Wenn ich da auf "Zertifikat anzeigen" klicke, dann sehe ich noch die Details von dem alten)
Auch div. Neustarts haben nicht geholfen. Auch das manuelle hinzufügen des neuen Zertifikates nicht (über Export im IIS und Import in den "Zertifkatspeicher" des Clients.

Kann man nicht irgendwie durch den registry Eintrag oder so die Abfrage "umgehen"? Oder ihm das alte Zertifikat austreiben? :-)

power.PNG

meldung2.png

Share this post


Link to post
Share on other sites
vor 1 Minute schrieb RobDust:

Ich brauch das Zertifikat überhaupt nicht, meiner Einschätzung nach.... (Keine Ahnung was mein Vorgänger hier vor hatte)

Offensichtlich ist deine Einschätzung falsch und "keine Ahnung" stimmt. ;)

Das brauchst du u.a. für den Zugriff auf die Free/Busy Informationen am Exchange. Und deswegen solltest du das neue Zertifikat, dessen Thumbprint du sinnloserweise ja ausgeblaut hast einfach mal an den IIS binden:

 

Enable-Exchangezertificate -thumbprint sdfsjfsdf9 -services iis

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Werbepartner:



×
×
  • Create New...