Jump to content

SBS 2011 Netzlaufwerke per GPO


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Ich versuche seit Tagen die Netzlaufwerke über ein Login Script per GPO einzubinden und es klappt nicht, das Script wird nicht ausgeführt. Wenn ich das Script manuell starte werden die LAufwerke verbunden und auch wenn ich es direkt dem Benutzer eintrage . Auf dem Server selbst werden die Laufwerke  auch nicht verbunden.

 

Es sind Windows 7 und XP Clients.

 

Bin so vorgegangen:

 

Gruppenrichtlinien Verwaltung - neues Objekt erstellt "Logindatei"

verknüpft mit SBS Users   da sind auch alle User drin incl. Admins

Objekt bearbeiten - Benutzerkonfiguration - Windowseinstellungen Scripte - Anmelden

anzeigen und habe dort die lobin.bat reinkopiert

dann auf hinzufügen und habe die login.bat  hinzugefügt

 

( habe auch schon versucht über netzwerk domäne.local netlogon auch ohne erfolg )

 

gpupdate /force auf server und clients

 

Die login.bat ist sehr einfach   net use z: \\servername\daten

 

Was mache ich falsch, ich habe schon diverse Beitzräge gelsen gegoogelt und nichts hilft.

Link to comment

AUf den Clients steht nichts im Protokoll, weder Windows 7 noch XP. Ich habe es mit Standarduser und Domainadmins getestet, beides war ohne Erfolg.

 

Wenn ich Norbert richtig verstehe, fehlen die Richtlinien im Server 2008 und müssen nachinstalliert werden.

 

Was ich nicht verstehe wenn ich mich am Server selbst als Domainadmin anmelde funktioniert es auch nicht, habe eine weiteren Admin angelegt bei dem greift die Richtlinie auf dem Server selbst  und die Laufwerke werden verbunden, aber nicht wenn ich mich dem dem Adminaccount auf dem Client anmelde.

 

Wenn ich die Richtlinie auf gleiche Weise auf dem SBS 2003 anlege funktioniert es überall auch mit Windows 7.

Link to comment

habe mir die Seite durchgelesen, die Updates auch installiert, komme jedoch nicht weiter, deshalb verstehe ich es so. Habe auch Richtlinien sichtbar aktiviert und sehe nichts ( Pausen sind auch eingefügt )

 

Komisch ist dass auf Server 2008 alles funktioniert, auf dem SBS 2011 auf gleiche Weise nicht. Wenn ich mich nicht irre ist ein Server 2008 als Basis.

Edited by Grzesiek
Link to comment

Hallo,

 

wird die Login.bar denn überhaupt aufgerufen nach dem Fertigstellen der Netzwerkwerkverbindung und der Anmeldung des Users, ist die Gruppenrichtlinie aktiviert "..... immer auf das Netzwerk warten.", wird die Richtlinie auf dem Client wirksam? Wurde das Ausführen der Bat mal sichtbar gemacht, und/oder eine Kontrollmechanismus eingebaut z.B. Erzeugen einer Datei, zusätzlich ein Pause eingebaut?

Edited by lefg
Link to comment

ich vermute dass es an den Benutzerrechten liegt, da ich die Login.bat wie auf http://www.petri.co....server-2008.htm

 

beschrieben nicht reinkopieren kann. Ich muss über c:\windows\sysvoll..... gehen damit ich das Script dort reinsetzen kann

 

 

 

 

 

 

Nun, der Client muss doch das Skript auf dem Server oder der Domäne aufrufen aus einem freigegebenen Verzeichnis; das Verzeichnis Skripts ist als Netlogon freigegeben.

 

 

 

Bei mir (nicht SBS) sieht der Aufruf also so aus:

 

\\Servername\NETLOGON\Login.bat

 

oder

 

\\Domänenname\NETLOGON\Login.bat

 

Bei Konfigurieren der GPO gehe ich also mit dem Explorer z.B. über das Netzwerk (Netzwerkumgebung, Gesamtes Netzwerk, Domäne) auf den Server, in NETLOGON, suche mir dort die Batch in binde sie in die GPO ein. Bei einem einzelnen DC ist es so ausreichend, bei mehreren DC`s sollte gewährleistet sein, dass es mit jeden DC funktioniert, deshalb den Namen des DC durch den der Domäne ersetzen.

Edited by lefg
Link to comment
Ich muss über c:\windows\sysvoll..... gehen damit ich das Script dort reinsetzen kann

 

Verstehe ich das jetzt richtig, dass der Pfad zum Skript in der GPO "c:\windows..." ist? Das kann ja dann auch nicht funktionieren. Darauf wurde ja auch schon ein paar mal hingewiesen.

 

Wenn Du nicht auf die Sysvol-Freigabe kommst, dann schau Dir mal die Berechtigungen genauer an.

Link to comment

ich vermute dass es an den Benutzerrechten liegt, da ich die Login.bat wie auf http://www.petri.co....server-2008.htm

 

beschrieben nicht reinkopieren kann. Ich muss über c:\windows\sysvoll..... gehen damit ich das Script dort reinsetzen kann

 

Dann fangen wir mal Adam und Eva an. ;) Du hast eine Batchdatei, die liegt irgendwo im Dateisystem. In dem GPO der Login.bat willst du nun die Login.bat integrieren, an dem Punkt wo Du die Batch hinzufügen mußt, klickst Du auf Durchsuchen und navigierst zum Ort im Dateisystem in dem die Batchdatei liegt. Fertig. Etwas anderes brauchst Du normalerweise nicht zu machen.

Link to comment
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...