Jump to content

Windows 2019 Terminalserver - Startmenü der Benutzer


Recommended Posts

Hallo zusammen,

 

ich habe ein Problem mit dem Startmenü der RDS Nutzer von meinem zwei Windows 2019 RDS Servern. 

 

mein setup ist wie folgt:

 

* 1 x ADS Windows 2019 Server

* 2 x RDS Windows 2019 Server

* die beiden RDS Server sind über openvpn (1Gbit Leitung) an die Domäne des ADS Server erfolgreich angebunden. 

* die Profile der Benutzer speichere ich als .vhdx auf dem ADS Server

* GPO für einige Operationen wurden den jeweiligen OU's zugewiesen

 

Soweit funktioniert alles wie es soll. AD RDS Nutzer können sich an beiden RDS Servern anmelden, ich kann über GPO Netzlaufwerk mappen, Drucker zuweisen oder Verknüpfungen auf dem Desktops der RDS Server Benutzer hinzufügen und wegnehmen. Soweit so gut.

 

An was ich mir gerade allerdings die Zähne ausbeiße ist, dass das Startmenü der RDS Benutzer "kaputt" ist. Mit kaputt meine ich, dass die Kacheln und dir Programmordner nur kryptisch dargestellt werden (siehe Bild). Wenn ich als Benutzer (nach der Anmeldung auf einem RDS Server) den Befehl  "gpupdate /force"  ausführe, dann erscheint das richtige und korrekte Startmenü mit Programme und Kacheln.

 

Hat jemand eine Idee wie ich das Problem des kaputten Startmenü's lösen kann? ...bzw. wo ein Konfigurationsparameter gesetzt werden kann/muss?

 

 

rds-nutzer-startmenue.png

Link to post

Hi,

 

vor 21 Stunden schrieb zero7:

* die beiden RDS Server sind über openvpn (1Gbit Leitung) an die Domäne des ADS Server erfolgreich angebunden. 

* die Profile der Benutzer speichere ich als .vhdx auf dem ADS Server

gemountete VHDX Files über eine WAN Strecke (oder auch generell per 1GBit im LAN) halte ich für keine gute Idee. Nutzt du FSLogix Profile Container oder Profile Disks?

 

Möchtest du den Usern ein Startmenü vorgeben? Falls ja, was hast du da denn bereits gemacht/versucht?

 

Gruß

Jan

Link to post

Hallo Jan,

 

ich nutze Profile Disks. An und für sich "läuft" es mit den UPD's - nur eben das Startmenü gibt mir rätsel auf...

 

Das Startmenü habe ich mir mit einem User zusammen gebaut und danach per 

Export-StartLayout –path <path><file name>.xml

 

exportiert. Danach habe ich es auf dem ADS auf der "NETLOGON Freigabe" für die Nutzer per GPO zur Verfügung gestellt.

Die Benutzer können über den entsprechenden UNC Pfad die Startmenü XML Datei erreichen und lesen - Berechtigungen sollten somit passen.

 

Der GPO Eintrag mit dem UNC Pfad wurde hier erstellt:   Benutzerkonfiguration -> Richtlinien -> Administrative Vorlagen -> Startmenü und Taskleiste -> Startlayout

 

Wenn sich ein Nutzer anmeldet, bekommt er das "kaputte" Startmenü - macht der Nutzer ein gpupdate /force  wird das korrekte Startmenü angezeigt/geladen

 

Druch Trial and Error ist mir folgendes aufgefallen:

Existiert für einen Benutzer noch keine (UPD) Profile Disk, also quasi bei der ersten Anmeldung, dann bekommt der Nutzer das korrekte Startmenü. Melde ich mich mit dem Benutzer ab - warte kurz 20 Sekunden - und melde mich wieder an, ist das Startmenü kaputt. Durch ein gpupdate /force ist es dann wieder da.

 

 

 

Edited by zero7
Link to post
  • 2 weeks later...

Wenn das Startmenü so bleiben soll, kannst du es auch lokal pro Server vorgeben:

Import-StartLayout -LayoutPath .\startlayout1.xml -MountPath C:\

 

Dann bist du nicht von der Gruppenrichtlinie abhängig. Es wird bei der Profilerstellung angewendet.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...