Jump to content

Exchange Security Updates Mai 2021


Recommended Posts

Posted (edited)

Ich hab grad 3 edge und 3 Mailboxserver durch. Dauert beim Edge etwa 15 Minuten und bei Mailboxservern so um die 30 Minuten auf halbwegs moderner Hardware. Alles Exchange 2019.

Edited by NorbertFe
  • Thanks 1
Link to post
vor 3 Minuten schrieb NorbertFe:

Ich hab grad 3 edge und 3 Mailboxserver durch. Dauert beim Edge etwa 15 Minuten und bei Mailboxservern so um die 30 Minuten auf halbwegs moderner Hardware. Alles Exchange 2019.

Danke Dir für die Info!

Link to post
vor 9 Minuten schrieb NorbertFe:

Und wie sieht’s aus? 

Moin,

das würde mich auch interessieren, vor allem was genau passiert ist.

Ich habs dann gestern auch noch auf 5 Servern installiert ohne irgendwelchen impact.

 

Link to post

Die Known Issues im KB unterscheiden sich von denen auf dem Exchange Team Blog. :-)

 

Released: May 2021 Exchange Server Security Updates - Microsoft Tech Community

Zitat

Known issues in May 2021 security updates


During the release of April 2021 SUs, we received some reports of issues after installation. The following issues reported for April 2021 SUs also apply to May SUs and have the following workarounds:

  • Administrator/Service accounts ending in ‘$’ cannot use the Exchange Management Shell or access ECP. The only workaround at this time is to rename Admin accounts or use accounts with no ‘$’ at the end of the name.
  • Some cross-forest Free/Busy relationships based on Availability address space can stop working (depending on how authentication was configured) with the error: “The remote server returned an error: (400) Bad Request.” Please see this KB article for how to work around this problem.
  • After application of the Exchange Server April or May security updates, cmdlets executed against the Exchange Management Console using an invoked runspace might fail with the following error message: The syntax is not supported by this runspace. This can occur if the runspace is in no-language mode. Please see this KB article for more information.

 

Description of the security update for Microsoft Exchange Server 2019, 2016, and 2013: May 11, 2021 (KB5003435)

Zitat

Issue 1

When you try to manually install this security update by double-clicking the update file (.msp) to run it in Normal mode (that is, not as an administrator), some files are not correctly updated.

When this issue occurs, you don’t receive an error message or any indication that the security update was not correctly installed. However, Outlook Web Access (OWA) and the Exchange Control Panel (ECP) might stop working.

This issue occurs on servers that are using User Account Control (UAC). The issue occurs because the security update doesn’t correctly stop certain Exchange-related services.

 

Issue 2

Exchange services might remain in a disabled state after you install this security update. This condition does not indicate that the update is not installed correctly. This condition might occur if the service control scripts experience a problem when they try to return Exchange services to their usual state.

To fix this issue, use Services Manager to restore the startup type to Automatic, and then start the affected Exchange services manually. To avoid this issue, run the security update at an elevated command prompt. For more information about how to open an elevated Command Prompt window, see Start a Command Prompt as an Administrator.

 

Issue 3

When you block third-party cookies in a web browser, you might be continually prompted to trust a particular add-in even though you keep selecting the option to trust it. This issue occurs also in privacy window modes (such as InPrivate mode in Microsoft Edge). This issue occurs because browser restrictions prevent the response from being recorded. To record the response and enable the add-in, you must enable third-party cookies for the domain that's hosting OWA or Office Online Server in the browser settings. To enable this setting, refer to the specific support documentation for the browser.

 

Issue 4

When you try to request free/busy information for a user in a different forest in a trusted cross-forest topology, the request fails and generates a "(400) Bad Request" error message. For more information and workarounds to this issue, see "(400) Bad Request" error during Autodiscover for per-user free/busy in a trusted cross-forest topology.

 

  • Like 1
Link to post
vor 28 Minuten schrieb NorbertFe:

Und wie sieht’s aus? 

Alles was ich weiß und kann hat nicht geklappt.

Habe das OS (ohne die DB´s) mit Veeam zurückgeholt, dann wollte er die VM nicht starten und musste mit dem icacls die Rechte setzten (war nicht das erste mal...)

Bootet gerade, ich berichte...

Jetzt wird es ganz schräg - ich habe die OS-Platte aus dem Backup vom Montag wiederhergestellt, hat immer geklappt.

Er kann schon die Exchange Shell mit dem o.g. Fehler nicht starten.

Mein Filter sagt aber, die Mails laufen (zumindest rein) ich habe nur keinen Zugriff, weder mit Outlook noch mit OWA, da geht zwar das login aber dann weißes Fenster.

Nun denn.... :-(

Link to post
vor 18 Stunden schrieb Nobbyaushb:

Mir hat es einen Server zerlegt, natürlich meinen eigenen...:traene:

Ich versuche jetzt noch eine Sache, wenn das nicht klappt hole ich den aus den Backup zurück

 

Murphy würd ich sagen. ;)

Habe jetzt 2x Exchange 2013 und 2x Exchange 2016 und 3x 2019 noch zusätzlich, alle ebenfalls ohne Probleme. Nur für die, die sich das immer 3x überlegen. Vorab ein Backup kann wie man sieht trotzdem nicht schaden.

Link to post
vor 51 Minuten schrieb NorbertFe:

Habe jetzt 2x Exchange 2013 und 2x Exchange 2016 und 3x 2019 noch zusätzlich, alle ebenfalls ohne Probleme. 

 

.... um die Datenbasis für die Statistik noch etwas zu verbreitern: bei mir 2 x 2019 ohne Probleme.  :thumb1: ;-)

Link to post
vor 13 Stunden schrieb testperson:

Ist in diesem "Potpourri der guten Laune" evtl. noch was bei, was du noch nicht kanntest: Repair failed installations of Exchange Cumulative and Security updates - Exchange | Microsoft Docs

 

Ich habe den Beitrag erst vor kurzem entdeckt und kannte den gar nicht. :-)

Den kannte ich in der Tat auch nicht, ist jetzt auf meiner Link-Liste!

 

Um das Thema von heute Nacht bzw. heute Morgen abzuschließen, nach dem Restore des Servers mussten noch mittels icacls die Rechte auf der vhdx abgepasst werden.

Dann nach dem (langen) Boot noch vier der fünf IIS Bindungen geändert und iisreset alles wieder hübsch.

Nächste Aufgabe Migration, entweder Soft-Swing auch auf Exchange 2016 auf Server 2019 oder gleich auf 2019/2019 - ich überlege noch.

Bei 2016 geht die Suche wenigstens teilweise….

 

:-)

  • Like 1
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...