Jump to content
M. Bohlmann

Exchange 2010 Mailrouting über stillgelegte Public Folder DB?

Recommended Posts

Hi Leute,

ich bin bissel mit meinen Debugfähigkeiten am Limit angekommen und suche neuen Input zu einem Phänomen beim Mailrouting

von emailaktivierten öffentlichen Ordnern. Das Setup ist sehr ungewöhnlich und wurde nicht durch mich "verbrochen", ich kämpfe da

auch an anderen Stellen immer mal wieder mit seltsamen Phänomenen.

Im Kern geht es darum:

Wir haben einen DAG aus 2 Ex2010, die auch beide ein PF-DB haben, sowie eine sehr umfangreiche PF Struktur von mehreren

100 Ordnern, viele davon emailaktiviert. Bei einer kürzlich durchgeführten Migration wurden von mir aus einer externen Exchange

Struktur Postfächer und auch Public Folders mittels eines zusätzlich danebengestellten Ex2010 übernommen (mit Code2 für Exchange).

Das hat den Grund, dass ich den DAG nicht direkt anbinden konnte für die Migration. Wir haben also quasi einen Umweg über einen

3. Exchange 2010 genommen, den ich in die Domäne neben den DAG installiert habe. Die Migration der Postfächer war soweit

unspektakulär, diese befinden sich mittlerweile in einer neuen Datenbank auf dem DAG, die MigrationsDB auf dem 3. Server ist

ausgehängt. Nun habe ich vor ca. 4 Wochen die öffentlichen Ordner auf den DAG verschoben. Gemacht habe ich das (wie eigentlich

immer) mit den entsprechenden PF Skripten.

Zunächst habe ich die beiden DAG Server als Replikatserver auf den PF hinzugefügt (AddReplicaToPFRecursive.ps1) und 4 Wochen

abgewartet (die Struktur ist sehr gross, wie gesagt). Vor ca. 4 Wochen habe ich dann alle Replica vom 3. Server auf einen der beiden

DAG Server verschoben (MoveAllReplicas.ps1) und wieder 2 Wochen gewartet.

Eine Prüfung der aktuellen Replica zeigt auch korrekterweise nur noch die beiden DAG Server an, der 3. Server ist da nicht mehr enthalten.

Auf dem 3. Server selber ist ein Replikat nach MoveAllReplicas.ps1 verblieben, was schon mal passieren kann, aus welchen Gründen auch

immer, get-PublicfolderStatistics -server ex3 zeigt also noch einen verbliebenen Public Folder an. Den gibt es aber auch auf ex1 und ex2,

dort hat er mittlerweile auch mehr Elemente, also gehe ich davon aus, dass das irrelevant ist.

 

Jetzt fängt aber der nicht so lustige Teil an.

Ich habe die PF DB auf dem ex3 ausgehängt  - und, da ich ein vorsichtiger Mensch bin, ein paar Tage abgewartet.

Nach einigen Tagen hatten wir dann plötzlich Mails in einer Queue auf dem ex3, die alle an emailaktivierte öffentliche Ordner adressiert

waren, die vorher in der PF DB auf dem ex3 residierten. Hänge ich die DB wieder ein, leert sich die Queue. Ich finde den ex3 in keiner

Stelle der Konfig mehr, ich habe da mehrfach alles links und rechts gemacht. Die Benutzer können auch auf alle Public Folder zugreifen,

wenn die PF DB auf dem ex3 ausgehängt ist, sie können halt nur keine Mails dahin schicken.

Mir sind leider keine forensischen Mittel mehr bekannt, mit denen ich den Mailfluss tracen und sinnvoll debuggen kann, damit ich irgendwie

dahinterkomme, an welcher Stelle in der Konfig diese eigentlich leere PF DB für eine Zustellung einer Mail an einen öffentlichen Ordner

benötigt wird, der selbst eigentlich auf ex1 oder ex2 liegt. Ich brauche also ein wenig Schwarmwissen :-)

 

Share this post


Link to post
Share on other sites
Am 17.5.2019 um 16:20 schrieb Nobbyaushb:

Sowas hatte ich auch mal bei einem Kunden, wenn ich mich recht entsinne, wurde ein Ticket bei MS aufgemacht (ist schon was her...)

 

Welchen Stand haben denn die 2010er in der DAG?

 

 

Die sind alle aktuell. Ich hatte die hochgezogen vor der Migration.

 

Share this post


Link to post
Share on other sites
vor 1 Stunde schrieb tesso:

Bist du sicher das er mit dem moven der PF schon fertig war? Das klingt nicht so.

Eigentlich schon. Als ich nach 14 Tagen nach MoveAllReplicas.ps1 gescahut habe, war nur noch ein Ordner vorhanden (get-publicfolderstatistics), dieser befand sich aber bereits auf dem DAG und hatte dort auch mehr Elemente. Ich habe danach noch 3 Tage zugewartet, weil ich auch erst dachte, der ist noch nicht fertig - es hat sich aber in den 3 Tagen gar nichts mehr am Ergebnis geändert. Hänge ich die PF DB auf dem ex3 aus, so kann man ganz normal auf diesen Ordner zugreifen, daher gehe ich davon aus, dass der auch rübergewandert ist, nur halt der Move nicht sauber abgeschlossen werden konnte. Das ist an sich nix Ungewöhnliches, das hatte ich auch schon an anderer Stelle. Das Interessante ist ja, dass Mails an Ordner nicht zugestellt werden, die definitiv nicht mehr auf dem ex3 liegen - erst wenn ich die PF DB dort wieder einhänge, gehen die aus der Queue auf dem ex3 raus und werden in die Ordner auf ex1 und ex2 zugestellt.

Share this post


Link to post
Share on other sites

Share this post


Link to post
Share on other sites

Hi 

 

auch wenn ich lange keinen 2010er mehr betreut habe, im Hinterkopf habe ich irgendwie, dass die Public Folder DB nicht innerhalb einer DAG liegen sollte (darf?)

 

Gruss

J

Share this post


Link to post
Share on other sites
vor einer Stunde schrieb MrCocktail:

Hi 

 

auch wenn ich lange keinen 2010er mehr betreut habe, im Hinterkopf habe ich irgendwie, dass die Public Folder DB nicht innerhalb einer DAG liegen sollte (darf?)

 

Gruss

J

Nunja, da würde sich mir die berechtigte Frage stellen, wo sie denn sonst liegen sollte ;-)

Ist ja beim 2010 "nur" eine zusätzliche DB, die Replikation stellt man halt durch die PF Replica sicher, nicht durch die DAG Features.

Share this post


Link to post
Share on other sites
vor 18 Stunden schrieb tesso:

 

Gute Quellen, sowas hab ich gesucht, danke dir!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...