Jump to content
Melde dich an, um diesen Inhalt zu abonnieren  
borabora

„Outlook kann den Pfad zum Archiv nicht finden“.

Empfohlene Beiträge

Hallo,

 

folgendes Problem:

neuerdings kommt bei meinem Client immer kurz nach der Anmeldung an der Domäne, „Outlook kann den Pfad zum Archiv nicht finden“. Das Archiv liegt auf einem Netzlaufwerk. In dem angezeigten Fenster muss ich das Archiv dann jedes Mal auswählen und ok klicken (Bild). Das ist lästig. Irgendwie kommt womöglich das mappen der Netzlaufwerke (insgesamt 4 ) der Anmeldung nicht hinterher. Ich benutze ein einfaches Anmeldeskript.

In g: liegt das Outlook Archiv.

 

@Echo off

net use * /delete /yes

net use g: /d

net use g: \\R1.xxxxx.local\User\%username%

net use k: /d

net use k: \\R1.xxxxx.local\Daten

net use o: /d

net use o: \\R56.xxxxx.local\Prog

net use v: /d

net use v: \\R44.xxxxx.local\Anwendung

exit

 

Client:Win7 + Outlook 2010

Domäne: Win 2008 R2

Exchange Srv 2010

 

Gibts eine Möglichkeit das abzustellen ?

 

Vielen Dank für eure Hilfe

Gruß Wolf

post-64537-0-04344300-1410943666_thumb.jpg

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Und bis du umgestellt hast, kannst Du wie folgt vorgehen:

 

Schließe Outlook, gehe in die Maileinstellungen der Systemsteuerung und passe den Pfad in dem Profil an. Dass sollte funktionieren.

 

Aber überdenke kurzfristig Euer Konzept!

 

PST-Dateien solltet ihr nicht mehr verwenden

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

 

@Echo off

net use * /delete /yes

net use g: /d

net use g: \\R1.xxxxx.local\User\%username%

net use k: /d

net use k: \\R1.xxxxx.local\Daten

net use o: /d

net use o: \\R56.xxxxx.local\Prog

net use v: /d

net use v: \\R44.xxxxx.local\Anwendung

exit

Warum trennst Du erst mit net use * /d alle Laufwerke und danach jedes einzelne noch mal? Besser wäre, nur fehlerhafte Zuordnungen einzeln zu bearbeiten (erst trennen, wenn erforderlich, dann korrekt verbinden). Den Rest hätte Windows dann schon "in Verbindung"...

 

Das mit "not supported" stimmt natülich auch, funktionieren tut es trotzdem, wenn man das Laufwerk nicht einfach mit Gewalt wegzieht, um es danach dann neu zu verbinden...

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Es ist aber nicht nur nicht supported, weils mal nicht da sein könnte. Hab schon häufiger die ekligsten Probleme gesehen diesbezüglich. Man sollte das nicht abtun. Die die das trotzdem einsetzen, sollten wissen, dass so eine pst auch kompletten Schrott enthalten kann.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Danke für eure Antworten.

 

 

ACK - wie immer, man muß halt wissen, was man tut, und dann auch mit den Konsequenzen leben :cool:

 

Was ist denn ACK ?

 

 

@
 

Warum trennst Du erst mit net use * /d alle Laufwerke und danach jedes einzelne noch mal? Besser wäre, nur fehlerhafte Zuordnungen einzeln zu bearbeiten (erst trennen, wenn erforderlich, dann korrekt verbinden). Den Rest hätte Windows dann schon "in Verbindung"...

 

Das mit "not supported" stimmt natülich auch, funktionieren tut es trotzdem, wenn man das Laufwerk nicht einfach mit Gewalt wegzieht, um es danach dann neu zu verbinden...

 

 

 



Falls bereits schon ein Netzlaufwerk unter dem jew. Laufwerksbuchstaben  verbunden ist, wird dieses erstmal getrennt, ist des Öfteren passiert daher erst die Trennung.

 

Im Allgemeinen wird doch jedes Postfach im Backup gesichert, aus dem kann ich problemlos jede pst zurückspielen. Ist sogar in Quartal aufgeteilt.

 

Vllt sollte ich meine Frage etwas präzisieren, nachdem ich eine SSD in meinen Client eingebaut habe, passiert manchmal, dass die Netzlaufwerke nicht schnell genug gemappt werden. Evtl. weiß ja doch jemand wie ich das Anmeldescript dementsprechend korrigieren kann

 

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Was ist denn ACK ?

http://www.gaarde.org/acronyms/

 

 

 

 

Falls bereits schon ein Netzlaufwerk unter dem jew. Laufwerksbuchstaben  verbunden ist, wird dieses erstmal getrennt, ist des Öfteren passiert daher erst die Trennung.

Du trennst als erstes ALLE Laufwerke und dann trennst du sie nochmal. ;) Vielleicht die Batch nochmal von oben nach unten lesen. Oder überseh ich was?

 

Im Allgemeinen wird doch jedes Postfach im Backup gesichert, aus dem kann ich problemlos jede pst zurückspielen. Ist sogar in Quartal aufgeteilt.

Aha. Na offensichtlich hast du noch nie gesehen, wie sich eine PST über die Zeit zerlegt bis nichts mehr geht. Sowas kann auch Quartale dauern, weil man eben auf Altdaten seltener zugreift, bis man das bemerkt. PST Dateien so oder so sind Mist. Sie belegen mehr Platz (jedenfalls nicht weniger) als innerhalb der Exchange DB und sind bei jedem Öffnen von Outlook exklusiv geöffnet. Wenn also dein User sein Outlook nicht schließt, dann hast du nicht mal ein vernünftiges Backup. Und falls doch, sicherst du jedesmal 100% der PST Dateien, weil die sich eben bei jedem Öffnen von Outlook ändern.

 

Aber wie oben gesagt, muß jeder selbst wissen was er tut. ;)

 

Bye

Norbert

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Evtl. weiß ja doch jemand wie ich das Anmeldescript dementsprechend korrigieren kann

Wozu noch die Mühe?

 

Da Du ja nun mehrfach gelesen hast, dass deine Vorgehensweise nicht zu empfehlen ist, wirst Du doch eh bald umstellen. Und dann brauchst du wohl auch diese Batch nicht mehr :p

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Außer ein paar Weisheiten, bin ich jetzt auch nicht weiter....

Ja, mit dem doppelt trennen der Laufwerke ist vllt. nicht ganz so toll, aber wenn ich das "delete yes" für alle LW rausnehme, bleibt das Script hängen und fragt jedesmal ab, ob die verbindung getrennt werden soll mit J oder N ! Erst dann gehts weiter....

hat das Einfluß auf mein Problem? Wenn ich Zeit habe werde ich das Script mal ändern und dann weiter testen.

 

Ich habe mal spaßhalber 3 PSt Dateien aus dem Backup geholt, von 2012 von 2013 von 2014 - alle sind okay, sind nicht verschimmelt oder zerlegt. Und wieso sollen die User ihr Outlook nicht schließen, die fahren doch alle ihre PC runter..... also verstehe den ganzen Hype um die pst  nicht.

 

Also nochmal: kann jemand was zu meinem eigentlichen Problem sagen?

da würde ich mich freuen :)

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Na, dann bauen wir doch erst mal Deinen Batch um...

@Nils: Ich mag Batch auch :thumb1:

 

Deine Version:

@Echo off
net use * /delete /yes
net use g: /d
net use g: \\R1.xxxxx.local\User\%username%
net use k: /d
net use k: \\R1.xxxxx.local\Daten
net use o: /d
net use o: \\R56.xxxxx.local\Prog
net use v: /d
net use v: \\R44.xxxxx.local\Anwendung
exit

Meine Version:

@Echo off
REM Erst mal alles trennen, was wir nicht haben wollen... Und NUR das:
For %%D in (D E F H I J L M N P Q R S T U W X Z) Do net use %%D: /d /y >nul 2>&1
REM Laufwerke persistent mappen, damit sie bei der nächsten Anmeldung gleich da sind:
net use /p:yes
REM Jetzt die gültigen Laufwerke verbinden:
Call :CheckDrive G \\R1.xxxxx.local\User\%username%
Call :CheckDrive K \\R1.xxxxx.local\Daten
Call :CheckDrive O \\R56.xxxxx.local\Prog
Call :CheckDrive V \\R44.xxxxx.local\Anwendung
Goto :EOF
:CheckDrive
Set CurrDrive=%1
Set CurrPath=%2
REM Wenn das Laufwerk schon verbunden ist und der Pfad zum Laufwerk gehört, nichts machen (Goto :EOF), sonst trennen...
net use %CurrDrive%: | find /i "%currpath%" >nul 2>&1 && Goto :EOF || net use %CurrDrive%: /d /y >nul 2>&1
REM Neu verbinden:
net use %CurrDrive%: %CurrPath%
Goto :EOF

Vorteil: Laufwerke, die stimmen, werden nicht angefasst. Das Errorhandling könnte man noch verbessern, und dass ich auch dann versuche, eine "falsche" Verbindung zu trennen, wenn da gar kein Laufwerk zugeordnet ist: Ok, aber egal :D

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

OK, da Martin Dir ja nun die Lösung für Dein Skriptproblem gepostet hat, möchte ich Dir noch ein Beispiel in Bezug auf PST-Dateien im Netzwerk nennen.

 

Vor einiger Zeit habe ich, genau wie Du, PST-Dateien auf Netzlaufwerken abgelegt. Also Archive-PSTs und auch Postfächer von POP-Konten, die ohne Exchange genutzt wurden.

 

Mir war damals schon die Problematik bekannt, hab aber gedacht: Ach, das klappt doch alles. Also mal wieder voll übertrieben, die von Microsoft :suspect:

 

Bis dann morgens ständig das Netzwerk auf einer ganzen Etage in die Knie ging und manche Benutzer sich erst nach ca. 45 min! anmelden konnten. Auch sonst war das Arbeiten im Netz eine Qual. Nach ca. einer Woche verloren die Jungs der 1. Etage dann so langsam die Geduld.

 

Hab dann endlich das Problem gefunden. Tja, der Grund war eine defekte PST-Datei, die an einem Outlook-Client angebunden war. Die hat das ganze Etagen-Netzwerk bis zum Switch immer wieder mal lahmgelegt.

 

Du siehst, was PST-Dateien im Netzwerk anrichten können. Und das ist nicht das einzige Problem, was ich bisher hatte.

 

Du musst unsere Ratschläge hier nicht annehmen. Aber sag später nicht, wir hätten Dich nicht gewarnt ;)

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Erstelle ein Benutzerkonto oder melde dich an, um zu kommentieren

Du musst ein Benutzerkonto haben, um einen Kommentar verfassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Es ist einfach!

Neues Benutzerkonto erstellen

Anmelden

Du hast bereits ein Benutzerkonto? Melde dich hier an.

Jetzt anmelden
Melde dich an, um diesen Inhalt zu abonnieren  

×