Jump to content

Skriptmaster gesucht


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Hallo Skriptmaster,

 

wer kann mir die Fehler nennen, warum das Skript (im Anhang nicht läuft).

Ich habe Windows 7 x86 Trialversion, was nicht die Ursache sein dürfte, oder???

Warum werden einfache copy Befehle nicht ausgeführt?

 

Was möchte ich erreichen?

1. USB-Stick wird autom. formatiert

2. das Image wird auf den USB-Stick übertragen

3. Rücksicherung soll möglich sein.

 

Derzeit komme noch nicht mal so weit das ich ein WinPE auf den Stick bekomme.

 

Leider hat MS keine Step by Step Anleitung nach der man das nachvollziehen kann, sondern immer nur Bruchstücke.

 

Danke schon mal

Wolfgang

CreateUSB-1.cmd.txt

Link to post
@wolfgang2011

 

Wie du bereits gemerkt haben solltest, sind bei uns Anhänge nicht sehr beliebt. Poste also deinen Code sonst wird dir niemand helfen können.

 

LG Günther

 

Ok, ich bin ja lernfähig.

@echo off
rem 08:59 08.01.2012

SETLOCAL
SET DiskPartScript="DiskpartScript_USB.txt"

if exist %DiskPartScript% goto weiter

title Loesche USB-Stick
echo list disk >%DiskPartScript%
echo select disk 1 >>%DiskPartScript%
echo clean >>%DiskPartScript%
echo create partition primary >>%DiskPartScript%
echo format fs=fat32 quick label="Wolfgang2011">>%DiskPartScript%
echo active >>%DiskPartScript%
echo assign letter=U >>%DiskPartScript%
echo exit >>%DiskPartScript%
DiskPart /s %DiskPartScript%


:weiter
title Erstelle WinPE
rd /s /q C:\winpe
d:\"Program Files"\"Windows AIK"\Tools\PETools\copype x86 C:\winpe
rem NACH DIESER ZEILE endet das Skript ohne Fehlermeldung. 


rem dism /Mount-Wim /WimFile:c:\winpe\winpe.wim /index:1 /MountDir:C:\Winpe\mount
rem echo wpeinit >C:\winpe\mount\Windows\system32\startnet.cmd
rem echo Hallo %HOSTNAME% >>C:\winpe\mount\Windows\system32\starnet.cmd
rem dism /UnMount-Wim /MountDir:C:\Winpe\mount /commit


if not exist U:\ goto Fehler1

:weiter2
title Kopiere WinPE
md C:\winpe\ISO\sources
copy C:\winpe\winpe.wim C:\winpe\ISO\sources\boot.wim
copy d:\"Program Files"\"Windows AIK"\Tools\x86\imagex.exe C:\winpe\ISO
oscdimg -n -bc\winpe\etfsboot.com C:\winpe\ISO c:\winpe\winpe.iso

xcopy c:\winpe\ISO\*.* u:\ /s


ENDLOCAL
exit

:Fehler1
echo Stick nicht unter Laufwerk U gefunden.
pause
exit

Link to post

Du hast den Teil "On your technician computer, click Start, point to All Programs, point to Windows OPK or Windows AIK, right-click Deployment Tools Command Prompt, and then select Run as administrator." in der Doku überlesen. Die Copype.cmd benötigt diese Umgebungsvariablen

 

Warum willst Du die gazen Schritte in einer Batch laufen lasen ? Bereite Dir doch ein fertiges WinPE-Image vor. Das kannst Du dann mit einer Batch auf einen USB-Stick kopieren (ab Step 3 in Walkthrough: Create a Bootable Windows PE RAM Disk on a USB Flash Disk )

Edited by zahni
Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...