Jump to content

wolfgang2011

Members
  • Content Count

    58
  • Joined

  • Last visited

Community Reputation

10 Neutral

About wolfgang2011

  • Rank
    Newbie
  1. Hallo, Ziel des nachfolgenden: 2 Dateien in ein Standard WinPE_x86 kopieren um eine weitere Automatisierung zu erreichen. Jetzt wäre ich schon glücklich, wenn ich die PE mounten/dismounten könnte, was derzeit der Hauptfehler ist, wofür ich eine Lösung suche. Ausgangsinfo: Exemplarische Vorgehensweise: Erstellen eines optimierten Windows PE-Abbilds @echo off rem Mo 06 Feb 2012 14:03:28 CET rem Modifiziere WimPE rem Verzweiflungszeilen, weil ich immer Fehler erhalte. siehe weiter unten dism /Unmount-Wim /MountDir:C:\winpe\mount /Commit dism /Unmount-Wim /MountDir:C:\winpe\mount /Discard Dism /cleanup-wim rem Die "Ur-WinPE" erstelle ich noch manuell if not exist c:\winpe\winpe.wim goto Fehler_2 Dism /Mount-Wim /WimFile:c:\winpe\winpe.wim /index:1 /MountDir:c:\winpe\mount if not exist c:\winpe\mount\Windows goto Fehler_1 copy startnet.cmd C:\winpe\mount\Windows\System32\ copy loesche_disk.dat C:\winpe\mount\ dism /Unmount-Wim /MountDir:C:\winpe\mount /Commit if not exist c:\winpe\ISO\sources\ mkdir c:\winpe\ISO\sources copy c:\winpe\winpe.wim c:\winpe\ISO\sources\boot.wim exit :Fehler_1 echo. echo Kann winpe.wim nicht mounten echo. pause exit :Fehler_2 echo. echo C:\winpe\winpe.wim not found echo. pause exit Und hier die Fehlerausgabe: Das ganze führe ich auf einen W2K8 R2 durch, was in der Vergangenheit kein Problem darstellte. Ich Danke schon mal allen die helfen wollen. Wolfgang
  2. Derzeit verwende ich Sophos, der auch nicht alles kann, weshalb andere Produzenten auch Leben können. Natürlich müssten die User (und evtl. der Chef) die Info (per Mail) erhalten, wenn Dateien verschoben werden und diese nach Ablauf von X-Tagen autom. gelöscht werden. Mir geht es um eure Erfahrungen und Meinungen. Danke Wolfgang
  3. Moin lefg, Richtig, aber einige "ziehen" ihre Updates online runter. Noch nicht, weil ich mich mit einen neuen 32GB Transcend 3.0 "rumgeschlagen" habe. (Die Diskpart-Option hat er in Wahrheit nicht angenommen, weshalb mir ein Linuxfreund den Stick erstmal "geputzt" hat... und siehe da: normal- und WinPe- Installation war möglich. Evtl. habe ich auch die Diskpart-Option /mbr auch übersehen) Ja ist es, ein Forenkollege hat mir die Option gegeben. Es sind nur 200 Clients mit verschd. Hardware in 6 x 2008 R2 Domains, die nicht alle an einen Standort sind und deshalb auch nicht gleichzeitig bedient werden. Intel MGA 500 Du meinst Treiberupdate? Wenn alles läuft und heise keine Security-Meldung dazu veröffentlich, werde ich den Treiber nie mehr Updaten, denn es existieren genügend andere Baustellen.
  4. Hallo Edgar, Ja, es ist ein Einzelrechner mit Windows 7 Prof. x86 ( MS-Testversion aus dem Internet die über WDS von Hand installiert wurde), den ich für Testzwecke verwende bevor ich die Erkenntnis der Machbarkeit, in einer Produktivumgebung umsetze. Für die meisten Dinge suche ich erstmal eine schnelle machbare Lösung. Da funktionierende VGA-Treiber nicht mehr aktualisiert werden ist die Lösung für mich OK. Für Software die keine msi mitbringen z.B. gimp/scribus sieht die Sache schon anderst aus. Dann kommt wahrscheinlich ein neues Rollout ins Spiel. Die Anregung, von anderen, es mit WSUS zu machen klingt interessant, aber nicht jeder benötigt WSUS bzw hat es installiert und ich habe noch kein Wissen wie ich das genau anstellen soll. Einfach den Treiber in ein WSUS-Verz. reinkopieren ? Gruß Wolfgang
  5. Anhang ist wahrscheinlich verloren gegangen. Meine sehr einfache Lösung ohne Reportfunktion ist: Statt eine CMD zu bauen, schreibe ich gleich die Commandline in der GPO. if not exist C:\Intel \\w2k8\install\....\setup -s Das Verz. Intel wird durch die Installation des Grafiktreiber angelegt. Wenn man größere Screeshots anhängen dürfte würde jeder sofort erkennen was ich damit sagen will.
  6. Ok, ich bin ja lernfähig. @echo off rem 08:59 08.01.2012 SETLOCAL SET DiskPartScript="DiskpartScript_USB.txt" if exist %DiskPartScript% goto weiter title Loesche USB-Stick echo list disk >%DiskPartScript% echo select disk 1 >>%DiskPartScript% echo clean >>%DiskPartScript% echo create partition primary >>%DiskPartScript% echo format fs=fat32 quick label="Wolfgang2011">>%DiskPartScript% echo active >>%DiskPartScript% echo assign letter=U >>%DiskPartScript% echo exit >>%DiskPartScript% DiskPart /s %DiskPartScript% :weiter title Erstelle WinPE rd /s /q C:\winpe d:\"Program Files"\"Windows AIK"\Tools\PETools\copype x86 C:\winpe rem NACH DIESER ZEILE endet das Skript ohne Fehlermeldung. rem dism /Mount-Wim /WimFile:c:\winpe\winpe.wim /index:1 /MountDir:C:\Winpe\mount rem echo wpeinit >C:\winpe\mount\Windows\system32\startnet.cmd rem echo Hallo %HOSTNAME% >>C:\winpe\mount\Windows\system32\starnet.cmd rem dism /UnMount-Wim /MountDir:C:\Winpe\mount /commit if not exist U:\ goto Fehler1 :weiter2 title Kopiere WinPE md C:\winpe\ISO\sources copy C:\winpe\winpe.wim C:\winpe\ISO\sources\boot.wim copy d:\"Program Files"\"Windows AIK"\Tools\x86\imagex.exe C:\winpe\ISO oscdimg -n -bc\winpe\etfsboot.com C:\winpe\ISO c:\winpe\winpe.iso xcopy c:\winpe\ISO\*.* u:\ /s ENDLOCAL exit :Fehler1 echo Stick nicht unter Laufwerk U gefunden. pause exit
  7. Ich habe das Skript als Administrator im DOS-Fenster gestartet, aber keine Fehlermeldung erhalten. Bye Wolfgang
  8. Hallo Skriptmaster, wer kann mir die Fehler nennen, warum das Skript (im Anhang nicht läuft). Ich habe Windows 7 x86 Trialversion, was nicht die Ursache sein dürfte, oder??? Warum werden einfache copy Befehle nicht ausgeführt? Was möchte ich erreichen? 1. USB-Stick wird autom. formatiert 2. das Image wird auf den USB-Stick übertragen 3. Rücksicherung soll möglich sein. Derzeit komme noch nicht mal so weit das ich ein WinPE auf den Stick bekomme. Leider hat MS keine Step by Step Anleitung nach der man das nachvollziehen kann, sondern immer nur Bruchstücke. Danke schon mal Wolfgang CreateUSB-1.cmd.txt
  9. Hallo, ich versuche seit Tagen ein PC über WDS mit Unattended zu installieren. (Unattended.xml im Anhang) Leider komme ich kein Stück weiter. Wer hat eine sehr sehr einfache Unattended.xml die 100% funktioniert und könnte diese freundlicherweise zur Verfügung stellen. (Leider sind hier starke Beschränkungen, weshalb ich nicht mehr Anhänge hinterlegen kann. Evtl. könnte man die Anzahl der Anhänge hochsetzen? Ob 240KB oder 2,4MB ... das dürfte den Kohl nicht fett machen.) unattend.xml
  10. Hallo Sunny61; vielen Dank für Deine Infos. Damit nicht bei jeden Neustart der Treiber installiert wird, habe ich alles etwas umgebaut. (siehe Anhang) Es wird eine Zeit brauchen bis ich alle Deine Info gelesen, getestet und verstanden habe.
  11. Hallo OliverHu, nein es existieren keine Sicherheitsanforderungen. Grund der Installation über GPO: 1. MS bringt keinen Treiber für ein EeePC mit. 2. Ohne Treiber = zu geringe Auflösung. 3. Anfänger im Bereich Unattended.
  12. Natürlich sind die Doku von MS für den Anfang, um ein groben Überblick zu erhalten, nicht schlecht, aber... und deshalb braucht man diesen Foren, weil der rote Faden ( Step by Step Anleitung) fehlt. Ich suche derzeit nach 2 roten Fäden: 1. Unattended Installation von USB. 2. Unattended Installation von WDS. Überall finde ich ein paar Bruchstück die falsch von anderen URL abgeschrieben wurden. Auch in den Windows Server How-To Guides: Home - ServerHowTo.de sind leider nicht alle Standardthemen enthalten. Naja; deshalb freue ich mich über jede Antwort, die mich weiterbringt.
  13. Vielen Dank für Deine Antwort. Mein Problem ist, dass der PC auf dem ich vieles teste nicht gerade die Powermaschine ist. (EeePC AH1201) Ansonsten gebe ich Dir Recht. Danke Wolfgang
  14. Für mein EeePC habe ich ein Grafiktreiber, aber kein MSI-Packet gefunden. (Intel® Graphics Media Accelerator 500) Derzeit habe ich \\w2k8\freigabe\eeepc\vga\setup -s im GPO-Startskript hinterlegt, was auch funktioniert. (eigene OU für diesen PC) Ideal ist das noch nicht, weil jetzt bei jeden Bootvorgang die Installation des Treibers erfolgt. Vielleicht habe ich auch in der GPO den Punkt Treiberinstallation übersehen bzw. nicht wahrgenommen. Nochmal die Frage: Gibt es Anfänger-Tools, die aus einer exe eine msi bauen können, oder wie werden Treiber richtig installiert? Evtl. kennt eine eine brauchbare URL? Wenn mein Gedankenansatz: "Treiber per MSI installieren" falsch ist... Bitte mich korregieren. Danke Wolfgang
  15. Vielen Dank für Deine Mühe, aber diese Antwort bringt mich kein Stück weiter. Wenn man jede Frage so beantwortet, dann braucht man kein Forum mehr. Das AIK existiert weiss ich... mit der habe ich auch meine WinPE erstellt die auf dem WDS liegt und funktioniert. Vielleicht kannst Du etwas konkreter werden? Danke Wolfgang
×
×
  • Create New...