Jump to content
Sign in to follow this  
pbsuu

W2K-Server und RAID nachrüsten. Vorgehensweise?

Recommended Posts

Hallo meine Freunde, Retter und Mentoren ;) !!

Heute möchte ich gerne ein OK haben für meine folgende Absicht: Einer unserer W2K Server (Aufgabe: Fiel&Printservices) soll mit RAID1 nachgerüstet werden. Der SVR hat eine 40 GB ATA HD, die Daten werden noch auf DAT ausgelagert. Ich habe nun eingekauft einenAdaptec 1200A und eine 40 GB HD. Natürlcih leider keine identische mit der ersten, da ja schon 3 Jahre rum sind, nachdem der SVR gekauft wurde.

Vorgehen: Raid Treiber installieren, Controller einbauen, 1. Platte umstecken auf Controller, 2 . (neue) Platte am Controller anschließen, über Controller BIOS Platte spiegeln. Neu booten unter WIndows2000, mit RAID-Tool kontrollieren. *FREUEN**.

Gehen wir konform oder mache ich Denkfehler? Danke für Tips und Antworten in einem bääärenstarken Forum :p

pbsuu

Share this post


Link to post
Share on other sites

Hi,

 

ich denke nicht das das klappt da ja der MBR auf deiner jetzigen platte ist. Und wenn du via Controller BIOS die platten zum Spiegel formierst die Boot.ini Ihren Bootrecord nicht mehr findet. Ausser du editierst danach die Boot.ini ob das dann aber trotzdem klappt durch die Spiegel erstellung das weiss ich nicht.

 

Eher klappt das:

 

- Sicherung der Datenpartition (auf DAT wie gesagt) mit NTFS Berechtigungen wenn das dein Backupprogramm kann.

- Sicherung des Systemstatus via ntbackup

- Controller und platte einbauen

- RAID 1 konfigurieren

- Win2000 neu installieren

- ServicePacks, Patches und Hotfixes installieren

- Systemstatus zurückspielen

- Daten zurück spielen

 

Am besten ist es allerdings wenn du indentische Platten hast, so geht es zwar auch aber aus Performance und Sicherheitsgründen würde ich zwei identische nehmen...is doff wenn eine z.B. 5400 rpm hat und die andere 7200 rpm.

 

So würde ich es machen...lasse mich aber gerne eines anderen belehren.

 

cheers

rote_gefahr

Share this post


Link to post
Share on other sites

Gehen wir konform oder mache ich Denkfehler?

pbsuu

 

Denkfehler, die Bootpartition ändert sich durch den RAID.

 

Vorgehen: Raid Treiber installieren, Controller einbauen, 1. Platte umstecken auf Controller, 2 . (neue) Platte am Controller anschließen, über Controller BIOS Platte spiegeln. Neu booten unter WIndows2000, mit RAID-Tool kontrollieren. *FREUEN**.

pbsuu

 

Wenn das so einfach wäre .....

 

Heute möchte ich gerne ein OK haben für meine folgende Absicht: Einer unserer W2K Server (Aufgabe: Fiel&Printservices) soll mit RAID1 nachgerüstet werden..pbsuu

 

Läuft der Standalone ? Dann mach die Kiste neu, geht am schnellsten und sichersten

 

Nein, dann siehts anders aus.

 

Auf jeden Fall nimm 2 neue Festplatten gleicher Hersteller, Typ und Firmware !

 

Lege die " alte " Platte auf die Seite falls beim Umbau was schief geht, dann hast du noch einen Notnagel ...

 

Ich würde den fast identischen Weg gehen wie oben, aber ich würde die Daten zuerst zurückspielen und dann eine Reparaturinstalltion mit Raid Treiber über F6 probieren, wenn es nicht klappt, dann halt auch eine komplette Installation wie beschrieben.

 

Aber auf jeden Fall vorher : Datensicherung !! ( egal wie du vorgehst ) ;)

Share this post


Link to post
Share on other sites

Hi !

 

@pbsuu: Deine Planung funktioniert auf jeden Fall nicht (siehe Vorredner- bzw. Schreiber).

 

Was geht: Mit dem neuen Raid-Controller und mindestens 2 Platten (also Raid 1) oder mindesten 3 Platten und Raid 5 ein neues Volume aufbauen.

 

Dann zwischen der Original-Platte und dem Raid (1 oder 5) ein Software-Mirror aufbauen.

Danach den Spiegel brechen und nur noch vom Raid starten.

 

Alles andere ist "Prinzip Hoffnung" ;)

 

@XP-Fan: Warum empfiehlst Du eine Neuinstallation - der Weg über ein Software-Mirror erscheint mir wesentlich einfacher, unkomplizierter und auch ziemlich sicher - ich seh dabei jedenfalls kein Problem, jederzeit eine Fallback-Variante zu haben !?!

Share this post


Link to post
Share on other sites
oder mindesten 3 Platten und Raid 5 ein neues Volume aufbauen.

 

Der Adaptec 1200A kann soweit ich weiß nur 0/1/10 IDE mit ATA 100.

 

Warum ? Ich hatte den Zeitfaktor im Sinn und bin immer noch der Meinung, das ich einen Win2k Server schneller neu gemacht habe als restauriert und die Folgefehler behoben habe, solange dieser nur als File / Print Server läuft.

Share this post


Link to post
Share on other sites

Hallo XP-FAn und auch alle anderen! Danke für die Blitzantworten. Parallel zu meiner Anfarge hier hatte ich bei Adaptec angerufen und denen das Problem geschildert. Man sagte, es wäre kein Problem bei folgender Vorgehensweise: Am lfd SRV Controller rein, Triber insten, aktualisieren. SRV down-Platte vom IDE-Port weg, and Adaptec dran, 2. (neue Platte) am Port 2 des Controllers anschließen und über das Controller BIOS eine Speigelung ausführen, SRV neu starten. Ich bin jetzt etwas voller ??? und was eigentlich nicht so recht, was ich tun soll. Fakt ist, dass a) keine Zeit ist für "längere" Lösungen bzw. b) Ausfall. Ich weiß , ich weiß, aber ich kann es nicht ändern. Es kommt noch hinzu, dass ich unserem Stremaer nicht mehr so über den Weg traue, er blinkt mir zu häufig nach Sicherungen (AS 2000) und will immer gereinigt werden. Deshalb ja das RAID. Danke trotzdem zunächst.

pbsuu

Share this post


Link to post
Share on other sites

@pbsuu

Kann funktionieren, muss aber nicht.

Ich habs mal so gelöst, Controller rein, Treiber installiert, dann mit Acronis gesichert, alte Platte raus, Acronis Sicherung auf das Raid 1 gespielt, neugestartet und es lief.

Ging aber bis jetzt nicht bei jedem Controller!

 

vg

Basti

Share this post


Link to post
Share on other sites

@pbsuu:

 

Diese Ausfallzeit "Ausreden" kenne ich auch ....

 

Jetzt rechne aber mal ....

 

- Einbau Controller, Treiberinstallation und Vorbereitung (ca 1 Stunde)

- Spiegelung der Platte über das Controllerbios (ca 1-2 Stunden, je nach Plattengrösse)

- Booten und feststellen es geht .... fein

- alternativ feststellen läuft nicht (Ärgerzeit 5-10 Minuten, feststellen, dass man doch kein Backup hat 10 Minuten, System neu installieren inklusive Konfiguration bis zum Ausgangspunkt ca 4-6 Stunden)

 

ergibt im schlimmsten Fall also so etwa 9-10 Stunden.

 

Sieht man mal davon ab, dass die Neuinstallation mit Rücksicherung des Systemstate nicht länger als der Controllereinbau + Spiegelung dauern sollte, und auch die Gesamtzeit einer Neuinstallation von Anfang an "nur" 4-6 Stunden Ausfallzeit bedeutet, frage ich mich wo genau Du Zeit sparen möchtest.

 

Wenn man jetzt bedenkt, dass der Controllereinbau + Spiegelung + einfach System neu booten nur funktionieren "könnte", was für mich bedeutet die Möglichkeit, dass das so funktioniert liegt bei höchstens 50% (so gesehen also 50:50, geht oder geht nicht), würde ich persönlich gar nicht erst daran denken das zu versuchen.

 

Sowas kann man vorher bei Spielwiesen mit gleicher Hardware testen und sehen, ob das taugt, aber so einfach ins "Blaue" hinein und nur weil Adaptec denkt es könnte gehen?

 

Just my 2 cent .....

 

Grüsse

 

Gulp

Share this post


Link to post
Share on other sites

Erfolgsmeldung: Ich habe am Server eine "ordentliche" Datensicherung mit Arcserve gemacht inkl. Systemstatus. Dann wurde der RAID Controller von Adaptec 1200A eingebaut. Treiber installiert, geupdatet. Vorhandene Platte an Port 1 , 2. Platte (Mirror) an Port 2 des RAID-Con.

NAch dem Booten das BIOS des RAID-Con. aufgerufen , ein RAID1 Array eingerichtet und dupliziert. Voila! Server bootet ohne Mucken. Übrigens, eine Anfrage bei Adaptec ergab die Bestätigung, dass dies für ein Nachrüsten von RAID1 funktioniert. Muss ich RAID0 installieren , geht tatsächlich der Bootsektor verloren. Soweit danke für das hilfreiche Posting.

 

Ach ja, nochwas! Ich war mit der gleichen Frage in anderen "Fach"-Foren unterwegs.

 

ABER NIRGENDWO WAREN DIE TIPS PROFESSIONELLER UND HILFREICHER ALS HIIIER !!! :p :p :p :p

Share this post


Link to post
Share on other sites
Der SVR hat eine 40 GB ATA HD, die Daten werden noch auf DAT ausgelagert. Ich habe nun eingekauft einenAdaptec 1200A und eine 40 GB HD. Natürlcih leider keine identische mit der ersten, da ja schon 3 Jahre rum sind, nachdem der SVR gekauft wurde.
Hallo,

 

Wird es nicht Zeit, eine dreijährige ATA in einem Server zu ersetzen?

 

Gruß

 

Edgar

Share this post


Link to post
Share on other sites

Hi Edgar,

 

ja, Recht hast Du schon... Aber der Server Eigner mag die Kosten des Tauschs nicht jetzt tragen, also ....

 

manchmal darf man sich nicht treu sein, sondern Söldner werden....

 

ciao,

pbsuu

Share this post


Link to post
Share on other sites

ja, Recht hast Du schon... Aber der Server Eigner mag die Kosten des Tauschs nicht jetzt tragen, also ....

Tja, wo so eine neue 40 GB - ATA - Platte heutzutage auch noch bis zu 40 € kostet - wer soll das bezahlen ! :D

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...