Jump to content

Win98 mit Win2k vernetzt -> sehr langsam


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Hallo!

 

Ich habe meinen Laptop (Win2k) mit meinem alten PC (Win98) mittels Crossoverkabel vernetzt. Wenn ich nun aber Daten zwischen den beiden austausche, geht das nur sehr sehr langsam, habe Netzwerkauslastungen von 0,25% (!)

Ich hab mal gehört, dass das irgendwas damit zu tun hat, dass Win2k beim 98er Rechner nach jedem Paket nachfragt ob er überhaupt noch da ist (oder so was ähnliches).

Weiß jemand mehr dazu, anscheinend soll man das auch irgendwo in der Registry abstellen können.

 

Gruß,

neuner99

Link to comment

Den Laptop (Win2k) hatte ich auch schon in anderen Netzwerken, dabei konnte ich die Netzwekverbindung auch voll ausnutzen. Der Win98 Rechner hat mit anderen Win98 Rechnern auch immer gut zusammengearbeitet. Daraus schließe ich, dass es nichts mit der Hardware zu tun hat sondern, dass wirklich was an dem dran ist was ich in meinem ersten Posting geschrieben habe

 

Ich hab mal gehört, dass das irgendwas damit zu tun hat, dass Win2k beim 98er Rechner nach jedem Paket nachfragt ob er überhaupt noch da ist (oder so was ähnliches).

 

Kann mir jemand etwas dazu sagen?

 

@drMelzer:

Win98 -> Netzwerkkarte von SMC mit aktuellen Treibern, 384MB-Ram

Win2k -> irgendeine Onboard auch mit aktuellen Treibern, 384MB-Ram

Aber wie gesagt, an der Hardware liegts ziemlich sicher nicht, sonst würden sie ja mit den selben Betriebssystemen auch nicht ordentlich funktionieren!!!

Link to comment

Hi neuner99 !

Erstmal zu Deiner Frage:

Erst wird schon nachgefragt, ob der andere noch da ist.

Was Du meinst mit der Abfrage nach jedem Paket, hat aber damit nichts zu tun. Dabei wird gecheckt, ob das Paket korrekt angekommen ist, wenn nicht, wird es nochmal geschickt.

Dies ist aber protokollbedingt und hat nichts mit Win98 oder w2k speziell zu tun. Im Normalfall funktioniert es auch zwischen Win98 und w2k

Ansonsten kommen die Standardfragen, um den Fehler einzugrenzen:

 

Welche Protokolle sind auf beiden PC installiert ?

Läuft auf einem oder beiden PC eine Firewall, bzw. ist zwar eine installiert aber deaktiviert ?

Wie ist der Transfer, wenn Du runtergehst auf 10Mbit/s ?

Kannst Du Dir von einem Bekannten ein Kabel borgen, um einen Kabeldefekt auszuschließen ?

Link to comment

@zuschauer

Ja, ich weiß, dass bei TCP/IP nach jedem Paket nachgefragt wird ob es korrekt angekommen ist, was ich aber meine (bzw mal gehört habe) ist, dass Win2k nachfrägt ob der andere PC überhaupt noch da ist, das hat dann eigentlich nichts mit dem TCP/IP Protokoll zu tun.

 

@klausk:

Ja, hab ich auch alles schon probiert, das ändert nichts

 

@dr melzer und die anderen auch :D :

Ich habe auf beiden Rechnern nur TCP/IP installiert.

Ich verwende keine Firewalls

Beide PCs haben eine feste IP und Subnetmask

 

So und jetzt der Hammer an dem ganzen:

Ich hab auf dem Win98-Rechner jetzt Win2k dazuinstalliert und siehe da, das Netzwerk funktioniert so wie man es sich erwartet, boote ich wieder Win98 sinkt die Auslastung auf 0,25%

Ich schließe somit fehlerhafte Netzwerkkabel und Karten aus, ich finde diese Registry Sache immer plausibler!!!

Die Frage bleibt aber nach wie vor: Wo ist denn dieser Eintrag?

 

Aber wie auch immer, vielen Dank für eure Beiträge bisher!!!!!!!! :)

 

@drMelzer:

Was macht eine "passive" Karte, wie funktioniert diese?

Link to comment

Na ja wenn du darauf bestehst mit einem Win98 PC zu arbeiten:

 

Bei den Karten kann mal die Geschwindigkeit ja einstellen...

Setz mal beide auf 100MBit halfduplex-mode oder auf automatik.

 

Falls die eine nämlich nicht korrekt mit 100MBit pro secunde arbeitet, und ie andere schneller ist, klapps nicht!

 

Und:

Wie viel Mhz?

Link to comment
Original geschrieben von BlackJake

Setz mal beide auf 100MBit halfduplex-mode oder auf automatik.

 

Das ist ja wohl totaler Blödsinn.

 

Setze beide Karten auf 100/fullduplex.

Wenn du beide auf Automatik setzt, werden sie lange darüber diskutieren wer die Einstellungen vorgibt, was noch mehr Ressourchen frisst.

 

Aktive Karten haben einen eigenen Chip auf der Karte, welcher dafür sorgt dass die Pakete ordentlich veschickt werden, bei passiven Karten übernimmt das der Arbeitsspeicher. Das kann dazu führen, dass gerade das Kopieren von sehr grossen Dateien oder Datenmengen (z.B. Videos) zum Geduldsspiel wird.

Link to comment

@blackJacke:

Das hab ich doch im vorigen Posting geschrieben, die beiden arbeiten absolut korrekt mit 100MBit/s fullduplex, das Problem ist ja nur beim vernetzten von verschiedenen OS Versionen.

Aber hab auch schon alle möglichen Einstellungen ausprobiert, automatisch, 10MBit, 100MBit, halfduplex, fullduplex.... das ändert alles nichts

 

@drMelzer:

Bei passiven Karten übernimmt das der Arbeitsspeicher??? Ich nehme an du meintest die CPU?

D.h. bei passiven müsste dann die CPU Auslastung auch ziemlich in die Höhe gehen?

Naja, bei meinen 0,25% Auslastung wurde die CPU noch nicht wirklich beansprucht :)

Link to comment
Original geschrieben von neuner99

Bei passiven Karten übernimmt das der Arbeitsspeicher??? Ich nehme an du meintest die CPU?

 

Der komplette Rechner natürlich, da die Daten von der Netzwerkkarte, durch den PCI-Bus in den Prozessor müssen und damit auch Arbeitsspeicher belegen.

 

Bei aktiven Karten (

COM, Intel) Passiert das alles in der Karte, was erheblich schneller ist.

 

Original geschrieben von neuner99

D.h. bei passiven müsste dann die CPU Auslastung auch ziemlich in die Höhe gehen?

Naja, bei meinen 0,25% Auslastung wurde die CPU noch nicht wirklich beansprucht :)

 

Nicht zwingend, aber es ist durch den Gesamtprozess erheblich langsamer.

Link to comment
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...