Jump to content

Keine Verbindung zu Mailbox auf Exchange 2016 bei Migration von 2010


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Hi,

 

habe einen neuen Windows Server 2016 installiert und durchgepatched sowie dort Exchange 2016 CU20 installiert. Nach der Grundkonfiguration (virtuelle Verzeichnisse / Outlook Anywhere, (Wildcard) Zertifikat, PF Proxy, IIS Crypto, Reboot) habe ich eine Test Mailbox auf dem neuen Server erstellt und am Test Client in der Hosts Datei outlook.example.com sowie autodiscover.example.com auf den neuen Exchange verwiesen. Jetzt startet Outlook mit der Test Mailbox nicht. OWA tuts.

 

Ich hatte schon verschiedene ähnliche Probleme, die hier nicht passen:

  • CAS Array = vDir / OA Host
  • "Blödsinn" im OutlookProvider
  • Tippfehler in den URLs der vDirs
  • Redirects im IIS

 

Da ich ein Wildcard Zertifikat habe, habe ich die virtuellen Verzeichnisse / Outlook Anywhere auf dem Exchange 2016 auf owa.example.com umkonfiguriert und im DNS angelegt. Jetzt geht Outlook auf und ein Move-Request mit einer Test Mailbox vom Exchange 2010 funktioniert auch "wie gewohnt". Hat jemand noch eine Idee?

 

Vielen Dank und Gruß

Jan

Link to post

Wenn ich es richtig raus lese, hast du noch einen zweiten Exchange Server und jetzt die Koexistenz hergestellt?

 

Ich hatte solch ein Problem tatsächlich schon ein zwei Mal mit einem Wildcard Zertifikat.

 

Grüße

Phil

Link to post
Zitat

 

Moin Jan,

 

ist dein CAS Array Name eindeutig?

 

Stell doch ansonsten Testweise mal Serverseitig auf intern ebenso Outlook Anywhere ein.

Hier ein paar mehr Infos darüber...

https://techcommunity.microsoft.com/t5/exchange-team-blog/ambiguous-urls-and-their-effect-on-exchange-2010-to-exchange/ba-p/593809

 

und das sind die Schalter die ich testen würde:

Set-OutlookProvider EXPR -OutlookProviderFlags:ServerExclusiveConnect

Set-OutlookProvider EXCH -OutlookProviderFlags:ServerExclusiveConnect

Hat mir schon oft bei Migrationen das Umziehen erleichtert.

Gruß mikro

Link to post

  Hi Phil,

 

vor 25 Minuten schrieb Gerber:

Wenn ich es richtig raus lese, hast du noch einen zweiten Exchange Server und jetzt die Koexistenz hergestellt?

Ja, korrekt. Der Exchange 2016 wurde für die Migration in die bestehende Exchange Organisation installiert.

 

vor 27 Minuten schrieb Gerber:

Ich hatte solch ein Problem tatsächlich schon ein zwei Mal mit einem Wildcard Zertifikat.

 

Ich erinnere mich an Wildcard Probleme "vor längerer Zeit", wo im Outlook Provider dann der CertPrincipialName "msstd:*.example.com" angegeben werden musste. Wäre ein Versuch wert.

 

Hi Mirko,

 

vor 2 Minuten schrieb mikro:

ist dein CAS Array Name eindeutig?

Ja, casintern.example.com und "der Rest" outlook.example.com.

 

vor 4 Minuten schrieb mikro:

und das sind die Schalter die ich testen würde:

Set-OutlookProvider EXPR -OutlookProviderFlags:ServerExclusiveConnect

Set-OutlookProvider EXCH -OutlookProviderFlags:ServerExclusiveConnect

Hat mir schon oft bei Migrationen das Umziehen erleichtert.

 

Das brauchte ich bislang nur, wenn das CAS Array bspw. auch outlook.example.de war. Schaden dürfte es aber auch nicht intern noch auf OA zu switchen.

 

Danke euch beiden schon mal für den Input.

 

Gruß

Jan

Link to post
Posted (edited)

Hi,

 

die Ideen haben leider nicht geholfen. Bin aber evtl. einen Schritt weiter(?).

 

Sobald ich im Ausgangszustand eine Mailbox auf dem Exchange 2010 in Outlook öffne, danach die DNS Einträge auf den Exchange 2016 ändere und den Client boote funktioniert Autodiscover nicht mehr. Mache ich hier einen Test ("E-Mail-Autokonfiguration testen...") gibt es nur "httpStatus=401" oder "httpStatus=500".

 

Eine Mailbox auf dem Exchange 2016 fordert in diesem Fall beim Start immer wieder zur Eingabe des Kennwortes auf bis auf "Abbrechen" geklickt wird. Danach funktioniert Outlook im Online Modus meldet allerdings "Kennwort erforderlich". Klicke ich auf "Kennwort erforderlich" wechselt der Status ohne Kennworteingabe in "Online mit Microsoft Exchange". Nach einer kurzen Zeit ploppt der Dialog wieder hoch und das Kennwort ist wieder erforderlich. Mache ich hier einen Test ("E-Mail-Autokonfiguration testen...") gibt es für "outlook.example.com" den "httpStatus=401" und für "owa.example.com" dann "httpStatus=200" und Autodiscover funktioniert.

 

Edit: Auf dem Test Client ist alles an Autodiscover in der Registry bis auf Autodiscover URL und SCP deaktiviert.

 

Ich tendiere fast schon in die Richtung, dass es mit den März Security Fixes / dem CU20 zusammenhängt (und der Exchange 2010 sicherlich etwas spät dran ist). Ansonsten werde ich wohl den geringeren Widerstand wählen und den Namensraum ändern. Vielleicht habe ich aber auch Lust und baue das mal in einem Lab nach, wo ich ein älteres CU nehme. ;)

 

Besten Dank und Gruß

Jan

 

Edited by testperson
Link to post

Hi,

 

LegacyURL / Namespace war AFAIK nur bei Exchange 2007 und für OWA(?) relevant. Zumindest habe ich bei der Masse der Ex2010 zu 2013/2016 nie eine LegacyURL gesetzt. Der Link beschreibt ja das, was ich eigentlich erwartet hätte:

  • Autodiscover -> Proxy über 2016 auf 2010
  • (Intern) RPC -> Direkt über CAS Array
  • (Intern) MAPIoverHTTP -> Über Exchange 2016

Ich bin grade nochmal den Exchange Deployment Assitant (Exchange Deployment Assistant (microsoft.com)) durchgegangen und genau so vorgegangen wie dort beschrieben.

 

Gruß

Jan

Link to post
vor 4 Stunden schrieb tesso:

Exchange 2010 und 2016 benötigt doch im 2016er die Angabe der Legacy URL. (Hieß die so?)

 

Nein die brauchst man nur per OWA und selbst dann nur, wenn man einen Redirect haben will. Man kann das aber auch per Proxy hinbekommen.

Link to post
  • 2 weeks later...

Mal ein kurzer Zwischenstand. Die Mailboxen sind alle "drüben", Bei 6 von 108 Postfächern war nach dem Move keine Outlookverbindung mit Outlook 2016 oder größer mehr möglich. Das hat sich über Nacht von alleine "gefixed" bzw. konnte durch Reboot vom alten und danach neuen Exchange beschleunigt werden.

 

Jetzt bleiben noch knapp 700 MB Public Folder...

Link to post
vor 36 Minuten schrieb testperson:

Bei 6 von 108 Postfächern war nach dem Move keine Outlookverbindung mit Outlook 2016 oder größer mehr möglich. Das hat sich über Nacht von alleine "gefixed" bzw. konnte durch Reboot vom alten und danach neuen Exchange beschleunigt werden.

Vermutlich hätte ein Reset des AutodiscoverAppPools im IIS ausgereicht. ;)

https://support.microsoft.com/en-us/topic/outlook-logon-fails-after-mailbox-moves-from-exchange-2010-to-exchange-2013-or-exchange-2016-bd3f59ed-c521-4349-5c00-c49717b5e04d

 

Aber 6 von 108 ist ne sehr gute Quote. :)

Link to post

Klingt genau passend. :)

 

Bin mir aber nicht mehr sicher, meine aber den IIS durchgestartet zu haben. (Das war vorm "Wochenend-Rest". ;)) Dabei wären doch auch die AppPools durchgestartet worden. Zwei User haben sich zum Test auf eine alte RDS Farm mit Outlook 2013 verbunden und da gingen die Mailboxen in den alten Profilen sofort und ohne Widerstand auf.

Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...