Jump to content
lukasf

In Place Upgrade von Server 2016 auf Server 2019

Recommended Posts

Hallo miteinander,

ich bin neu hier. Bin IT-Admin an mehreren Schulen in Österreich...

Ich möchte gerne ein InPlace-Upgrade von Server 2016 (Standard - Desktop) auf Server 2019 machen. Die Maschine läuft virtuell in Hyper-V.
Ich habe diese Prozedur bereits bei mehreren Systemen hinter mir. Bis jetzt immer ohne Probleme.
Ich weiß, man soll das nicht in einem Produktivsystem machen...

Jetzt schlägt das Upgrade mit folgender Fehlermeldung aber fehl:

"... konnte nicht installiert werden ... 0x800706BA - 0x20003 ... ...In der Phase SAFE_OS ist während des Vorgangs INSTALL_UPDATES ein Fehler aufgetreten"

Google liefert mir nicht wirklich was.
Den Komponentenspeicher habe ich bereits erfolgreich repariert. (DISM /online /Cleanup-Image...)

Alle Updates sind korrekt installiert.

Danke und Gruß
Lukas

Inhalt der setuperr.log:
 

2020-04-25 14:32:08, Error CallPidGenX: PidGenX function failed on this product key. (hr = 0x8a010001)
2020-04-25 14:32:08, Error MOUPG CDlpActionProductKeyValidate::ReportDownlevelInstallChannel(3135): Result = 0x8A010001
2020-04-25 14:32:08, Error MOUPG ProductKey: Failed to report Host OS channel to telemetry.
2020-04-25 14:32:41, Error MOUPG CFCAcquirerDCAT::CopyCompDBs(1600): Result = 0x80070003[gle=0x00000003]
2020-04-25 14:32:41, Error MOUPG CFCAcquirerDCAT::DownloadInitialPayload(961): Result = 0x80070003[gle=0x00000003]
2020-04-25 14:32:41, Error MOUPG CFCAcquirerDCAT::Download(918): Result = 0x80070003[gle=0x00000003]
2020-04-25 14:32:41, Error MOUPG CFCPayloadLatentAcquisition::Download(132): Result = 0x80070003[gle=0x00000003]
2020-04-25 14:32:41, Error MOUPG DUImage: Error on Latent Acquisition Payload: [0x80070003][gle=0x00000003]
2020-04-25 14:43:55, Error DU DU::CDUSession::Search: Failed to set WU internal configuration property for targeted scans. hr = 0x80070057
2020-04-25 14:43:55, Error DU DU::CDUSession::BuildSearchCriteria: Caller profile search criterion is not supported. hr = 0x80070032
2020-04-25 14:43:55, Error DU DU::CDUSession::Search: Failed to build the search criteria. hr = 0x80070032
2020-04-25 14:44:12, Error CONX Windows::Compat::Appraiser::SetupAppraiser::UpdateExpiredAvRegistry (2599): Failed to update AV status: [0x80041010].[gle=0x80041010]
2020-04-25 14:44:12, Error CONX Windows::Compat::Appraiser::SetupAppraiser::ScanInternal (231): Error initializing av status in registry using inbox appraiser [0x80041010].[gle=0x80041010]
2020-04-25 14:44:20, Error CONX Windows::Compat::Appraiser::WmiQueryAntiMalware::AddAvFiles (196): Error getting enumerator for AntiSpywareProduct: [0x80041010].[gle=0x80041010]
2020-04-25 14:44:20, Error CONX Windows::Compat::Appraiser::WmiQueryAntiMalware::ComInitializedWmiQuery (163): Error adding files for AntiSpywareProduct: [0x80041010].[gle=0x80041010]
2020-04-25 14:44:20, Error CONX Windows::Compat::Appraiser::WmiQueryAntiMalware::Initialize (67): InitializeWmiQuery Error: [0x80041010].[gle=0x80041010]
2020-04-25 14:44:20, Error CONX Windows::Compat::Appraiser::WicaApplicationInventory::AddAntiMalwareFiles (578): Failed to query wmi, swallowing: [0x80041010].[gle=0x80041010]
2020-04-25 14:44:20, Error CONX Windows::Compat::Appraiser::WicaApplicationInventory::GetInventory (268): Failed AddAntiMalwareFiles, swallowing: [0x80041010].[gle=0x80041010]
2020-04-25 14:44:26, Error SP CNewSystem::PreInitialize: FveCheckSuspendBitLockerOnUpgrade failed: 0x8007007e, assuming auto-unlock is not supported[gle=0x0000007e]
2020-04-25 14:44:53, Error SP CNewSystem::PreInitialize: FveCheckSuspendBitLockerOnUpgrade failed: 0x8007007e, assuming auto-unlock is not supported[gle=0x0000007e]
2020-04-25 14:50:46, Error [0x0803b6] MIG Can't retrieve group information for user NT SERVICE\MSSQL$MICROSOFT##WID. NetUserGetLocalGroups failed 0x000008AD
2020-04-25 14:50:46, Error [0x0803b6] MIG Can't retrieve group information for user IIS APPPOOL\.NET v4.5. NetUserGetLocalGroups failed 0x000008AD
2020-04-25 14:50:46, Error [0x0803b6] MIG Can't retrieve group information for user IIS APPPOOL\.NET v4.5 Classic. NetUserGetLocalGroups failed 0x000008AD
2020-04-25 14:50:59, Error [0x0803b6] MIG Can't retrieve group information for user NT SERVICE\MSSQL$MICROSOFT##WID. NetUserGetLocalGroups failed 0x000008AD
2020-04-25 14:50:59, Error [0x0803b6] MIG Can't retrieve group information for user IIS APPPOOL\.NET v4.5. NetUserGetLocalGroups failed 0x000008AD
2020-04-25 14:50:59, Error [0x0803b6] MIG Can't retrieve group information for user IIS APPPOOL\.NET v4.5 Classic. NetUserGetLocalGroups failed 0x000008AD
2020-04-25 14:51:22, Error SP pSPRemoveUpgradeRegTree: failed to delete reg tree HKLM\SYSTEM\Setup\Upgrade[gle=0x00000005]
2020-04-25 14:51:25, Error [0x0803b6] MIG Can't retrieve group information for user NT SERVICE\MSSQL$MICROSOFT##WID. NetUserGetLocalGroups failed 0x000008AD
2020-04-25 14:51:25, Error [0x0803b6] MIG Can't retrieve group information for user IIS APPPOOL\.NET v4.5. NetUserGetLocalGroups failed 0x000008AD
2020-04-25 14:51:25, Error [0x0803b6] MIG Can't retrieve group information for user IIS APPPOOL\.NET v4.5 Classic. NetUserGetLocalGroups failed 0x000008AD
2020-04-25 14:52:58, Error [0x0803b6] MIG Can't retrieve group information for user NT SERVICE\MSSQL$MICROSOFT##WID. NetUserGetLocalGroups failed 0x000008AD
2020-04-25 14:52:58, Error [0x0803b6] MIG Can't retrieve group information for user IIS APPPOOL\.NET v4.5. NetUserGetLocalGroups failed 0x000008AD
2020-04-25 14:52:58, Error [0x0803b6] MIG Can't retrieve group information for user IIS APPPOOL\.NET v4.5 Classic. NetUserGetLocalGroups failed 0x000008AD
2020-04-25 14:56:18, Error CSetupAutomation::Resurrect: File not found: C:\$WINDOWS.~BT\Sources\Panther\automation.dat[gle=0x00000002]
2020-04-25 14:56:18, Error SP CSetupPlatform::ResurrectAutomation: Failed to resurrect automation: 0x80070002[gle=0x00000002]
2020-04-25 15:35:59, Error SP CAddPackage::DoExecute: Failed to add package Add [1] package C:\$WINDOWS.~BT\GDRs\DU\7b446f73-32b9-45b8-9dfc-cdf3ac349831\Windows10.0-KB4549949-x64.cab. Error: 0x800706BE
2020-04-25 15:35:59, Error SP CAddPackage::DoExecute: Failed to check new OS image health. Error: 0x800706BA[gle=0x0000007a]
2020-04-25 15:35:59, Error SP Operation failed: Add [1] package C:\$WINDOWS.~BT\GDRs\DU\7b446f73-32b9-45b8-9dfc-cdf3ac349831\Windows10.0-KB4549949-x64.cab. Error: 0x800706BA[gle=0x000000b7]
2020-04-25 15:38:46, Error MOUPG Finalize: Error reading narrator reg key: [0x80070002]
2020-04-25 15:38:48, Error [0x0803b6] MIG Can't retrieve group information for user NT SERVICE\MSSQL$MICROSOFT##WID. NetUserGetLocalGroups failed 0x000008AD
2020-04-25 15:38:48, Error [0x0803b6] MIG Can't retrieve group information for user IIS APPPOOL\.NET v4.5. NetUserGetLocalGroups failed 0x000008AD
2020-04-25 15:38:48, Error [0x0803b6] MIG Can't retrieve group information for user IIS APPPOOL\.NET v4.5 Classic. NetUserGetLocalGroups failed 0x000008AD
2020-04-25 15:39:09, Error SP CFinalizeCriticalBoundary::DoExecute: Cannot create hardlink betweeen C:\$WINDOWS.~BT\Sources\SetupPlatform.exe and C:\WINDOWS\System32\OOBE\SetupPlatform\SetupPlatform.exe. Error: 0x000000b7[gle=0x000000b7]
2020-04-25 15:39:09, Error SP CFinalizeCriticalBoundary::DoExecute: Rollback in system context will not be registered.[gle=0x000000b7]
2020-04-25 15:39:10, Error SP BFSVC: Error copying boot debugging files from C:\$WINDOWS.~BT\Sources\system32 to \\?\GLOBALROOT\Device\HarddiskVolume3\EFI\Microsoft\Boot (kd_*_*.dll). Last Error = 0x6[gle=0x00000006]
2020-04-25 15:39:10, Error SP BFSVC: Error copying boot debugging files from C:\$WINDOWS.~BT\Sources\system32 to \\?\GLOBALROOT\Device\HarddiskVolume3\EFI\Microsoft\Boot (kdstub.dll). Last Error = 0x6[gle=0x00000006]
2020-04-25 15:39:10, Error SP Error loading SrClient.dll. Error: 0x0000007E[gle=0x0000007e]
2020-04-25 16:02:35, Error SP CAddPackage::DoExecute: Failed to add package Add [1] package C:\$WINDOWS.~BT\GDRs\DU\7b446f73-32b9-45b8-9dfc-cdf3ac349831\Windows10.0-KB4549949-x64.cab. Error: 0x800706BE
2020-04-25 16:02:35, Error SP CAddPackage::DoExecute: Failed to check new OS image health. Error: 0x800706BA[gle=0x0000007a]
2020-04-25 16:02:35, Error SP Operation failed: Add [1] package C:\$WINDOWS.~BT\GDRs\DU\7b446f73-32b9-45b8-9dfc-cdf3ac349831\Windows10.0-KB4549949-x64.cab. Error: 0x800706BA[gle=0x000000b7]
2020-04-25 16:04:20, Error SP Cannot revert execution of operation 59 (Cleanup source WIM file(s)). Execution queue is now compromised.[gle=0x00000091]
2020-04-25 16:04:20, Error SP Operation execution failed: 3. hr = 0x800706BA[gle=0x00000091]
2020-04-25 16:04:20, Error SP ExecuteOperations: Failed execution phase Safe OS. Error: 0x800706BA[gle=0x00000091]
2020-04-25 16:04:20, Error SP CSetupPlatformPrivate::Execute: Execution of operations queue failed, abandoning. Error: 0x800706BA[gle=0x00000091]

 

Share this post


Link to post

Ist da ein AV drauf, wenn ja, welcher?

 

Treiber sollten ja eigentlich keine benötigt werden, wenn das eine VM unter Hyper-V ist - wurde der mal mittels Tools von Physik zu VM konvertiert?

 

Hier hatte einer das gleiche Problem, allerdings bei W10

https://answers.microsoft.com/de-de/windows/forum/all/größere-windowsupdates-schlagen-immer/939ae07a-33f1-4c42-9599-ea7f179044e8

 

:-)

Share this post


Link to post

Moin,

 

bevor man da jetzt lange rummacht und es sich vielleicht gar nicht lohnt - muss es denn ein Inplace-Upgrade sein? Von sowas rät man aus guten Gründen bei Servern eigentlich immer ab. 

 

Gruß, Nils

 

Share this post


Link to post

Will jetzt keiner hören, aber ich hab alle 2016er, die zu mir gehören, inplace auf 2019 gehoben. Alle ohne Probleme (bis auf einen Bug in Windows Defender ATP, der für Hyper-V "Compute" Service ne Sonderregel mitbrachte, die wieder raus mußte).

@lukasf besorg Dir mal err.exe (Download bei MS, gehört zu Exchange), mit dem kannst die meisten Errorcodes aufdröseln, vielleicht gibt das einen Hinweis. winerror.exe geht auch, das war zumindest mal im SDK dabei. Hilft, wenn man die Ursache und Schwere dieser Fehler interpretieren will.

Share this post


Link to post

Moin,

 

Prima, aber der TO hat ja nun mal Probleme ...

 

Gruß, Nils

 

Share this post


Link to post

Hallo miteinander,

vielen Dank für eure Antworten.


ad AV: nein, es ist kein AV installiert. Daran kann es also kaum liegen.
Die einzige "Fremdsoftware", die läuft, ist Acronis Backup & Recovery Server 11.7. Kann es daran liegen???

 

ad "im Prdouktivsystem": für mich wäre ein In-Place-Upgrade jetzt deswegen doch noch in Frage gekommen, da es beim Hyper-V-host für diese VM und dem darauf laufenden Domänencontroller anstandslos geklappt hat...

 

ad err.exe bzw. winerr.exe: das werde ich bei nächster Gelegenheit testen.

 

Ich habe inzwischen Kopien der VMs gezogen und kann in geschützter, nicht produktiver Umgebeung testen.

 

Vielen Dank und ich werde meine Ergebnisse hier mitteilen.

 

Lukas

 

Edited by lukasf

Share this post


Link to post
vor 7 Minuten schrieb lukasf:

Die einzige "Fremdsoftware", die läuft, ist Acronis Backup & Recovery Server 11.7. Kann es daran liegen???

Ja, ich denke schon. Acronis nistet sich wie ein Virenscanner tief im System ein. Ich würde es mal ohne versuchen in der Testumgebung.

 

Bei mir haben In-Place-Upgrades von Server 2016 auf 2019 bis jetzt immer geklappt. Es waren aber alles VMs ohne systemnahe Software.

Share this post


Link to post

Guten Abend,

 

heute hatte ich im Testsystem mit einem InPlaceUpgrade Erfolg. Ich habe beim Upgrade lediglich ausgewählt, dass jetzt KEINE Updates gesucht und installiert werden sollen. Und siehe da, der Prozess hat zwar relativ lange gedauert, lief aber erfolgreich durch.

 

Ist jetzt diesees Upgrade mit dem Upgrade samt Updates gleichzusetzen? Ich nehme schon an. Die Updates installiere ich so eben nachträglich. Sehe ich das richtig?

 

Somit würde ich mir die Deinstallation von Acronis also sparen...

 

Danke und Gruß

Lukas

 

 

Edited by lukasf

Share this post


Link to post

Hallo nochmal,

 

Heute Nacht verlief das InPlace-Upgrade erfolgreich. Wie im vorigen Post beschrieben, ohne Installation der Updates während des Vorgangs selber. Die nachträgliche Installation der Windows-Updates hat porblemlos funktioniert.

Danach war eine Neukonfiguration des WSUS notwendig. Die Windowsbereitstellungsdienste musste ich einmal entfernen, wieder installieren und nachkonfigurieren.

 

Die Ursache für das Problem kenne ich also nicht wirklich. Vielleicht Acronis?

 

Danke für eure Hilfe und schönes Wochenende

Lukas

 

Edited by lukasf
  • Thanks 1

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


Werbepartner:



×
×
  • Create New...