Jump to content
loom

Server 2019 Test IPv6 Verständnisfrage

Recommended Posts

HI Leute,

 

ich schlage mich jetzt schon ein paar Wochen mit IPv6 rum, so richtig will es mir nicht einleuchten.

Ich nutze einen Server 2019 als AD, DNS, DHCP für Ipv4 - Routing und RAS aktiviert und als NAT Router konfiguriert.

Also WAN Schnittstelle und LAN Schnittstelle im Server - Clients an der LAN Schnittstelle bekommen ihre IPv4 Adressen zugewiesen klappt alles wunderbar.

 

Jetzt möchte ich mich mehr und mehr mit der IPv6 Geschichte auseinandersetzen doch so richtig komme ich auf keinen grünen Zweig :(

Problem ist glaube ich mein Verständnis des ganzen wobei mir einer bitte helfen müsste.

Ich möchte zusätzlich zum IPv4 NAT,  IPv6 einrichten das heisst ich möchte am Ende weg vom NAT und allen Clients über den Server Zugang zum Internet gewähren, sowie die Clients per IpV6 auch übers Internet erreichen können.

 

Also einfach nur an der WAN und LAN Schnittstelle IPv6 aktiveren und das ganze per SLAAC laufen/konfigurieren lassen funktioniert nicht.

Was habe ich getan:

 - am Telekom Speedport Hybrid Router IPv6 aktiviert, wobei ich dort nichts weiter einstellen ausser IPv6 verwenden und mir eine ULA generieren lassen kann.

 - Virtuellen Server in den per WAN an den Switch des Telekom Routers "gesteckt" und an dessen an die SERVER LAN Schnittstelle einfach einen virtuellen WIN10 Pc angeschlossen 

 - IPv6 aktiviert

 - der Server selbst nutzt das Telekom spezifische Präfix und baut sich eine Ipv6 Adresse zusammen am WAN Port doch am LAN port sehe ich nur eine FE80:xxxx adresse.

 - und der angebundene Client hat keine IPv6 Verbindung - zumindest per test-ipv6.com ... 

Jetzt meine Fragen: :)

 - wie macht man das in der Praxis? nutzt man SLAAC und wenn ja was muss man da alles noch zusätzlich einstellen .. bzw. wäre mir eine Dokumentation dazu lieb... im Netz finde ich nichts wirklich brauchbares ... vllt. kennt einer von euch ein

gutes Tutorial dazu ... für IPv4 gibts die ja nun zu hauf, aber für IPv6 Fehlanzeige,

 - und falls man in der Praxis kein SLAAC nutzt sondern die Adressen zu den Clients per DHCPv6 verteilt - wie route ich dann die IpV6 Adressen aus dem LAN ins Internet? Da ja mein WAN Adpater leider keine Statische IPV6 Adresse bekommen kann da der Prefix des TelekomRouters sich ja doch ab und zu ändert. Und wäre das am Schluss dann eigentlich nicht doch bloss wieder NAT nur mit viiel  mehr Adressen???

 

 

Danke fürs lesen und mich hoffentlich erleuchten ....

 

 

 

 

 

 

Ashampoo_Snap_2020.03.23_18h18m01s_010_.png

Share this post


Link to post
Share on other sites

Hey Dukel,

Leider geht der Hybrid DSL+LTE Spass nur mit dem Speedport :(

Das Problem was ich habe das es nicht funktioniert denke ich liegt am Speedport. Dennoch muss es ja auch dafür eine Lösung geben ;) 

Bzw. wäre es eben für mich auch wichtig zu wissen, wie man sowas in der Praxis löst.... 

 

 

Share this post


Link to post
Share on other sites
vor 6 Minuten schrieb loom:

Bzw. wäre es eben für mich auch wichtig zu wissen, wie man sowas in der Praxis löst....

Am Speedport das IPv6 DHCP abschalten und im Stateless Mode arbeiten - oder, wenn man IPv4 kann, die paasende Literatur zu IPv6 lesen und verstehen.

Start

https://www.elektronik-kompendium.de/sites/net/0812201.htm

 

:-)

Share this post


Link to post
Share on other sites
vor 51 Minuten schrieb Nobbyaushb:

Am Speedport das IPv6 DHCP abschalten und im Stateless Mode arbeiten - oder, wenn man IPv4 kann, die paasende Literatur zu IPv6 lesen und verstehen.

Start

https://www.elektronik-kompendium.de/sites/net/0812201.htm

 

:-)

Hab ich gelesen ... dennoch brauch ich momentan noch ein wenig mehr Praxis ... ums zu verstehen (bzw. die IPv4 Logik Nat etc. abzulegen :) ) und siehe da ein Problem was ich nicht lösen kann.

Weil ich nicht weiss wie das Routeradvertisement von WAN zu LAN weitergegeben werden kann, bzw. ob man das Praxistauglich auch so macht - ich stelle mir da momentan eine Firma mit 1000nden PCs vor und denke da an den Admin der aufgrund des Adresspaces den er vom Provider bekommt, garnicht mehr zuordnen kann wer welche IPv6 bekommen hat...

 

DHCP am Speedport ist aus, da IPv4 DHCP ja der Server macht ... 

 

 

 

Share this post


Link to post
Share on other sites

In einer Firma mit 1000 PCs hat man kein Speedport und man muss nicht wissen, welcher Client welche IP bekommen hat. Selbst bei Server ist das evtl. auch irrelevant. Dafür gibts DNS.

Share this post


Link to post
Share on other sites

@Dukel ok verstanden. 

Wie machen das dann ein Mittelständische Unternehmen? 

 

So wie ich Privat?

Speedport als Modem nutzen - dahinter eine Firewall welche das Advertising übernimmt?

In meinem Fall hier privat funktioniert das ganze ohne Probleme -

- Speedport umgestellt als Modem (kein HybridRouter bei dem kann man den nicht als Modem konfigurieren)

- dahinter einen USG von Ubiquity welcher die Verbindung und das IpV6 Advertising für das gesamte LAN übernimmt.

- das klappt ohne Probleme jeder PC hinter dem USG hat IPv6 Konnektivität und läuft auch nach Modem/USG Neustart also neuem Präfix der Telekom :)

 

Sorry wenn ich mich wiederhole...  

Das ist aber eben nur Privat - wenn ich das ganze jetzt auf ein kleines bis mittelständisches Unternehmen portieren will dachte ich eben an einen Server 2019, bei dem ich per NAP, DHCP, DNS und AD relativ gut Kontrolle über das Client Netz habe.

Oder dann doch der komplett falsche Ansatz?

Wie gesagt nur Testweiser Aufbau zum Verständnis meinerseits - und um ein paar Wissenslücken zu füllen welche man eben am besten in der Praxis erprobt ...

Das Testnetz kann ich leider nur am Speedport Hybrid aufbauen - wenn ich das hier zu Hause aufbaue dann erschlägt mich meine Frau ;) 

In diesen Zeiten ohne Internet - das geht dann doch nicht :)

 

Danke euch!!! 

 

 

Share this post


Link to post
Share on other sites

Firmen haben keinen Speedport sondern wie ich einen Glasfaseranschluß - die meisten meiner Kunden, sogar einiger der ganz kleinen.

 

Ein paar der größeren spielen sogar mit BGP - weil die ein paar Hundert externe IP-Adressen haben, aber das führt jetzt zu weit und ist Off-Toppic

 

Ich habe mal eine Prüfung von einem Auszubildenden der Telekom abgenommen, der hat über Routing von IPv4 über IPv6 geschrieben - ich müsste mal gucken, ob man das frei bekommen kann

 

Auf jeden Fall haben wir mit 8 Prüfern drüber geschaut und keinen Fehler gefunden - der junge Mann ist immer noch bei der T-Kom...

 

Und um auch noch mal deinen letzten Abschnitt zu beantworten - in keiner Firma die ich betreue, regelt sowas ein Windows-Server sondern ein Router bzw. eine vernünftige Firewall

 

My2Cents - und viel Erfolg beim lernen! - Bist du gerade in der Ausbildung?

Share this post


Link to post
Share on other sites

Moin,

 

vor 1 Stunde schrieb Nobbyaushb:

Firmen haben keinen Speedport sondern wie ich einen Glasfaseranschluß

nur der Spitzfindigkeit halber: Ich habe einen Glasfaseranschluss und einen Speedport daran. Das schließt sich ja nun nicht aus.

(Ist aber auch keine Firma.)

 

Gruß, Nils

 

Share this post


Link to post
Share on other sites

Wenn wir schon gerade bei Fehlkonfigurationen sind. Warum hast du auf deinem DC einen Google-DNS als zweien DNS-Server drin stehen? ;-)

Edited by MurdocX

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


Werbepartner:



×
×
  • Create New...