Jump to content
franzjosef

KB4523171 bricht mit 0x80070643 ab

Recommended Posts

Hallo zusammen,

 

ich habe heute versucht das "Security Update For Exchange Server 2016 CU14 (KB4523171)" auf unserem Exchange-Server (2016 CU14) zu installieren. Der Updatevorgang über den Windows-Assi bricht mit 0x80070643. Laut dem Log schafft er es noch diverse Dienste zu beenden und deaktivieren und zeigt dann folgende Fehlermeldung (siehe Log).

 

[13:04:19] -----------------------------------------------
[13:04:19] * ServiceControl.ps1: 10.01.2020 13:04:19
[13:04:19] Performing service control with options: 
[13:04:23] Saving service and registry data
[13:04:23] Saving service state to 'C:\ExchangeSetupLogs\ServiceState.xml'...
[13:04:28] Saving services startup mode.
[13:04:28] Adding to installed roles list: AdminTools
[13:04:28] Adding to installed roles list: ClientAccessMailboxRole
[13:04:28] Adding to installed roles list: Mailbox
[13:04:28] Adding to installed roles list: Bridgehead
[13:04:28] Adding to installed roles list: Mailbox
[13:04:28] Adding to installed roles list: UnifiedMessaging
[13:04:28] Stopping services for the following roles: AdminTools ClientAccess FrontendTransport Bridgehead Mailbox UnifiedMessaging
[13:04:28] Stopping services for 'AdminTools ClientAccess FrontendTransport Bridgehead Mailbox UnifiedMessaging'...
[13:04:29] Stopping service 'WinMgmt'.
[13:05:24] Stopping service 'W3Svc'.
[13:06:54] Stopping service 'SearchExchangeTracing'.
[13:06:54] Stopping service 'MSExchangeUM'.
[13:07:01] Stopping service 'MSExchangeTransportLogSearch'.
[13:07:01] Stopping service 'MSExchangeTransport'.
[13:07:13] Stopping service 'MSExchangeThrottling'.
[13:07:13] Stopping service 'MSExchangeSubmission'.
[13:07:13] Stopping service 'MSExchangeServiceHost'.
[13:07:13] Stopping service 'MSExchangeRPC'.
[13:07:15] Stopping service 'MSExchangeRepl'.
[13:07:25] Stopping service 'MSExchangeMailboxReplication'.
[13:07:25] Stopping service 'MSExchangeMailboxAssistants'.
[13:07:26] Stopping service 'MSExchangeIS'.
[13:07:31] Service 'System.ServiceProcess.ServiceController' is marked that it cannot stop
[13:07:31] Service 'System.ServiceProcess.ServiceController' is marked that it cannot stop
[13:07:31] Stopping service 'MSExchangeFrontendTransport'.
[13:07:35] Stopping service 'MSExchangeFastSearch'.
[13:07:35] Stopping service 'MSExchangeEdgeSync'.
[13:07:36] Stopping service 'MSExchangeDelivery'.
[13:07:39] Stopping service 'MSExchangeDagMgmt'.
[13:07:39] Stopping service 'MSExchangeAntispamUpdate'.
[13:07:39] Stopping service 'MSExchangeADTopology'.
[13:07:50] Stopping service 'IISAdmin'.
[13:07:56] Stopping service 'hostcontrollerservice'.
[13:08:29] Killing instead of Stopping 'FMS'.
[13:08:29] Disabling services for 'AdminTools ClientAccess FrontendTransport Bridgehead Mailbox UnifiedMessaging'...
[13:08:30] Disabling service 'FMS'.
[13:08:30] Disabling service 'hostcontrollerservice'.
[13:08:30] Disabling service 'IISAdmin'.
[13:08:30] Disabling service 'MSExchangeADTopology'.
[13:08:30] Disabling service 'MSExchangeAntispamUpdate'.
[13:08:30] Disabling service 'MSExchangeDagMgmt'.
[13:08:30] Disabling service 'MSExchangeDelivery'.
[13:08:30] Disabling service 'MSExchangeDiagnostics'.
[13:08:30] Disabling service 'MSExchangeEdgeSync'.
[13:08:30] Disabling service 'MSExchangeFastSearch'.
[13:08:30] Disabling service 'MSExchangeFrontendTransport'.
[13:08:30] Disabling service 'MSExchangeHM'.
[13:08:30] Disabling service 'MSExchangeHMRecovery'.
[13:08:30] Disabling service 'MSExchangeIMAP4'.
[13:08:30] Disabling service 'MSExchangeIMAP4BE'.
[13:08:30] Disabling service 'MSExchangeIS'.
[13:08:30] Disabling service 'MSExchangeMailboxAssistants'.
[13:08:30] Disabling service 'MSExchangeMailboxReplication'.
[13:08:30] Disabling service 'MSExchangePOP3'.
[13:08:30] Disabling service 'MSExchangePOP3BE'.
[13:08:30] Disabling service 'MSExchangeRepl'.
[13:08:30] Disabling service 'MSExchangeRPC'.
[13:08:30] Disabling service 'MSExchangeServiceHost'.
[13:08:30] Disabling service 'MSExchangeSubmission'.
[13:08:30] Disabling service 'MSExchangeThrottling'.
[13:08:30] Disabling service 'MSExchangeTransport'.
[13:08:30] Disabling service 'MSExchangeTransportLogSearch'.
[13:08:30] Disabling service 'MSExchangeUM'.
[13:08:30] Disabling service 'pla'.
[13:08:30] Disabling service 'RemoteRegistry'.
[13:08:30] Disabling service 'SearchExchangeTracing'.
[13:08:30] Disabling service 'W3Svc'.
[13:08:30] Disabling service 'WinMgmt'.
[13:08:30] Disabling service 'wsbexchange'.
[13:08:30] Script completed succesfully.

Ich hab das Update als .msp dann manuell heruntergeladen und via Admin versucht zu installieren, mit dem gleichen Ergebnis. Das Zurücksetzen des Windows Update Repositories hat auch keine Besserung gebracht. Der auf dem Server installierte TrendMicro Agent war beim versuch jeweils deaktiviert.

 

Aktiviere ich die Dienste, so wie sie im Log als disabled beschrieben werden und starte den Server neu funktioniert alles wieder, das Update fehlt aber dennoch. Kennt jemand das Problem?

Danke!

 

Ereignisanzeige:

Installationsfehler: Die Installation des folgenden Updates ist mit Fehler 0x8024001E fehlgeschlagen: Security Update For Exchange Server 2016 CU14 (KB4523171)

- <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
- <System>
  <Provider Name="Microsoft-Windows-WindowsUpdateClient" Guid="{945A8954-C147-4ACD-923F-40C45405A658}" /> 
  <EventID>20</EventID> 
  <Version>1</Version> 
  <Level>2</Level> 
  <Task>1</Task> 
  <Opcode>13</Opcode> 
  <Keywords>0x8000000000000028</Keywords> 
  <TimeCreated SystemTime="2020-01-10T12:13:25.046067100Z" /> 
  <EventRecordID>975036</EventRecordID> 
  <Correlation /> 
  <Execution ProcessID="1320" ThreadID="4404" /> 
  <Channel>System</Channel> 
  <Computer>mail.DOMÄNE</Computer> 
  <Security UserID="S-1-5-18" /> 
  </System>
- <EventData>
  <Data Name="errorCode">0x8024001e</Data> 
  <Data Name="updateTitle">Security Update For Exchange Server 2016 CU14 (KB4523171)</Data> 
  <Data Name="updateGuid">{BDE44A64-0908-49F0-B1C9-6AB06BD661CA}</Data> 
  <Data Name="updateRevisionNumber">201</Data> 
  <Data Name="serviceGuid">{7971F918-A847-4430-9279-4A52D1EFE18D}</Data> 
  </EventData>
  </Event>

 

Share this post


Link to post
Share on other sites

Hi,

 

Zitat

[13:07:26] Stopping service 'MSExchangeIS'.

[13:07:31] Service 'System.ServiceProcess.ServiceController' is marked that it cannot stop

[13:07:31] Service 'System.ServiceProcess.ServiceController' is marked that it cannot stop

Der Informationsspeicher kann scheinbar nicht beendet werden. Aus den Known-Issues (https://support.microsoft.com/en-us/help/4523171/security-update-for-exchange-server-2019-2016-and-2013):

Zitat

When you try to manually install this security update by double-clicking the update file (.msp) to run it in Normal mode (that is, not as an administrator), some files are not correctly updated.

Evtl. hilft es bei dir auch, das Update mit Rechtsklick -> "Als Administrator ausführen".

 

Ansonsten könntest du versuchen direkt das CU15 für Exchange 2016 zu installieren.

 

Gruß

Jan

 

Share this post


Link to post
Share on other sites

Hallo zurück,

 

ich habe das CU15 für Exchange 2016 installiert, welches auch Problemlos durchlief. Die Exchange-Dienste kamen nach dem Installations Ende alle sauber hoch und in allen Logs waren keine Fehler. Der Exchange wurde in allen Bereichen "healthy" gemeldet (auch vor dem Update)

 

Dann also sauber neugestartet und bemerkt das die Dienste nicht mehr hoch kommen. Als Urspungsdienst habe ich den nettcpportsharing ausgemacht, der laut Timeout-Fehler nicht hochkommt und damit weitere auch für den Exchange relevanten Dienste nicht starten lässt.

 

Ich habe alle Möglichkeiten geprüft, inkl. der Server Performance, DNS und diverse andere und konnte keine Engpässe oder anderen Fehler feststellen. Gefunden habe ich aber andere Leute in andere Foren mit gleichen Problemen aber teils abweichenden CU Ständen. Eine Lösung war die Anpassung in der Reg:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control
ServicesPipeTimeout DWORD:60000(Dezimal)

Damit habe ich seitdem keine Probleme/Fehler usw. mehr. Ich habe seit Problemlösung durch diesen Eintrag auch mehrere Neustarts durchgeführt und alle Dienste laufen wie sie sollen.

 

Mir wäre es auch lieber gewesen eine genaue Ursache herauszufinden als dumpf und blind ein Timeout anzupassen. Da ich leider den eigentlichen Ursprung dieses Problems nicht festellen konnte freue ich mich dennoch wenn jemand ähnliches feststellen und seine Erfahrungen teilt. Man lernt ja nie aus.

 

In diesem Sinne, danke!

Share this post


Link to post
Share on other sites

die Problematik, dass manchmal nach einem Neustart die Exchange Dienste nicht hoch gestartet wurden hatte ich an einigen Standorten auch. Ich lasse jetzt einfach über den Taskplaner nach dem Neustart mit zwei Minuten Verzögerung ein Powershell Script laufen, dass alle nötigen Exchange Dienste startet. Seit dem ist Ruhe! (Problem ist manchmal, dass die VMs einfach zu schnell starten - die liegen auf einem SAN SSD Storage - und deshalb sind manche Systemdienste die Exchange benötigt einfach noch nicht komplett gestartet ...

 

(Das Powershell Script kann ich morgen gerne posten, wenn es gewünscht wird)

Edited by Squire

Share this post


Link to post
Share on other sites
vor 22 Stunden schrieb Squire:

(Das Powershell Script kann ich morgen gerne posten, wenn es gewünscht wird)

Hi, Danke für deine Erfahrungen. Ein Script habe ich auch schon gefunden. Perse ist mir der Weg mit angepasstem Timeout lieber. Ich hab früher Server bei Kunden gesehen die 20 Minuten für einen Cold-Boot (als VM) benötigt haben. Zum Beispiel völig überladene SBS. Da hatte ich nie solche Probleme. Heute gibts SSDs und Co. und weil es zu schnell ist gibts Probleme? Hast du da eine Quelle dafür? Würde ich gerne besser verstehen können.

 

Danke und Grüße

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


Werbepartner:



×
×
  • Create New...