Jump to content
Sign in to follow this  
Erebos

Windows 2000 Domäne und DNS

Recommended Posts

Habe vor kurzem einen neuen Router fürs Internet bekommen, der den bisherigen Proxy-PC(WINNT4) ersetzten sollte.

Allerdings funktioniert die Anmeldung an der Domäne(Win2kServer) nicht mehr, wenn ich bei den Clients (XP) den primären DNS Server auf die DNS Server des Providers ändere. Im Moment ist als primärer DNS Server der Win2k PC, auf dem der DomäneServer läuft, angegeben.

Auch wenn ich die Win2kServer als sekundären DNS Server angebe funktioniert es ebenfalls nicht.

 

Hat jemand eine Idee, welche Einstellungen noch falsch sein könnten?

Share this post


Link to post
Original geschrieben von Erebos

Im Moment ist als primärer DNS Server der Win2k PC, auf dem der DomäneServer läuft, angegeben.

Hallo Erobos,

 

Warum willst du das ändern ? :confused:

Bei den Clients sollte nur der lokale DNS eingetragen sein.

Share this post


Link to post

hallo!

 

das problem kenne ich - habe ich nämlich auch gerade.

 

es gibt viele viele möglichkeiten, es zu lösen. leider sehe ich nicht "die beste".

 

aber die einfachste, die nix kostet, ist folgende:

 

du trägst bei den clients NUR die dns-adresse des w2k-servers ein.

beim server aktivierst du zusätzlich eine weiterleitung auf die ip-adresse des routers. es geht auch direkt die dns-adresse des providers, ist aber angeblich nicht so sauber. teste also erstmal das erste!

 

tata. fertig.

 

aber: der server muß wohl als gateway auch den router eingetragen habe - glaube ich. muß ich alles selber noch testen.

 

ich suche nämlich eine schöne lösung... aber das wird nur was mit proxy (jana) oder oder!

 

mit alternativem dns gehts wohl nicht.

 

MFG

 

RALF

Share this post


Link to post

@master-obi-wan:

und wie kann ich dann die DNS namen aus dem internet auflösen wenn ich surfe?

 

um dennnoch surfen zu können müsste ich ja irgendwie dns-forwarding machen am server oder? (gateway ip habe ich bereits eingetragen)

Wie macht man soetwas?

Share this post


Link to post

Hallo Erebos,

 

da die Infos die du hier ablieferst etwas spärlich sind, rate ich einfach mal ins blaue:

 

Hast du die Zone "." schon gelöscht ? Wenn nein, dann mach das mal !

Erst danach weiss dein DNS, dass er kein Stammserver ist und fragt weitere DNS-Server ab.

 

Am besten du liest dir mal den KB-Artikel durch, da sind die meisten Fehlerchen schön beschrieben. ;)

Share this post


Link to post

tja so ein bisschen spärlich sind die Angaben schon.

 

vor allem kommt es aber darauf an, was man eigentlich bezwecken möchte:

 

sollen alle pcs einfach so ins internet können, firewall und accesscontrol auf dem router, oder soll der server auch solche aufgaben übernehmen. dann sind erstmal zwei netzwerkkarten im server fällig, der switch ist an der internen netzwerkkarte angeschlossen und der router direkt (oder über einen kleinen hub) an der externen. man setzt dann zwei unterschiedliche ip-kreise ein. als standardgateway wird im dhcp oder in der ip-konfiguration der clients dein server eingetragen, vom router dürfen die nix wissen und sie haben ja auch keinen direkten kontakt.

 

wenn man direkt über den router gehen möchte, dann muss man natürlich die ip-konfiguration der client auf diesen ausrichten.

 

aus meiner sicht ist der verwaltete zugang über den server natürlich zu empfehlen.

Share this post


Link to post

hm, ist doch ein häufiges problem, finde ich...

 

und so wie ich das lese, willst du einfach nur, dass die clients direkt ins netz können, gell?

 

der link von master-obi-wan ist gut... es könnte reichen, wenn du die "." Zone löscht, da Windows selber auf DNS-Server im Netz dann forwarden kann, ohne dass du selber einen weiteren einträgst - was aber auch geht.

 

den gateway wirst du aber benötigen, der aber wie du sagtest auch schon da!

 

Also - wenn du die "."-Zone gelöscht hast, "könnte"/müßte es das gewesen sein!

 

PS: bei den clients natürlich wie erwähnt nur die dns des w2k-servers eintragen!

 

MFG

 

RALF

Share this post


Link to post

Nachdem ich, wie Mcmuc richtig erkannt hat, einfach nur mit den Clients ins Netz will hoffe ich dass das löschen des "." DNS Eintrags reicht (sitze gerade nicht vor der Kiste, werde das aber gleich morgen testen).

 

Möchte mich aber bei allen Bedanken für die super Hilfe!!!

Share this post


Link to post

es ist auf jeden fall richtig, die "."-zone zu löschen - und nötig.

 

es kann aber doch sein, dass danach noch eine forward-ip-adresse eines internet-dns-servers angegeben werden muß.

 

interne adressen löst dann der w2k-server auf, externe werden an diese adresse geschickt...

 

MFG

 

RALF

Share this post


Link to post

Hi to all,

 

So wird es wohl auch gehen aber ich denke das alleine schon aus Sicherheitsgründen (z. B. Email kann nun von jedem Rechner direkt aus dem Web selber entgegengenommen werden - ohne verlässlichen Virencheck ) es eine gute Idee ist es weiterhin über einen Proxy laufen zu lassen. Wurde ja oben schon mal angesprochen (Jana) - ich mache es so und es läuft seit Jahren absolut rund.

 

Gruss Wolke

Share this post


Link to post

@ MCMuc:

 

Das Problem hatten wir glaub ich jetzt schon in vier

Threads :D

 

@ Erebos:

 

Die richtige Antwort und meines Erachtens auch die Beste hat

bereits Tango gegeben ich hab die Konfig mit 2 Nics im Server

und Routing- und RAS auch am laufen und es funktioniert

einwandfrei! Jana- und anderes kannst damit erstmal

ad acta legen. Die "." DNS-Zone muss, wie McMuc schon richtig

gesagt hat, auch weg. Am Client nur die Serveradresse als DNS

und zwar die adresse des Servers, auf dem die Domäne läuft.

Sonst wird das mit der Anmeldegeschwindigkeit an der Domäne

gleich dein nächster Thread :D .

Und vor allem zwei IP-KREISE !!! Ich hatte das ewig in einem

und wunderte mich wieso über den ROUTING und ras Dienst

nichts drüber geht, ich *****.

 

Also dann viel Spaß beim basteln und viel Erfolg!

 

Mfg.

 

Charly

Share this post


Link to post

Moin,

 

bin neu im Forum und lese seit ein paar Tagen als Lurker mit :D aber für die Geschichte hier hätte ich 'nen Tipp:

 

Ich hab bei mir zu Hause folgende Konfiguration laufen:

 

DSL Router mit Firewall

IPCop (Linux Firewall mit Webproxy)

W2k Server

 

Router mit 192.168.0.xx

der IPCop Rechner hat 2 Nics (Nic 1 (Red) 192.168.0.xy / Nic 2 (Green) 10.x.x.x)

W2k Server 10.x.x.y

 

Auf den Clients ist einzig der W2k Server als Defaultgateway und DNS eingetragen (via DHCP). Der W2k macht DNS Forwarding auf die Linuxbox. Diese ist DNS Proxy und der DSL Router bekommt seine Nameserver via DSL Dialin.

 

Das Ganze hat den Vorteil, dass zwei Firewalls aktiv sind. Sprich wenn jemand einbrechen sollte hat er nach der Routerfirewall noch an der Linux Box zu knabbern.

 

Für die Linuxbox reicht ein Pentium 1 mit 64 MB aus. Das Iso-Image gibt es unter http://www.ipcop.org - kann jeder innerhalb weniger Minuten installieren, der Bildschirmdialoge lesen kann ;) IPCop ist unter der GPL - sprich darf sowohl in kommerziellen als auch privaten Umgebungen kostenlos eingesetzt werden.

 

Läuft alles wunderprächtig und stabil - Kostenaufwand minimal und sehr hohe Sicherheit!

 

Ciao

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...