Jump to content
Peterzz

Exchange Powershell nicht funktional?

Recommended Posts

Hallo,

ich habe auf einem Windows Server die Exchange 2013 CU 23 Verwaltungstools und die AD Verwaltungstools installiert, damit ich von diesem Server aus den Exchange Server und das AD administrieren kann.

Nach dem Aufruf der Exchange Management Shell verbindet sich die Shell auch mit dem Exchange Server und mit der MMC U&C kann ich das AD administrieren. 

 

Nun habe ich das Problem, dass nicht alle Exchange Powershell Befehle auf dem System ausgeführt werden können.

Get-MobileDeviceStatistics -Mailbox ... oder Get-MobileDeviceStatistics -Mailbox .... bringt die Fehlermeldung: " Die Benennung "Get-MailboxFolderPermission" wurde nicht als Name eines Cmdlet ..." .

Get-Calendarprocessing -Identity ...  bringt die Meldung "In Active Directory können keine Informationen über den lokalen Server LOKALER SERVERNAME gefunden werden. ..."

 

Woran kann das liegen?

Share this post


Link to post

Moin.

An den Rechten.. Schau dir mal deine Rolegroups an. Ist dein User im Organisationsmanagement? 

 

Gruß mikro

Share this post


Link to post

An den Rechten kann es eigentlich nicht liegen.

Melde ich mich mit dem gleichen Benutzer direkt am Exchange Server an, so kann ich die Befehle ohne Fehlermeldung in der Exchange Shell aufrufen.

Share this post


Link to post
vor 7 Stunden schrieb Peterzz:

An den Rechten kann es eigentlich nicht liegen.

Melde ich mich mit dem gleichen Benutzer direkt am Exchange Server an, so kann ich die Befehle ohne Fehlermeldung in der Exchange Shell aufrufen.

...und dennoch: Wenn einige Exchange-Befehle vorhanden sind und andere nicht, kann es an fast nichts anderem liegen.

Was passiert denn, wenn Du auf dem Management-Rechner aus einer neutralen PowerShell  eine Remoting-Sitzung zu Exchange aufbaust? Kriegst Du die Befehle dann?

Share this post


Link to post

Nehme ich die neutrale Powershell und führe den Befehl "Get-MobileDeviceStatistics -Mailbox Postfachname" aus, erhalte ich die Fehlermeldung: "Get-MobileDeviceStatistics : Die Benennung "Get-MobileDeviceStatistics" wurde nicht als Name eines Cmdlet, einer Funktion, einer Skriptdatei oder eines ausführbaren Programms erkannt. ..."

 

Lade ich innerhalb der neutralen Powershell das Exchange SnapIn mit Add-PSSnapin Microsoft.Exchange.Management.Powershell.Snapin, erhalte ich bei dem gleichen Befehl die Fehlermeldung "Get-MobileDeviceStatistics : "In Active Directory können keine Informationen über den lokalen Server LokalerServername.domain.tld gefunden werden. Grund hierfür kann einer Änderung des Servernamens sein"

Wobei LokalerServername der Name des Servers ist, von dem ich das Powershell Script starte.

Share this post


Link to post

Hi,

 

evtl. "ein Klassiker": Was sagt denn "whoami" in einer Commandline auf dem Managment Server? Bist du mit dem korrekten Domain User oder mit einem lokalen User angemeldet?

 

Gruß

Jan

Share this post


Link to post

 

35 minutes ago, BOfH_666 said:

Vielleicht hier noch mal die von Microsoft eigentlich vorgesehene Weise, sich mit dem Exchange-Server per Powershell zu verbinden:

https://docs.microsoft.com/en-us/powershell/exchange/connect-to-exchange-servers-using-remote-powershell?view=exchange-ps

Ich habe das jetzt mal nach dieser Anleitung von meiner Windows 10 Workstation probiert und es hat funktioniert.

Mit dem Management Server bekam ich wieder die gleiche Fehlermeldung, muss also irgendwie Server liegen :-

Danke an alle für die Hinweise und Tipps.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...