Jump to content
ChritzEDV

Server 2019 Cluster mit 2 Nodes kleine Probleme

Recommended Posts

Hallo zusammen,

ich habe eine Frage bei der mir das "allwissende" Google nicht mehr weiter hilft.

 

Ich habe einen Cluster als Fileserver mit 2 Nodes über Quorum erstellt.

Er läuft auch soweit wie es sein sollte. Bis auf 2 Probleme.

Problem1 (komisch aber nicht so dramatisch):

Wenn ich den Cluster auf einem Node verschiebe (mit Anhalten -> Rollen ausgleichen) bekomme ich eine Warnung:

 

"Die Cluster-IP-Adressressource "Cluster-IP-Adresse" konnte die Lease für IP-Adresse "xxx.xxx.xxx.155" nicht freigeben."

 

Das war eine DHCP Adresse von einem Node bevor dieser eine Feste bekommen hatte. Ich finde keine vernünftigen Ansätze zu dem Problem (wenn es überhaupt eines ist).

 

2tes Problem (schwerwiegend):

Wenn ich einen Node anhalte ist alles gut. Wenn ich nun aber den angehaltenen Node herunterfahre geht auch der Cluster offline.

Hab jetzt gelesen das MS sagt das bei 50% der Cluster herunter gefahren wird. Passiert das deswegen? Dann frag ich mich aber, warum hier nichts darüber steht:

https://docs.microsoft.com/de-de/windows-server/failover-clustering/deploy-two-node-clustered-file-server

 

Kann mir da BITTTEEE jemand weiter helfen, DANKE!

 

Kurz zu den Grundlagen: Unterbau sind 2 ESXis im Cluster an einem SAN. Den Filecluster betreibe ich als Speicherort für die Profile einer Remote Desktop Farm.

 

Gruß,

Christian

Share this post


Link to post

Moin,

 

was hast du denn als Cluster-IP eingetragen? Im Fall des Falles wäre eine Fehlkonfiguration hier mit Sicherheit ein Problem.

 

Zu dem Offline-Schalten des Clusters: Wie hast du denn das Quorum konfiguriert? Das ist ja genau dafür da, dass du nicht einfach in ein 50-Prozent-Problem läufst.

 

Gruß, Nils

PS. es beschleunigt die Antworten in einem Forum nicht, wenn man per Großschreibung "brüllt".

Share this post


Link to post

Hi,

vor 1 Stunde schrieb ChritzEDV:

Kurz zu den Grundlagen: Unterbau sind 2 ESXis im Cluster an einem SAN. Den Filecluster betreibe ich als Speicherort für die Profile einer Remote Desktop Farm.

noch als Ergänzung, der In-Guest Cluster ist in einer supporteten Konfiguration: https://kb.vmware.com/s/article/2147661

 

Gruß

Jan

Share this post


Link to post

Sorry, wollte nicht "brüllen" sondern mich eher bedanken für Antworten!

 

Also schon einmal danke für die Antworten.

 

Auf dem esxsen habe ich das ganze nach etlichen studieren einiger howtos über rdms gemacht.

Windows hat das Qurom auch anstandslos aktzeptiert. Ich kann die Rollen auch ohne probleme von einem Node auf dem anderen schieben. Nur wenn ich ein Node ausmache (z.B. Windows Updates) geht der Cluster Offline.

Für den Cluster habe ich eine feste freie IP Vergeben.

Der Cluster Test hat auch keine probleme festgestellt.

 

Dem link von testperson nach zu urteilen ist die umgebung so supportet (hab das auch zuvor soweit wie möglich geklärt)

Wobei mir grade dies im Dokument auffällt was ich definitiv nicht gemacht habe.

"

2. Modify advanced settings for a virtual SCSI controller hosting the boot device.

Add the following advanced settings to the VMs node:

scsiX.returnNoConnectDuringAPD = "TRUE"

scsiX.returnBusyOnNoConnectStatus = "FALSE"

"

 

das werde ich morgen mal setzen.

 

Anbei noch ein snip der config von einem Node

 

Und nochmals danke.

hardware.PNG

Share this post


Link to post

Moin,

 

Und wie hast du das Quorum nun eingerichtet? Vermutlich nicht korrekt, sonst bliebe der Cluster ja online.

 

Ebenso wäre zu klären, warum der Cluster meint, eine DHCP-Adresse zu verwenden. Da kann ja auch was nicht stimmen.

 

Also bitte mal die Fragen ordentlich beantworten.

 

Gruß, Nils

Share this post


Link to post

Ich versuche mal die fragen so gut ich kann zu beantworten.

Das Quorum habe ich über den Wizard des Cluster-Managers eingerichtet. Anbei der snip.

Warum das mit dem DHCP ist weiß ich eben leider auch nicht. Bei einem ipconfig ist sie niegends eingetragen. Ich habe im DHCP die Adresse mal geblockt um herraus zu finden ob sie erreichbar ist. Ist sie aber nicht. Auch im Server Manager taucht sie nicht auf.

 

VMware ESXi, 6.5.0, 5969303 als Lenovo Image.

Auch das HowTo (entschuldige, aber für meinen begriff ist das auch sowas) von vmware habe ich zu hilfe genommen. Vieleicht nicht zu 100% jeden Punkt davon, das will ich mal nicht behaupten.

 

cl.JPG

sm.JPG

Share this post


Link to post

Auf dem SAN habe ich eigene luns eingerichtet die dann über fc an die ESXen gegeben werden. Dann der ersten vm im Cluster diese als RDM und der anderen vm als bestehenden Datenspeicher.

Beides auf dem 2ten virtuellem scsi controller mit der gleichen zuordnung (was auf 1.1 ist ist auch bei dem 2ten auf 1.1)

hba.JPG

Share this post


Link to post

Genaue Konfiguration.

Compatibility Mode?

SCSI Controller? Typ? Extra Controller?

SCSI Bush Sharing?

 

Wenn man jede Einstellung aus der Nase ziehen muss macht das kein Spaß zu helfen.

 

Kannst du die Quorum Disk zwischen den Knoten switchen?

Share this post


Link to post

Moin,

 

Ich bin ja kein VMware-Spezi - aber liegt in dem RDM nicht vielleicht der Grund, dass der ganze Cluster ausfällt, wenn man einen Node beendet?

 

Gruß Nils

 

Share this post


Link to post

Comp Mode: Physikal

Controller: Paravirtuell

Auf Controller 1 ist nur die boot disk, natürlich nicht shared

Auf Controller 2 sind die shared disks

Entschuldige, SCSI Bush Sharing sagt mir erstmal nix, hab ich was übersehen/lesen?

 

Warum ich das mit rdms machen? Weil ich es nicht besser weiß. Das ist mein kenntnisstand.

Ist es falsch es so zu machen? Gibt es andere wege die einfacher und zuverlässiger sind?

 

@nils: das habe ich mir auch schon gedacht. Dann müsste ja aber zumindest der cluster da bleiben wenn der 2te node mit den shared disk heruntergefahren wird weil ja die erste vm auch der "halter" der rdm ist. Es ist aber egal welche vm ich abschalte. Der cluster geht immer runter.

Share this post


Link to post

Lies mal die Links von mir.

Wenn dir Bus Sharing nichts sagt wirst du das nicht konfiguriert haben. Wie soll das dann mit dem Cluster gehen? Du brauchst eine Shared Storage!

Ich würde einen DL dazu ziehen, der sich die aktuelle Konfiguration anschauen und korrigiert.

  • Thanks 1

Share this post


Link to post

Ich lese mir das mal durch, danke. Der Shared Storage ist aber über das SAN gegeben und es geht ja auch alles. Ich kann ja die rollen verschieben so oft ich will ohne fehler. Auch den Cluster kann ich problemlos verschieben. Bis eben auf die merkwürdige Meldung mit der IP.

So, habs gerafft. Ist spät. Hab gedacht Du meintest mit Typ den Bus Shared. Das hab ich konfiguriert. Und zwar Physikal weil sich beide VMs auf dem gleichen host befinden. Bleibt noch die frage, was meinst du mit "typ"?

controller.JPG

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


Werbepartner:



×
×
  • Create New...