Jump to content
todde_hb

Geplante Aufgabe per GPO startet nicht

Recommended Posts

Hallo,

 

Ziel der Übung ist die Installation von O365 via script. Habe eine USER GPO erstellt in der das script lokal nach %windir%\office_installation.bat gespeichert wird. Das klappt auch. Das Script lässt sich auch ausführen und die Office Installation startet nach Eingabe der Admin Credentials. In der gleichen GPO habe ich auch noch einen geplanten Task hinzugefügt, damit das Script automatisch beim Login des Users ausgeführt wird und das gleich mit Admin rechten. Aber da hapert es. Keine Ahnung wo da mein Konfig- bzw.  vielleicht auch mein Denkfehler liegt. Den Task habe ich wie in den Screenshots zu sehen erstellt.

 

Der Inhalt des Sripts ist ganz simpel:

 

\\server\share\setup.exe /configure \\server\share\configuration.xml

Ist ein mittells ODT bereitgestelltes O365 Setup.

 

Leider wird beim Client auch in der Ereignisanzeige nichts angezeigt, was das Ausführen der GPO oder des Scripts angeht.

 

Nun bin ich etwas ratlos. Hat jemand einen Tipp?

 

 

01.png

02.png

03.png

04.png

Share this post


Link to post

Ich tippe mal, dass das lokale Konto "System" keine Ausführungen im Netzwerk durchführt.

Edited by 4077
komisches Deutsch behoben

Share this post


Link to post

Um das mal anders zu formulieren: Der Trigger ist zwar "Bei Anmeldung eines Benutzers", aber der ausführende User ist SYSTEM. Hat der Computer Zugriff auf den Share? Logging ist wie immer alles... Und Deine Screenshots sind inkonsistent. Im ersten steht als Aktion "Aktualisieren", im letzten "Ersetzen". Beides führt übrigens zu größerem Chaos, wenn im Task ein Ausführungs-Delay konfiguriert ist (was Du leider nicht gezeigt hast).

 

Und die Historie des Tasks könntest Du auch mal prüfen :-)

Share this post


Link to post

Also das share habe ich so konfiguriert, dass alles drauf kommen. Das ist nicht das Problem. Habe im Eventlog jetzt doch ein Hinweis gefunden als Warning:

 

Quote

Das Benutzer "O365 Installation"-Einstellungselement im Gruppenrichtlinienobjekt "O365_Install Office {C2F37E43-208A-4620-8478-4E3C6D6DA5B8}" wurde aufgrund eines Fehlers nicht angewendet. Fehlercode: "0x80070005 Zugriff verweigert" Dieser Fehler wurde unterdrückt..

 

Das merkwürdige ist, dass es einmal an einem Test PC funktioniert hat, obwohl diese Warnung ausgespuckt wurde. Habe für den Scheduled Task jetzt mal anstatt "System" einen Service Account mit Adminrechten genommen. Bringt aber auf anderen Test PCs nichts.

 

@daabm 

 

 

Ja, den Screenshot habe ich erstellt, bevor ich auf "ersetzen" geklickt hatte. Mein Fehler

 

Hier die Historie von einem PC. Kann da nichts ungewöhnliches sehen.

Quote

Informationen    23.01.2020 11:52:11    106    Aufgabe registriert    Info    
Informationen    23.01.2020 11:52:11    141    Die Aufgabenregistrierung wurde gelöscht.    Info    
Informationen    23.01.2020 09:59:04    140    Die Aufgabenregistrierung wurde aktualisiert.    Info    
Informationen    23.01.2020 09:59:04    102    Aufgabe abgeschlossen    (2)    46294950-4217-4ec7-b459-cd8a5f486db8
Informationen    23.01.2020 09:59:04    201    Aktion abgeschlossen    (2)    46294950-4217-4ec7-b459-cd8a5f486db8
Informationen    23.01.2020 09:59:03    200    Die Aktion wurde gestartet.    (1)    46294950-4217-4ec7-b459-cd8a5f486db8
Informationen    23.01.2020 09:59:03    100    Die Aufgabe wurde gestartet.    (1)    46294950-4217-4ec7-b459-cd8a5f486db8
Informationen    23.01.2020 09:59:03    129    Prozess für erstellte Aufgabe    Info    
Informationen    23.01.2020 09:59:03    119    Die Aufgabe wurde durch eine Anmeldung ausgelöst.    Info    46294950-4217-4ec7-b459-cd8a5f486db8
Informationen    23.01.2020 08:42:20    140    Die Aufgabenregistrierung wurde aktualisiert.    Info    
Informationen    23.01.2020 06:59:20    140    Die Aufgabenregistrierung wurde aktualisiert.    Info    
Informationen    23.01.2020 05:16:21    140    Die Aufgabenregistrierung wurde aktualisiert.    Info    
Informationen    23.01.2020 03:33:21    140    Die Aufgabenregistrierung wurde aktualisiert.    Info    
Informationen    23.01.2020 01:50:21    140    Die Aufgabenregistrierung wurde aktualisiert.    Info    
Informationen    23.01.2020 00:07:20    140    Die Aufgabenregistrierung wurde aktualisiert.    Info    
Informationen    22.01.2020 22:24:20    140    Die Aufgabenregistrierung wurde aktualisiert.    Info    
Informationen    22.01.2020 20:41:21    140    Die Aufgabenregistrierung wurde aktualisiert.    Info    
Informationen    22.01.2020 18:58:21    140    Die Aufgabenregistrierung wurde aktualisiert.    Info    
Informationen    22.01.2020 17:15:21    140    Die Aufgabenregistrierung wurde aktualisiert.    Info    
Informationen    22.01.2020 15:32:21    140    Die Aufgabenregistrierung wurde aktualisiert.    Info    
Informationen    22.01.2020 14:18:57    140    Die Aufgabenregistrierung wurde aktualisiert.    Info    
Informationen    22.01.2020 14:13:57    140    Die Aufgabenregistrierung wurde aktualisiert.    Info    
Informationen    22.01.2020 13:49:21    106    Aufgabe registriert    Info    

 

 

05.png

06.png

Edited by todde_hb

Share this post


Link to post

Was ich komisch finde und gerade entdeckt habe ist, dass der Scheduled Task auf dem Test PC immer noch angezeigt wird mit "System", obwohl ich in der GPO längst schon einen ServiceAccount mit Adminrechten eingetragen habe.

 

07.png

08.png

Share this post


Link to post

Neu gestartet hast Du den Rechner zwischendurch schon? Ab- und wieder Angemeldet den User ebenfalls?

 

Womöglich wäre es mit dem WSUS und dem WSUS Package Publisher schneller gegangen. Hier ein paar HowTos zu dem Thema: https://www.wsus.de/wsus-package-publisher/

Share this post


Link to post
5 hours ago, Sunny61 said:

Neu gestartet hast Du den Rechner zwischendurch schon? Ab- und wieder Angemeldet den User ebenfalls?

 

Womöglich wäre es mit dem WSUS und dem WSUS Package Publisher schneller gegangen. Hier ein paar HowTos zu dem Thema: https://www.wsus.de/wsus-package-publisher/

So etwas weiß man hinterher immer besser 😫

 

Neustart war gemacht. Ich probiere mal eine neue GPO anzulegen. Vielleicht bringt das was. Zur Not am Ende WPP

Share this post


Link to post
vor 10 Minuten schrieb todde_hb:

So etwas weiß man hinterher immer besser 😫

Ich habe mich vor vielen Jahren auch mit allen möglichen Methoden abgekämpft, die Kombination WSUS/WPP hat sich als stabil und sehr zuverlässig erwiesen.

Share this post


Link to post

Bei diesem AG haben wir WPP nicht mehr, probier doch zuerst mal aus selbst eine Anwendung zur Verfügung zu stellen. Auf wsus.de > WSUS Package Publisher gibt es ein paar HowTos zu dem Thema. Das ist wirklich nicht schwer.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


Werbepartner:



×
×
  • Create New...