Jump to content
Stibo

Visual Studio Code - IntelliSense bei Powershell

Recommended Posts

Guten Morgen zusammen,

 

ich bin kürzlich auf Visual Studio Code gestoßen und bin ziemlich angetan davon; vor allem, weil die ISE ja anscheinend nicht mehr weiterentwickelt wird. Ich habe allerdings eine Frage bzw. ein Problem: wie kriege ich die IntelliSense für PS bei einer neuen Datei zum Laufen? Existierende ps(m)1-Dateien, die ich öffne, aktivieren es wohl sofort, aber wenn ich eine neue Datei erstelle wird nicht erkannt, dass der Code Powershell ist.

 

Kann man das irgendwo definieren (z.B. jede neue Datei ist erst mal bis zur Änderung PS)? :hmmm:

Bin dankbar für jede Hilfe! :)

Edited by Stibo
Orthographie

Share this post


Link to post
Share on other sites

Ja, das war die erste Extension, die ich runtergeladen habe.

 

Danke für den Link, allerdings hilft die Einstellung leider auch nicht (auch nach einem Neustart des Programms). Ich überlege gerade, ob eine komplette Reinstallation vielleicht helfen könnte (habe das Programm nicht als Portable gewählt).

Share this post


Link to post
Share on other sites

Ich befürchte das geht nicht. Woher voll VS Code wissen, was du schreiben magst. Kann ja auch plötzlich eine andere Sprache sein oder nur eine Text Datei.

Share this post


Link to post
Share on other sites

Hast Du PowerShell auch als Standard-Sprache hinterlegt? (“files.defaultLanguage”: “powershell”,)

 

Share this post


Link to post
Share on other sites

Ja, so sieht meine settings.json aus:

 

{

    "workbench.colorTheme": "Winter is Coming (Dark Black)"

    “files.defaultLanguage”: “powershell”

}

{
    "workbench.colorTheme": "Winter is Coming (Dark Black)"
    "files.defaultLanguage": “powershell"
}

 

Share this post


Link to post
Share on other sites

Das ist ein anderes Zeichen vor Powershell! Ändere das mal ab. Ist vermutlich kopiert, oder?

Sonst wird die ganze Zeile ignoriert.

Bin da auch reingefallen. :-)

Edited by 4077
Ergänzung

Share this post


Link to post
Share on other sites

Ja, war tatsächlich kopiert. Hatte es von Hand eingegeben und es funktionierte immer noch nicht, bis mir auffiel, dass nach dem Theme noch ein Komma fehlte - jetzt geht's. :-) Vielen Dank!

Edited by Stibo
  • Thanks 1

Share this post


Link to post
Share on other sites

Du kannst auch jederzeit <F1> drücken und den Languagemode auf Powershell umschalten, wenn das bei Dir nicht der Standard-Languagemode ist.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


Werbepartner:



×
×
  • Create New...