Jump to content
Shemeneto

10G Nic auf Hyper-V 2019 VM nicht funktionsfähig

Recommended Posts

Hallo,

 

ich teste gerade auf einem Testserver (eigene NICs sind nur 1G) mit installiertem Windows Server 2019 und Hyper-V Rolle eine 10G Verbindung.
Vom Host selbst aus funktioniert diese wunderbar. Binde ich die 10G Karte allerdings in einem "Virtuellen Switch" und starte eine VM (egal ob Server 2019 oder Windows 10) damit, bekomme ich keine Konnektivität.
Aber erst im Windows selbst. Starte ich eine VM mit PXE über WSUS lädt er das Startimage und ich kann auch ein Image auf die Maschine installieren...

Die Netzwerkkarte ist eine EDIMAX EN-9320TX-E (mehr war für einen Test nicht im Budge und war auch die Einzig lieferbare...). Die Treiber sind laut Hersteller bis Server 2016 getestet.

 

vG Shemeneto

Share this post


Link to post
Share on other sites

Hi,

 

und das

vor einer Stunde schrieb Shemeneto:

Binde ich die 10G Karte allerdings in einem "Virtuellen Switch" und starte eine VM (egal ob Server 2019 oder Windows 10) damit, bekomme ich keine Konnektivität.

tust du genau wie?

 

Gruß

Jan

 

Share this post


Link to post
Share on other sites

Eigenschaften des vSwitch:
- Externes Netzwerk 
- "gemeinsames Verwenden..." ist deaktiviert (dafür ist ein anderer virtueller Switch mit OnBoard NIC konfiguriert)

- SR-IOV ist deaktiviert 
- ansonsten Standard

 

Eigenschaften der Netzwerkkarte in der VM:
- Netzwerkkarte: Standardeinstellungen
- Hardwarebeschleunigung sind alle Features deaktiviert (wird keines von der NIC unterstützt!)
- erweiterte Features: Standardeinstellungen

 

aber es ist eigentlich egal was ich einstelle. Es funktioniert nicht...
 

Share this post


Link to post
Share on other sites
Am 10.5.2019 um 22:56 schrieb Nobbyaushb:

Ist die Karte in der HCL von Hyper-V, gibte es einen Treiber vom Hersteller für das verwendete Server-OS?

Natürlich nicht...
Werde mal ein Windows 2016 Server aufsetzen. Dafür ist der Treiber zertifiziert...

Share this post


Link to post
Share on other sites

Hast du mal getestet nur die 10G Karte zu benutzen? Also 1G komplett deaktivieren und dann einen neuen vSwitch mit der 10G Karte inkl. Management erstellen?

Share this post


Link to post
Share on other sites

Deswegen habe ich nach der Gegenstelle gefragt - wenn dort ein Unifi-Switch verbaut ist, kann der ggf. ein-oder zweimal LWL und ich hätte ggf. was auch der Spielekiste...

Und die 10G bei Unifi kosten (mich) keine 60€

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


Werbepartner:



×
×
  • Create New...