Jump to content

Sharepoint Foundation 2013 + Web App Server


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

moinmoin ...

 

... nachdem ich nun in einer Testumgebung meinen SharePoint Foundation 2010 erfolgreich zu SahrePoint Foundation 2013 migrieren konnte, stehe ich nun vor dem nächsten Planungsziel:

Einbindung eines Web App Servers ...

 

Diesen habe ich mittlerweile auf einem Windows 2008 R2 SP1 installiert.

Ein Server Zertifikat für HTTPS ist installiert und die Farm ist erstellt.

interne URL : https://srvwebapp

externe URL : https:/webapp.meinedomain.de

 

Auf dem SharePoint wurde die Verbindung zu webapp.meinedomain.de erstellt und die WOPI Zone auf "external-https" festgelegt.

 

Der SharePoint ist ebenfalls via HTTPS erreichbar (https://shares.meinedomain.de)

 

Auf dem SharePoint an sich scheint alles zu laufen.

Was nicht klappt, ist das Öffnen oder Anlegen von Dokumenten.

Hier ist es auch egal, ob es sich um Word oder Excel handelt ... keine Variante funktioniert.

 

Es erscheint in allen Fällen eine Meldung, dass die Dokumente nicht gefunden werden konnten.

Im SharePoint sind sie verfügbar ...

Klicke ich eins an, wird der WebAppServer aufgerufen und dann kommt die Fehlermeldung.

 

Gleiches beim Neu-Anlegen eines Dokuments.

Es kommt noch das Eingabefenster, dass den Namen des Dokumentes abfragt, und danach kommt der Fehler ...

 

Sieht für mich irgendwie nach einem Berechtigungsproblem aus.

Als ob ein WebAppServer-Dienst nicht die Berechtigung hat, das übergebene Dokument zu öffnen.

 

Hoffe, jemand hat eine Idee ...

Link to comment

Hi

 

Nimm doch Dein Public Zertifikat und setze den internen DNS Server wie die Externe Adresse:

 

zb. webmail.firma.de

 

Machst alles gleich. Zertifikate müssen auf beiden Seiten stimmen! Sprich das gleiche sein.

 

Schau im TechNet für Exchange 2013 mit WebApps da findest Du gleich den Thread für SharePoint 2013.. ;)

 

Gruss

Link to comment

Der SP-Server muss mit dem Office WebApp-Server kommunizieren können. Der WebApp-Server braucht meiner Meinung nach keine externe Adresse oder Domain. Das SSL-Zertifikat muss dann natürlich für die interne Adresse ausgestellt sein und der SP-Server muss den Zertifikate vertrauen (am Besten über eine interne CA.

Link to comment

Sind beide Server in der selben Farm? Laufen alle Benötigten Dienste auf den Servern? Sind die Webapplikationen richtig konfiguriert.

 

Waren die Webapps bei Sharepoint 2010 auch schon integriert und liefen? Wie hast du die Farm migriert?

Gibt es Fehler in den Logs? Gibts es Korrelations ID's?

Link to comment
  • 4 weeks later...

Der SP-Server muss mit dem Office WebApp-Server kommunizieren können. Der WebApp-Server braucht meiner Meinung nach keine externe Adresse oder Domain. Das SSL-Zertifikat muss dann natürlich für die interne Adresse ausgestellt sein und der SP-Server muss den Zertifikate vertrauen (am Besten über eine interne CA.

Das war der Weg zum Erfolg ...

Eine interne CA hatte ich bereits auf dem DC.

Also habe ich im IIs eine Domain-Zertifikat generiert.

Der SharePoint musste auf external-https stehen, aber der webapp-server musste mit dem lokalen FQDN eingetragen werden ...

Link to comment
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...