Jump to content
Sign in to follow this  
Aronosky

2K3 - Proxy Einstellungen werden für IE7 nicht übernommen

Recommended Posts

Hallo zusammen,

 

Ich habe folgendes mysteriöses Problem:

 

Per GPO werden die benötigten Proxy Einstellungen verteilt. Dies funktioniert auch mit dem IE6 (der von der Kundensoftware bis dato leider gefordert wurde). Nun muss aber auf mehreren Clients IE7 installiert werden...und dort beginnt das Problem.

 

Per gpupdate/z werden die Proxyeinstellungen alle korrekt angezeigt und auch sonst kommt es zu keinen Fehlern.

 

Die Gopher Einstellungen habe ich deaktiviert (da diese vom IE7 sowieso nicht unterstützt werden).

 

Das Problem ist, dass in der Registry unter: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings

 

Die Punkte: "ProxyEnable"

"ProxyServer"

"ProxyOverride"

 

nicht eingetragen werden.

 

Wenn ich diese einfach Importiere funktioniert alles wie es soll...

 

Nur zum Verständnis:

 

Die Mitarbeiter haben keine festen Arbeitsplätze, jeder kann sich an jeden Platz setzten um dort zu arbeiten. Beim Anmelden wird ein lokales Profil erstellt womit er aber alle für ihn/sie wichtigen Programme und Fuktionen zur Verfügung hat.

 

Nun die eigentliche Frage: Woher kann dieses Problem noch rühren?

 

Ich würde mich über Lösungsansätze freuen.

 

Domäne: Windows Server 2003 Standard

Clients: XP SP3

 

 

Danke fürs Lesen!

Share this post


Link to post
Share on other sites

Hi!

 

Der Proxy wird über die Administrative Vorlage "inetres.adm" konfiguriert.(Die beim IE7 dabei war).

Die Richtlinie läuft über die OU in der sich sämtliche User befinden.

 

 

WPAD wäre wohl auch noch eine Alternative, jedoch müsste ich erst abklären (über mehrere Wege) ob diese Umstellung überhaupt so gewünscht ist.

 

Ob WPAD allerdings das Problem lösen würde, ist auch noch eine gute Frage!

 

Danke aber schonmal für die Antwort!

Share this post


Link to post
Share on other sites

Per gpupdate/z werden die Proxyeinstellungen alle korrekt angezeigt und auch sonst kommt es zu keinen Fehlern.

 

Die Gopher Einstellungen habe ich deaktiviert (da diese vom IE7 sowieso nicht unterstützt werden).

 

Das Problem ist, dass in der Registry unter: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings

 

Die Punkte: "ProxyEnable"

"ProxyServer"

"ProxyOverride"

 

nicht eingetragen werden.

 

Wenn ich diese einfach Importiere funktioniert alles wie es soll...

 

Ich würde die Einstellungen per Group Policy Preferences verteilen. GPP - Group Policy Preferences - Gruppenrichtlinien Einstellungen

Share this post


Link to post
Share on other sites

Hallo Sunny!

 

Danke für den Tip. Die GPP sieht sehr verführerisch aus. Ich werde sie im nächsten Jahr mal direkt ausprobieren.

 

Da nur 8 von knapp 400 Client von diesem Problem betroffen sind (Sprich den IE 7 brauchen) , lasse ich die Reg bei den 8 Clients per Startskript importieren.

 

Sobald ich die GPP ausprobiert habe werde ich aber berichten.

 

Vielen Dank für die Hilfe und Anregungen!

Share this post


Link to post
Share on other sites

Hallo zusammen,

 

Ich wollte euch einmal auf den neusten Stand bringen.

 

Nun habe ich folgendes Problem...

 

Die Umstellung auf die GPP soll nun doch nicht erfolgen (warum auch immer...)

 

Nun soll das alte System, sprich die einfache Proxyverteilung über die GPO wieder eingeführt werden. Momentan werden die Proxy Einstellungen einfach per Reg Key importiert. Dies funktioniert auch ohne Probleme. Warum wieder auf das alte System umgestellt werden soll bleibt mir ein Rätsel :confused: ...ist aber leider nicht meine Entscheidung.

 

Nun habe ich das die REG Datei wieder aus dem Startskript rausgenommen...dann kam die böse Überraschung... die Einstellungen werden von der GPO nicht mehr richtig angezogen. Die GPO an sich ist unverändert.

 

Woran könnte das liegen? Hat jemand eine Idee?

Bis Ende der Woche soll der alte Zustand wieder hergestellt sein. :eek:

 

Vielen Dank schonmal fürs lesen!

Share this post


Link to post
Share on other sites
......Nur zum Verständnis:

 

Die Mitarbeiter haben keine festen Arbeitsplätze, jeder kann sich an jeden Platz setzten um dort zu arbeiten. Beim Anmelden wird ein lokales Profil erstellt womit er aber alle für ihn/sie wichtigen Programme und Fuktionen zur Verfügung hat.

 

Nun die eigentliche Frage: Woher kann dieses Problem noch rühren?

 

 

Bis eine GPO auf einem einem neu erstellten Profil wirkt, ..... . Was sagt denn gpresult.msc?

 

Wie wäre es mit servergespeicherten Profilen für die User? Oder mit einer zentralen Vorlage für ein neues lokales Profil?

Share this post


Link to post
Share on other sites

Hallo lefg!

 

Danke für die schnellen Antworten. Servergespeicherte Profile wurden abgelehnt da die Useranzahl und Mitarbeiterfluktuation viel zu hoch ist.

 

Wo jetzt der Knackpunkt war kann ich nicht genau sagen,da die Einträge bei den Usern in der REG alle richtig übernommen...jedoch anscheinend nicht richtig angewendet wurden.

 

Auch gpresult war komplett in Ordnung. Sonst hätte ich dieses auch erwähnt.

 

Folgendes habe ich dann durchgeführt:

 

Die Proxyausnahmen wurden ausgemistet (da sich dort über die Jahre wohl vieles angehäuft hat) und über das gute * konnten auch viele Einzeleinträge zusammengefasst werden.

Auch waren viele Einträge doppelt...sprich einmal mit http einmal ohne usw.

 

Nach der kompletten GP Überarbeitung (Auch Startskripte wurden ausgemistet) funktioniert nun alles wieder wie es soll....und das beste daran...auch mit IE7.

 

Auf der einen Seite gut...auf der anderen Seite hätte ich gerne dem Unternehmen GPP näher gebracht.

 

 

Aber ich danke euch nochmal für die Hilfe!

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...