Jump to content
Sign in to follow this  
Dark1

einem GPO-Problem

Recommended Posts

Hallo Kollegen!

 

Ich stehe vor einem kleinen Problem und hoffe, daß mir hier jemand helfen kann. In einem Projekt das ich leite hätte gerne der Kunde, daß die Proxy-Einstellungen des IE über GPO abhängig von dem Standort des angemeldeten Laptops zugewiesen werden. Soweit erst einmal kein Problem. Das wollen wir lösen, indem wir die GPO auf AD-Standortebene ansetzten. Der Haken ist, daß wir gerne hätten, daß gar keine Proxy-Einstellungen verwendet werden wenn der Mitarbeiter sich nicht im Firmennetzwerk anmeldet. (z. B. im Hotel sitzt und surfen möchte)

 

Hat jemand von Euch eine Idee wie ich das lösen kann? Oder noch besser Erfahrung mit einer solchen Situation? Ich habe überlegt WMI-Filter einzusetzen, kenne mich aber leider zuwenig mit der Syntax aus um zu wissen wonach ich suchen muß.:confused:

Share this post


Link to post

Hallo,

 

ich bin mir nicht sicher, aber ich glaube mit WMI kommen wir da nicht weiter. Die Erkennung einer "Slow-Link"-Verbindung wird glaub ich immernoch über eine Berechung von Laufzeiten bei Pings gemacht.

 

In den GPOs kann man einstellen, was als Slow-Link gilt. Sollte eine Verbindung unter dieser Schwelle liegen, wird sie als Slow-Link erkannt und bestimmte Prozesse laufen nicht wie beispielsweise Anmeldeskripte.

 

Also wäre es eine Möglichkeit die Proxy-Einstellungen über ein Anmeldeskript zu setzen und dann per Slow-Link-Detection den "Hotel"-Usern die Ausführung dieses Skriptes verweigern.(Aber dabei auf alle anderen Komponenten der GPOs achten, die von einer Slow-Link-Detection abhängen!!!)

 

Details für Slow-Link-Verbindungen gibts bei MS unter dem Artikel D227260....

Share this post


Link to post

Hi Onewayticket!

 

das ist leider keine Option. Der Kunde arbeitet mit verschlüsselten Offline-dateien... :rolleyes:

 

Hallo und Willkommen,

 

Vieleicht solltet Ihr einen 2ten User für diese Zwecke anlegen.

zb. user: Hans.Meier und Hans.Meier-Hotel

 

MfG

Onewayticket

Share this post


Link to post
Hallo,

 

ich bin mir nicht sicher, aber ich glaube mit WMI kommen wir da nicht weiter. Die Erkennung einer "Slow-Link"-Verbindung wird glaub ich immernoch über eine Berechung von Laufzeiten bei Pings gemacht.

 

In den GPOs kann man einstellen, was als Slow-Link gilt. Sollte eine Verbindung unter dieser Schwelle liegen, wird sie als Slow-Link erkannt und bestimmte Prozesse laufen nicht wie beispielsweise Anmeldeskripte.

 

Also wäre es eine Möglichkeit die Proxy-Einstellungen über ein Anmeldeskript zu setzen und dann per Slow-Link-Detection den "Hotel"-Usern die Ausführung dieses Skriptes verweigern.(Aber dabei auf alle anderen Komponenten der GPOs achten, die von einer Slow-Link-Detection abhängen!!!)

 

Details für Slow-Link-Verbindungen gibts bei MS unter dem Artikel D227260....

 

Das scheint mir etwas zu kompliziert, schließlich gibt es ja alle Schalter in der GPO... :confused:

 

Ich tippe deshalb auf WMI-Filter, da es ja feststellbar ist ob der User sich an der Domäne oder mit seinen lokalen (Profil) Informationen angemeldet hat.

Share this post


Link to post

Hi,

 

ich würde auch die Slowlink-Variante nehmen. Da wird funzen, leg es über die anderen GPO´s für die jeweiligen Nutzer.

 

Ich kann das leider nicht testen, aber probier doch einfach mal in den lokalen Policies die Proxy-Werte auf nicht definiert zu setzen.

 

Wenn dat allet nicht funzt, dann gib dem User (wenn er damit umgehen kann) das Proggie: Mobile Net Switch

Damit kann er per Knopfdruck vorkonfigurierte Netzwereinstellung nehmen.

Share this post


Link to post

Du kannst doch einen Proxy per GPO setzen, aber der User kann ja die verwendung des Proxies selber wieder ausschalten. Das sollte das Problem doch beheben?!

 

 

grizzly999

Share this post


Link to post
Du kannst doch einen Proxy per GPO setzen, aber der User kann ja die verwendung des Proxies selber wieder ausschalten. Das sollte das Problem doch beheben?!

 

Das dürfte wohl kaum eine praktikabele Lösung sein. Irgendwelchen Usern einfach zu sagen, die sollen an ihren Proxy-Einstellungen rumfummeln. Da freut sich die Hotline!!!

 

Ausserdem, man implementiert Gruppenrichtlinien ja grade weil man Einstellungen zentral (und zwingend) setzen und kontrollieren will!

Share this post


Link to post

Wie wäre es denn mit verschiedenen Hardwareprofilen?

Bei dem einen ist dann ein Proxy eingetragen, beim anderen nicht bzw. ein anderer?

Gruß,

Frauke

Share this post


Link to post
Wie wäre es denn mit verschiedenen Hardwareprofilen?

Bei dem einen ist dann ein Proxy eingetragen, beim anderen nicht bzw. ein anderer?

Gruß,

Frauke

HW-profile speichern keine Usereinstellungen (wie z.B. Proxies) sondern Hardwaresache. Daher der Name

 

grizzly999

Share this post


Link to post
Du kannst doch einen Proxy per GPO setzen, aber der User kann ja die verwendung des Proxies selber wieder ausschalten. Das sollte das Problem doch beheben?!

 

 

grizzly999

 

Das ist leider auch keine brauchbare Lösung. Die User haben nicht das nötige Wissen, um das zu machen und wir wollen Ihnen auch garnicht die Rechte dafür geben.

 

Die Script lösung kommt aber auch nicht in Frage, da es ein kleines Problem gibt. Die Einstellungen des Scripts müssen ja auch irgendwie weg. Natürlich könnte man ein Abmeldescript schreiben, aber das ist nun wirklich von-hinten-durch-die-Brust-ins-Auge gearbeitet. Ich brauche eine Profi-Lösung...:confused:

Share this post


Link to post
.... Ich brauche eine Profi-Lösung...:confused:

 

Also, nach meinem Wissen gibt es keine Möglichkeit über WMI die Verbindungbandbreite abzufragen. Vielleicht gibts ein kompliziertes Konstrukt mit ner Kombination aus Abfrage welcher Netzwerkadapter aktiv ist, ob ne einwahl passiert ist usw..

WMI arbeitet da leider sehr rudimentär......

 

Übr.: Der Weg das über Slow-Link-Detection und Scripts zu machen ist durchaus so üblich und wird in vielen Bereichen so implementiert.

Share this post


Link to post

Ein ISA Server könnte das mit installiertem Firewallclient, der die Proxyinformationen vom ISA abruft. Wenn kein ISA vorhanden, dann trägt er auch keinen Proxy ein.

 

 

grizzly999

Share this post


Link to post

Ich habe gerade die Lösung von den MS-Newsgroups bekommen. Das was ich erreichen will kriege ich mit den wpad-Dateien hin! http://www.msisafaq.de/Anleitungen/2000/Installation/wpad.htm

 

Übrigens, ich wollte nicht mit WMI die Leitungsbandbreite rauskriegen, sonder wann ein Client sich mit den "Stored Credentials" angemeldet hat... Egal, hab jetzt meine Lösung. Danke noch mal an alle!:p

Share this post


Link to post

Hi

 

 

 

Wie schauts mit 2 Startprofilen aus? Eins für intern eins für zB. hotels? Gleicher nutzer in beiden fällen sollte doch dann keine problem mehr geben. Wenn ich da jetzt nicht falsch liege sollte das doch die einfachste Lösung sein?

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...