Jump to content
Sign in to follow this  
jock1307

w2k Server - Raid5 defekt nach Gewitter

Recommended Posts

Hallo,

 

gestern Nacht ist unser Server bei einem Gewitter abgeraucht - mitten in der Datensicherung.

 

Problem ist jetzt, unser Adaptec 2120s erkennt den Raid5 Array nicht mehr.

 

Folgendes habe ich bereits gemacht:

 

1. Das vorhandensein der HDDs überprüft - werden erkannt (3x IBM 68,3 GBHDD)

2. Mit "Verify Disk Media" erstmal nach Datenfehlern gesucht - kein Ergebnis zeigt aber 68,3GB pro Platte an.

3. Versucht den Array neu zu erstellen - und da wirds komisch:

Die Platten werden angezeigt, mit korrekter ID und allem nur zeigt er lediglich 64KB als Größe an und wenn ich Sie dem Array hinzufügen möchte sagt er mir (übers.) "mit der Anzahl der von Ihnen gewählten Festplatten kann kein Array erzeugt werden".

 

Hat jemand ne Idee?

 

Grüße, Christoph.

Share this post


Link to post

Nach einem Stromschlag kann nun wirklich alles mögliche kaputt sein.

 

Vielleicht der Controller ?

 

-Zahni

Share this post


Link to post

Vielleicht fehlt eine Spannung am Netzteil ? Z.B. 12V. Das Mobo braucht die nicht. Aber die HD's u.U.

 

-Zahni

Share this post


Link to post

Die HDs "spinnen" ganz normal hoch, werden erkannt und können geprüft werden, keines der Netzteile gibt auch nur einen Mucks von sich (normal starten die ein Inferno von piepgeräuschen, wenn da was faul ist).

 

Christoph

Share this post


Link to post

So, habe jetzt zwei alte 17er drangehängt, lasse sie jetzt gerade initialisieren und sehe dann, ob ich daraus ein Raid stricken kann (die aktuellen kann ich ja nicht testen, da durch eine initialisierung die Daten verloren gehen) - dann weis ich, ob der Controller O.K. ist.

 

Christoph

 

edit: Controller scheint zu funktionieren, erstellt gerade problemlos den Array auf den "alten" Platten.

Share this post


Link to post

Mal den Adaptec Support bemühen, wenn die Daten wichtig sind. Die kennen sich da bestimmt am besten aus und haben entsprechende Erfahrung mit solchen Fällen.

 

Edit: Da war mein Tipp nicht schnell genug:

Vielleicht testweise mit anderen Festplatten versuchen ein neues RAID aufzubauen, um zu testen ob der Controller noch geht.

Share this post


Link to post

Also, Adaptec hat zu folgenden Schritten geraten:

 

Festplatten initialisieren (Array wird gelöscht), neuen Raid-Verbund erstellen (gleiche Konfiguration wie zuvor) und dann mit Quick Init laufen lassen.

Bei Erfolg sollte ich dann das ganze aus dem Raid Manager in Windows mit der Option "Verify" wieder in den Status "Optimal" bringen können.

 

Ergebnis:

 

Positiv: Das Raid läuft wieder und glücklicherweise sind die Datenpartitionen unberührt geblieben.

Negativ: Die Systempartition ist vollständig hinüber d. h. die Verzeichnisstruktur ist zerstört (auf c:\ kein "dir" mehr mögl.)

 

Ergo: DC neu aufsetzen und hoffen, daß ich den Systemstate wieder von der Sicherung reingebraten bekomme (SID lässt grüßen) - ansonsten gibbet noch ne lange Nacht...

 

Ansonsten danke für eure Hilfe!

 

Grüße,

 

Christoph

Share this post


Link to post
DC neu aufsetzen und hoffen, daß ich den Systemstate wieder von der Sicherung reingebraten bekomme (SID lässt grüßen)

Wenn der DC wieder steht ab und an mal ein ASR Backup machen, dann hast du das Problem nicht!

Berichte mal was deine Versuche ergeben haben!

Share this post


Link to post

Mal abgesehen von der Lösung für Dein Problem - Vielleicht solltest Du Dir mal überlegen, den (die) Server in dieser Hinsicht abzusichern.

Meistens werden Server zumindest an eine USV gehängt, welche als Nebeneffekt auch den Strom filtert. Zusätzliche Überspannungsfilter (vor der USV) sind sicherlicht auch kein Fehler.

Share this post


Link to post

@PAT: ist alles vorhanden und die USV läuft auch anstandslos, ein Überspannungsschutz ist auch vorgeschaltet, das Prob. ist, daß ich denke, die fehlspannung kam (obwohl dort auch ein entsprechender Schutz installiert ist) über ISDN (Datev).

 

@Christian: Problem war, daß wir gerade ein neues Bandlaufwerk eingebaut haben, das nicht auf Anhieb lief (Veritas hat gezickt), ergo kamen wir noch nicht dazu die volle Sicherung zu machen (ist keine Ausrede, ich weis) - Nachher ist man immer schlauer und Murphys Law hat hier mal wieder voll zugeschlagen...

Share this post


Link to post

Also, hier der Endstand:

 

da die aktuelle Sicherung der Systempartition defekt war mussten wir auf eine ältere zurückgreifen, daher kamen noch einige Stunden Anpassungen der Datev-Plattform hinzu.

Die Datenbanken auf der noch erhaltenen Datenpartition waren nat. alle im Betrieb abgeschmiert und daher inkonsistent, ließen sich aber problemlos von der Sicherung wieder einspielen.

 

Fazit der Geschichte - ab Fehlereintritt über 20h Arbeit die Sache wieder ans Laufen zu bringen, die Größte Arbeit waren die nachträglichen Anpassungen an Datev.

In Folge dieser Aktion wird Die Datensicherung jetzt noch einmal überarbeitet und (danke ChristianHemker) um ASR (bei änderungen am System) erweitert.

 

Grüße, Christoph.

Share this post


Link to post

In Folge dieser Aktion wird Die Datensicherung jetzt noch einmal überarbeitet und (danke ChristianHemker) um ASR (bei änderungen am System) erweitert.

 

Wenn das Sicherungskonzept steht, würde ich ab und an mal ein Desaster Recovery durchführen:

1. Server per Image sichern (Norton Ghost 2003 macht immer noch wunderbare Offline Images)

2. Alternativ neue Festplatten (temporär) einbauen

3. Das ASR Backup und alles Daten zurückspieln

4. Hoffen das alles läuft ;)

 

PS: Nichts zu danken!

Share this post


Link to post

Heute morgen komplett neuer Fall an der gleichen Domäne, mehrere Clients können sich nicht anmelden.

Also habe ich mich lokal angemeldet, mich von der Domäne abgemeldet um mich im Anschluss wieder anzumelden.

Folgende Fehlermeldung tritt auf:

 

Mehrfache Verbindungen zu einem Server oder einer freigegebenen Ressource von demselben Benutzer unter Verwendung mehrerer Benutzernamen sind nicht zulässig...

 

NET USE zeigt allerdings keine Verbindungen, die ich trennen könnte.

edit: ich kann allerdings ohne Einschränkungen auf die Serverfreigaben zugreifen.

 

Hat jemand ne Idee?

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...