Jump to content
Sign in to follow this  
KingSoft

2 Subnetze

Recommended Posts

Hallo Leute,

 

ich habe mal eine Frage zum Netzwerk bei einem Kunden.

 

Es gibt 2 kleine P-to-P-Netze mit je einem Switch. Folgende Subnetzadressen werden verwendet:

- 192.168.1.x für Netz 1

- 192.168.2.x für Netz 2

Diese beiden Netzte wurden nun zusammengeschlossen (Ein Patch-Kabel verbindert jetzt beide Switches) da der Anwender aus Netz 2 auch auf eine Freigabe im Netz 1 zugreifen will.

 

Konkret:

Netz1: Server: 192.168.1.1 (Win98SE), AP1: 192.168.1.2 (Win98SE), AP2: 192.168.1.3(XP Pro) .....

Netz2: Server: 192.168.2.1 (XP Pro), AP1: 192.168.2.2 (Win98SE), AP2: 192.168.2.3 (XP Pro) .....

 

Mit dem AP2 aus Netz2 will er auf eine Freigabe auf Server1 im Netz 1 zugreifen.

Dem AP2 aus Netz2 habe ich zusätzlich die IP-Adresse 192.168.1.103 gegeben, ein Ping auf 192.168.1.1 (Server Netz 1) funktioniert einwandfrei;

jedoch sagt ein netuse auf die Freigabe "Der Netzwerkpfad \\192.168.1.1\C_Rohr-C wurde nicht gefunden" !

Warum?!

 

Könnt ihr mir helfen?

Grüße Bernd

Share this post


Link to post

hi,

 

wenn du 2 subnetze verbinden will, wirst du über routing nicht hinauskommen.

Entweder lässt du einen Windows Rechner mit 2 Netzwerkkarten das übernehmen oder du besorgst dir einen Hardware-router.

 

lg

il_principe

Share this post


Link to post

Herzlichen Dank für die schnellen Antworten.

 

Die Sache mit dem dirthy hack werde ich nächste Woche testen.

 

Aber trotzdem habe ich noch eine Verständlichkeits-Frage:

 

Durch den eintrag einer zweiten IP-Adresse im PC des 2. Netzes hat der PC doch ganz "normalen" zugriff auf das 1. Netz; ( das anpingen klappt ja ausgezeichnet), also verhält sich der PC doch als wäre er im ersten Subnetz, oder?

Dann frage ich mich was der unterschied zwischen anpingen und SMB-Freigabe ist. Ist für den Zugriff auf SMB unbedingt routing nötig?

Share this post


Link to post

Ist schon ok mit deiner 2. Adresse... also den Effekt mit \\IP-Adresse\Freigabe - geht nicht

Habe ich auch schonmal gehabt...

versuch einfach den Namen des PCs anzugeben... der sollte ja über Netbios aufgelöst werden können - ansonsten mal die XP Firewall testhalber deaktivieren... ggf. für SMB Zugriff auf das andere Netz konfihurieren..

Share this post


Link to post

Hallo,

 

du kannst darüber nachdenken,

 

sollen die beiden Netze mittels Routing verbunden werden

 

oder

 

ist es möglich und sinnvoll die Adressierung eines Netzes an das andere anzupassen

 

und die Netze damit zu vereinigen!

 

Gruß

 

Edgar

Share this post


Link to post

Hallo KingSoft,

 

Ich würde fast behaupten wollen, daß das besser klappt, wenn du dieselbe Arbeitsgruppe verwendest.

Routing ändert an dem Problem nichts, das macht nur die doppelten IPs überflüssig.

Vielleicht hilft dir auch wirklich die Namensauflösung weiter (Vielleicht mal testweise die andere Maschine in systemroot\drivers\etc\hosts eintragen.

NetBios über TCP/IP sollte aktiviert sein.

 

Viel Rfolg...

 

Götz

Share this post


Link to post
Ich würde fast behaupten wollen, daß das besser klappt, wenn du dieselbe Arbeitsgruppe verwendest.

Hallo,

 

eine AG ist für die User übersichtlicher, so das benötigt wird. Es ist dann auch nur ein Masterbrowser tätig.

 

systemroot\drivers\etc\hosts eintragen
.

Nach meiner Kenntnis für das LAN die LMHOSTS.

 

Gruß

 

Edgar

Share this post


Link to post

HAllo,

 

wenn diese beiden Netze nicht in andere Netze gehen (Internetanbindung etc.), kannst du auf dem Anwender-Rechner und auf dem Ziel-Rechner jeweils eigene IP Adresse als Standard-Gateway eintragen.

Share this post


Link to post

Hallo lefg

 

<<sollen die beiden Netze mittels Routing verbunden werden

<<oder

<<ist es möglich und sinnvoll die Adressierung eines Netzes an das andere anzupassen

<<und die Netze damit zu vereinigen!

 

- weiß ich noch nicht genau was das beste ist; jedes Netz hat einen eigenen Internetzugang über jeweils eine ISDN-Fritze-Karte (soll auch so bleiben).

 

 

Hallo weg5st0

 

<< Ich würde fast behaupten wollen, daß das besser klappt, wenn du dieselbe Arbeitsgruppe verwendest.>>

- werde ich mal testen

 

<< Routing ändert an dem Problem nichts, das macht nur die doppelten IPs überflüssig.

Vielleicht hilft dir auch wirklich die Namensauflösung weiter (Vielleicht mal testweise die andere Maschine in systemroot\drivers\etc\hosts eintragen.

NetBios über TCP/IP sollte aktiviert sein.>>

 

- teste ich auch

 

 

Hallo varnik

 

<< wenn diese beiden Netze nicht in andere Netze gehen (Internetanbindung etc.), kannst du auf dem Anwender-Rechner und auf dem Ziel-Rechner jeweils eigene IP Adresse als Standard-Gateway eintragen.>>

 

- geht nicht, die wird jeweils schon von Fritz-Lan-Freigabe benutzt für Internetanbindung.

 

Am Mittwoch weiß ich mehr, dann teste ich beim Kunden.

Danke erstmal für eure Mühe.

 

Gruß Bernd

Share this post


Link to post

Hallo Leute,

 

komme greade vom testen:

 

Beides ausprobiert:

- PC2 aus Netz2 in Arbeitsgruppe von Netz1: funzt nich

- Firewall ausgeschaltet: immer noch nix.

- Enable IP Forwarding beim XP-PC gesetzt, funzt immer noch nich

- NetBios aktiviert, komme einfach nicht drauf.....

 

Meldung: Der Netzwerkpfad \\192.168.1.1 wurde nicht gefunden.

 

(wie gesagt, anpingen geht; zumindest von dem Netz2 aus. In die andere Richtung teste ich am Freitag. )

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...