Jump to content

2003 Server stürzt regelmäßig nachts ab


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Hallo!

 

Ich habe seit geraumer Zeit ein HEFTIGES Problem mit einem unserer DCs und habe inzwischen keine Ideen zur Problemlösung mehr. Ich hoffe ihr könnt mir ein bisschen helfen:

 

-----

Zunächst zum Server:

Windows Server 2003, 5.2 (3790), alle Updates installiert

Antivirus-Software von Panda

SharePointTeamServices 2 inkl. MS SQL-Server, IIS, ...

VERITAS Netbackup Client Software

DNS

 

Der Server ist der einzige DC der Domäne, hat aber eine nichttransitive Vertrauensstellung zu einer Windows 2K-Domäne, die wiederum in einen großen 2K-Forest eingebunden ist.

Es ist kein DHCP installiert, sondern es wird der DHCP der vertrauten Domäne benutzt.

 

----

Nun zum Problem:

Der Server friert in Abständen von ungefähr 4 bis 8 Tagen ein. Leider kann ich nicht weiter beschreiben, wie sich das Problem äußert, weil es immer über Nacht eintritt (fast immer kurz nach Mitternacht) und am nächsten Morgen der Rechner mit dem Reset-Knopf neu gestartet werden muss, weil er nicht mehr reagiert.

 

Das Ereignisprotokoll füllt sich in dieser Zeit mit vielen Ereignissen:

 

-Anwendung:

Userenv: Fehler 1058, 1030, 1053, 1054 (in der Reihenfolge in der sie auftreten)

APCPBEAgent (das ist das UPS): Fehler 3000: "Lost Communication With UPS"

W3SVC-WP: Fehler 2269

Zwischen den Abstürzen treten keine Fehlermeldungen auf!

 

-Sicherheit:

Hier tritt etwas Interessantes auf, das ich nicht richtig deuten kann:

 

Ereignistyp: Fehlerüberw.

Ereignisquelle: Security

Ereigniskategorie: An-/Abmeldung

Ereigniskennung: 537

Fehlgeschlagene Anmeldung:

Grund: Während der Anmeldung ist ein Fehler aufgetreten.

Benutzername: kkaufmann

Domäne: GENETIK

Anmeldetyp: 3

Anmeldevorgang: NtLmSsp

Authentifizierungspaket: NTLM

Name der Arbeitsstation: ROSE

Statuscode: 0xC0000017

Substatuscode: 0x0

 

Dabei ist kkaufmann ein Benutzerkonto der vertrauten Domäne! Nicht der Domäne in der das Problem auftritt. Gleiches gilt für die Arbeitsstation ROSE!

 

Vorher tritt Security, Fehler 673 auf, den ich auch nicht einordnen kann. Da ist aber kein signifikanter Zusammenhang zum Absturzzeitpunkt zu sehen.

 

- System

Im Wesentlichen scheinen die Fehlermeldungen aus irgendwelchen Ressource-Problemen zu entstehen...

Hier kommen jetzt lauter Meldungen, dass irgendwelche Dienste nicht mehr erreicht werden können oder herunter gefahren werden aus Ressourceprobelemen... z.B.:

 

Netlogon Fehler 5719: "Der Computer konnte eine sichere Sitzung mit einem Domänencontroller in der Domäne GENETIK *vertraute Domäne* aufgrund der folgenden Ursache:

Für diesen Befehl ist nicht genügend Speicher verfügbar. nicht einrichten. [...]

 

- Verzeichnisdienst

Auch hier Meldungen. Aber erst etwa eine Stunde nachdem die ersten Meldungen woanders aufgetreten sind...

 

- DNS:

Etwa 10 Minuten nach den ersten Fehlermeldungen:

 

Ereignistyp: Fehler

Ereignisquelle: DNS

Ereigniskennung: 4015

Beschreibung:

DNS-Server hat einen kritischen Fehler im Active Directory ermittelt. Stellen Sie sicher, dass das Active Directory ordnungsgemäß funktioniert. [...]

und

 

Ereignistyp: Fehler

Ereignisquelle: DNS

Ereigniskennung: 4004

Beschreibung:

Der DNS-Server konnte die Aufzählung der Verzeichnisdienste der Zone "_msdcs.mikrobio.aem" nicht vollständig durchführen. Dieser DNS-Server ist so konfiguriert, dass [...]

---

 

Ich habe auch schon mal versucht ein Leistungsprotokoll mitlaufen zu lassen. Allerdings hat das auch keine Ergebnisse gebracht, da Arbeitsspeicherauslastung und RAM als "normal" aufgenommen wurden in dieser Zeit. Das Problem bei den Leistungsprotokollen ist, dass ich nicht weiß wann der Fehler auftritt...

 

Da der Fehler immer nachts auftritt wäre es vielleicht interessant welche Dienste oder Prozeduren nachts aktiv werden. Leider kenne ich mich da nicht aus.

Ich wäre da über Hinweise und Tipps SEHR dankbar!!!

 

Schöne Grüße und vielen Dank schon einmal!

 

P.S. Wenn Bedarf besteht, kann ich auch noch mal die gesamte Ereignisprotokoll-Log online stellen.

Link to comment
  • 2 weeks later...
  • 2 weeks later...

Moin moin und frohes Neues!

 

Vielen Dank für den Hinweis, airtime! Ich habe in verschiedenen Versuchsdurchläufen den UPS-Agenten deaktiviert und die UPS selbst entfernt. Leider stürzt der Server nach wie vor ab.

 

Hat jemand eine Idee, wie man systematisch die Fehlerursache ausmachen könnte?

 

Übrigens läuft auf unserem Server auch STS 2.0 und das windowseigene Backup parallel zu dem Veritas Netbackup-Client.

Dass STS (bzw. IIS) schuld ist, kann mit großer Wahrscheinlichkeit ausgeschlossen werden, da "die kriese" wohl kaum IIS auf dem Fileserver betreiben wird.

 

Habt ihr alle das windowseigene Backupprogramm aktiviert bzw. einen Veritas Clienten laufen?

 

Schöne Grüße!

Link to comment

hallo zusammen.....

 

wir haben ebenfalls das problem das sich der server nachts aufhängt....

allerdings unregelmässig.... eventvwr ist clean wie ein baby popo.....

 

@skyfire... benutz mal die boardsuche... ich meine da etwas gelesen zu haben über probleme mit dem 875er und 2003.... bin aber nicht mehr sicher....kann mich auch irren....

 

benutzt ihr alle auch exchange??

 

gruss

 

chris

 

NACHTRAG:

wir benutzen windows eigene backup.....

Link to comment

Wir verwenden ein Intel D845GER Desktop-Board mit Intel i845GE Chipsatz.

Außerdem einen Promise FastTrack S150 TX2plus RAID-Controller.

 

@blub: Bei uns beginnt das Ereignisprotokoll ein paar Stunden vor dem Crash sich mit unzähligen Einträgen zu füllen.

 

@biglemon: Wir verwenden kein Exchange.

 

Schöne Grüße!

Link to comment

Wir hatten auch schon dieses Problem. Ich habe in den Einstellungen für STOP-Fehler den Eintrag dahingehend geändert, dass der Rechner nicht automatisch wieder hochfährt, damit ich mir den Bluescreen genauer anschauen konnte.

 

Die Fehlermeldung führte mich in die KnowledgeBase zu Artikel 831128

 

Die Abstürze kamen bei mir eigentlich nur bei beim Kopieren großer Dateien auf irgendwelche Netzwerkresourcen, genau wie in dem Artikel beschrieben.

 

Dies passiert natürlich auch nachts jeweils während des Backups...

 

Also bei Microsoft angerufen und das kostenlose Hotfix betellt und sogar noch kostenlosen Installationssupport erhalten.

 

Vielleicht lliegt ja bei einem von Euch der selbe Fehler vor...

 

Viel Glück

 

Stephan Kallauch

Link to comment

Moin moin!

 

Vielen Dank euch allen schon einmal für die rege Beteiligung!

 

@Kali: Es ist nicht so, dass der Rechner neu startet. Das wäre halb so schlimm. Offenbar werden immer mehr Ressourcen verbraucht, sodass der Rechner immer mehr Dienste verweigert. Es ist außerdem unwahrscheinlich, dass das eins der Backupprogramme beteiligt ist, da die Backups täglich erfolgen, der Server jedoch etwa wöchentlich abschmiert.

 

@CoolAce: Ich habe seit über einem Jahr mit dem Server zu tun und er lief in dieser Zeit noch nie ohne dieses Problem. Ob er vorher schon mal problemlos lief ist mit nicht bekannt - mein Vorgänger ist nicht mehr erreichbar.

Das Problem war allerdings nach Aussage einiger Mitarbeiter früher schlimmer. Damals sei der Server mehrmals in der Woche abgeraucht.

 

Schöne Grüße!

Link to comment

In meinen Augen ist das des Pudels Kern:

 

Für diesen Befehl ist nicht genügend Speicher verfügbar

 

schau doch mal mit perfmon (geht auch remote), ob irgendwelche prozesse viel "process/private bytes" (oder sonstige memory-resourcen) verbrauchen.... ist meist hinweis auf memoryleaks durch defekte HW/schlechte SW.

Ausserdem mal die durchschnittliche Länge der Festplattenwarteschlange checken mit demselben Tool

Vielleicht liesse sich so ein stoerender Prozess finden.

Link to comment

Hallo

 

wir hatten dasselbe Problem, dass während dem Backup der Server einfriert. Das auch nicht täglich.

Wir hatten zuerst das Backuptool "DataProtector" von HP in Verdacht, weil der Server meistens abgschmiert ist, wenn er seine eigene DB gesichert hat.

Wir haben unterdessen den Server neu installiert (W2K3) und die Software neu installiert (DB importiert). Mit dem gleichen Effekt.

Der Techniker hat dann auf Hardwareprobleme getippt, obwohl keine Fehlermeldungen vorhanden sind.

Unterdessen sind Motherboard und CPU ersetzt. Immer noch das gleiche Problem !!!

 

Jetzt kann es eigentlich nur noch am Memory liegen !!!

Alles andere ist ja ersetzt worden oder neu installiert worden.

 

Eventuell habt Ihr das gleiche Phenomen ???

 

Gruss

Ritchie

Link to comment
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...