Jump to content

Exchange 2016 Recover - Datenbankdate fehlt


Go to solution Solved by tesso,

Recommended Posts

Hallo zusammen,

 

ich stelle grade für einen Kunden einen Exchange 2016 nach Anleitung von FrankysWeb wieder her.

Bis zu dem Punkt Mailbox mounten ist alles ohne Fehler gelaufen.

 

Jetzt kommt bei dem Befehl

 

Get-MailboxDatabase -Server KS-Exchange | Mount-Database

Bestätigung
Mindestens eine Datenbankdatei dieses Informationsspeichers fehlt. Das Einbinden dieses Informationsspeichers erzwingt
die Erstellung einer leeren Datenbank. Führen Sie diese Aktion nicht aus, wenn Sie eine frühere Sicherung oder eine
fortlaufende Replikationskopie Ihrer Datenbank wiederherstellen möchten. Möchten Sie den Vorgang wirklich fortsetzen?
[J] Ja  [A] Ja, alle  [N] Nein  [K] Nein, keine  [?] Hilfe (Standard ist "J"): 

Der Ordner "Mailbox Database 0384629771" ist auf Quell und Zielsystem bis auf letzte Byte gleich groß.

Kann mir jemand sagen, wo es haken könnte ?

 

Gruß

chrismue

 

Link to post
Posted (edited)

Leider startet die Management Shell auf dem alten Exchange nicht mehr.

Aber ich habe grade mal Manuell verglichen

 

Alter Server: "E:\Exchange Server\V15\Mailbox"

Neuer Server: "E:\Exchange Server\Mailbox"

 

Ich habe die Installation mit

 

f:\Setup.exe /IAcceptExchangeServerLicenseTerms /Mode:RecoverServer /TargetDir:"E:\Exchange Server" gestartet.

 

Wo ist der V15 Ordner, oder muss ich mit /TargetDir:"E:\Exchange Server\v15" installieren ?

 

Nachtrag:

Der V15 Ordner ist unter E:\Exchange Server erstellt worden, enthält aber nur die Ordner "ClientAccess,FrontEnd,TransportRoles"

 

Gruß

chrismue

 

 

Edited by chrismue
Link to post
  • Solution
vor 13 Minuten schrieb chrismue:

Leider startet die Management Shell auf dem alten Exchange nicht mehr.

Und vom neuen Server? Der liest doch das selbe AD aus. 

Wo liegt deine DB auf dem neuen Server? Entweder legst du die DB/logs in die Ordner wo die laut AD stehen oder du verschiebst die Datenbank an die Stelle wo sie nun liegt.

  • Thanks 1
Link to post
Posted (edited)

Hallo @tesso,

 

ja, wird gemacht.

 

Was mir noch aufgefallen ist, ich habe das CU20 zur Wiederherstellung genutzt.

Mir wird aber folgende Version angezeigt.

 

AdminDisplayVersion             : Version 15.1 (Build 1415.2)

 

Das wäre CU8.

Das SetupLog schreibt Setup version: 15.1.2242.4.

 

Das verwirrt mich jetzt ein wenig.

 

Gruß

chrismue

Edited by chrismue
Link to post

Man könnte natürlich auch mal die Doku bemühen:

https://docs.microsoft.com/de-de/exchange/high-availability/disaster-recovery/recover-exchange-servers?view=exchserver-2016

If you do not have the installation media for the Cumulative Update (CU) version that was installed on the server to be recovered, you can recover a server using the latest available Cumulative Update. Only the last two CUs are available for download. For more information, see Updates for Exchange Server. Once the upgrade is successful, AdminDisplayVersion in EMS or msExchVersion attribute on recovered server will show old build number and this is a cosmetic in nature. We can either run setup /m:upgrade /IAcceptEchangeServerLicenseTerms or wait for next Cumulative Update release and perform the upgrade which will correct this.

Link to post

@NorbertFe

Danke fürs raussuchen. Dann war ich auf dem richtigen Weg. Ich dachte mir schon, das beim Recovery die Version nicht gesetzt wird (Warum auch, ist kein Update). 

 

Zur Sicherheit würde ich das CU nochmal installieren. Dann sind wir sicher das auch alle Schemaerweiterungen korrekt angekommen sind. Die Version ist schließlich von CU8 auf CU20 geändert. Ich müsste erst nachschauen, ob es dort Schemaänderungen gab. 

vor 4 Minuten schrieb NorbertFe:

Man könnte natürlich auch mal die Doku bemühen:

Ich sage immer: Ich lese keine Handbücher, ich drücke Knöpfe bis es geht. :D

  • Haha 1
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...