Jump to content
Chris_30

SQL Server (Veeam) startet nicht

Recommended Posts

Hallo liebe Boardkollegen,

 

folgende Situation: Veeam auf einem 2012R2 Host installiert inklusive der SQL Datenbank die Veeam automatisch mitbringt/braucht. Seit neuestem startet der SQL Server nicht mehr. Folgende Symptomatik: Die Instanz schnappt sich alles was am Host als freier RAM da ist (16 GB) doch offensichtlich reicht das nicht zum starten obwohl die Datenbank selbst nur lächerliche 100MB hat. Leider ist SQL Server so gar nicht mein Thema :-( 

Im Eventlog des Server steht die 7023 - nicht genug Arbeitsspeicher, log vom SQL Server hänge ich an.

 

Schon mal danke im Vorraus!

 

Gruß

Chris

ERRORLOG.txt

Share this post


Link to post
Share on other sites

Der SQL Server auf dem Host ist veraltet: Microsoft SQL Server 2012 (SP1) - 11.0.3000.0 (X64)

Zuerst den SQL Server aktualisieren, dann Reboot und nochmal probieren.

Share this post


Link to post
Share on other sites
vor 9 Minuten schrieb Dukel:

Auf dem Host sollte ausser Hyper-V nichts laufen.

Wenn es nicht anderst geht (!) dann kann man den SQL Server begrenzen, dass dieser nur maximal xx GB Ram nutzt.

https://docs.microsoft.com/en-us/sql/database-engine/configure-windows/server-memory-server-configuration-options?view=sql-server-2017

Mir bewusst dass idealerweise nichts ausser Hyper-V läuft - aber halt das typische Szenario, 2 virtuelle Maschinen am laufen und ein extra Sicherungsserver hätte dann ja extra Lizenzen bedeutet. Auf der Büchse ist kein SQL Management Studio - nur der "nackte" SQL Server wie er von Veeam mit installiert wird. Gibt es da auch einen anderen Weg um den Speicher zu begrenzen?

Share this post


Link to post
Share on other sites
vor 3 Minuten schrieb wi-ra:

Häää, die Express-variante ist doch seit ewigen Zeit lizenzseitig/programmseitig auf 1 GB RAM begrenzt, wie kommen da 16 GB RAM-Nutzung zustande?

 

In dem Fall jetzt 13 - er nimmt sich was da ist.

 

image.png.7721e885e647489ad57afc468e9d5a24.png

Share this post


Link to post
Share on other sites
vor 3 Stunden schrieb Sunny61:

SSMS downloaden: https://go.microsoft.com/fwlink/?linkid=2099720&clcid=0x407

Und unbedingt den SQL aktualisieren! Hier findest Du die Builds und die dazugehörenden SPs/CUs: https://buildnumbers.wordpress.com/sqlserver/

Das mit dem SSMS hat halt einen kleinen Schönheitsfehler … für die erstmalige Verbindung/Einrichtung muss der SQL Server wohl laufen...

 

image.png.07bef73fe4c2eb810aa556496f8feb6d.png

Share this post


Link to post
Share on other sites

Du kennst die Instanz? Du kennst den Port? Schau dazu im SQL Server Konfigurationsmanager nach.

 

Veeam hat sicherlich einen Dienst, falls ja, den beenden und auf deaktiviert setzen. Jetzt den SQL Server Dienst starten. Kannst du dich jetzt anmelden?

Edited by Sunny61

Share this post


Link to post
Share on other sites

nachdem ich in letzter Zeit öfters merkwürdige SQL Verbindungsfehler hatte: schon mal mit ".\VEEAMSQL2012" probiert zu verbinden?
hatte es in letzter Zeit öfters, dass der Hostname nicht mehr gemocht wurde für solche Verbindungen

...und SSMS als Admin starten kann auch noch helfen :D   (wie oft ich schon darüber gestolpert bin...)

 

Share this post


Link to post
Share on other sites
vor 34 Minuten schrieb Sunny61:

Du kennst die Instanz? Du kennst den Port? Schau dazu im SQL Server Konfigurationsmanager nach.

 

Veeam hat sicherlich einen Dienst, falls ja, den beenden und auf deaktiviert setzen. Jetzt den SQL Server Dienst starten. Kannst du dich jetzt anmelden?

Alle Veeam Dienste beendet und deaktiviert - SQL Server startet trotzdem nicht. Werde dann die Büchse so nochmal neu starten ob er dann startet.

vor 19 Minuten schrieb PyroTFD:

nachdem ich in letzter Zeit öfters merkwürdige SQL Verbindungsfehler hatte: schon mal mit ".\VEEAMSQL2012" probiert zu verbinden?
hatte es in letzter Zeit öfters, dass der Hostname nicht mehr gemocht wurde für solche Verbindungen

...und SSMS als Admin starten kann auch noch helfen :D   (wie oft ich schon darüber gestolpert bin...)

 

Beides leider kein Erfolg. Irgendwie ja auch klar, solange der SQL Server nicht startet :-(

Share this post


Link to post
Share on other sites

So, NS mit deaktivierten Veeam Diensten, SP4 installiert, SSMS sich sofort verbunden, max. RAM auf 4GB konfiguriert. Läuft!

 

Danke an alle für die Unterstützung!

Share this post


Link to post
Share on other sites

Hallo, ich hatte auch auf dem Server2016 Datacenter eine sehr hohe Speicherauslastung des Veeam SQL-Service. Ich hab es über osql gelöst. Dazu brauchte ich den Pipe-Namen zuerst. Veeam B&R installierte bei mir auch den "SQL Server 2016 Configuration Manager". Wenn ich den aufrufe finde ich den Pipe-Namen unter:
 

SQL Server 2016 Configuration Manager (local) => SQL Server Network Configuration => Protocols for VeeamSQL2016 => Named Pipes => Pipe Name

Siehe Bild.

 

Dann konnte ich in der Konsole mit folgenden Befehlen  "max server memory" ändern.

 

osql -E -S \\.\pipe\MSSQL$VEEAMSQL2016\sql\query
exec sp_configure 'show advanced option', '1';
reconfigure;
### hier mir die Werte angeschaut:
exec sp_configure;
go
### Werte auf 6144 MB gesetzt:
exec sp_configure 'max server memory', 6144;
reconfigure with override;
go

 

Würde mich interessieren, wie ich den Pipe-Namen auf Powershell-Ebene herausgefunden hätte :)

 

sql.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


Werbepartner:



×
×
  • Create New...