Jump to content
Kuddel071089

PS: Set-FSRMQuota mit Variable

Recommended Posts

Hallo zusammen,

 

ich habe ein Skript für unseren Verwaltungshost geschrieben, um die Speicherbegrenzung des Homeverzeichnisses eines Anwender zu begrenzen.

 

Man muss nur die neuen Speichergrenze (als Zahl) eingeben.

 

Leider bekomme ich es nicht hin, die GB als Format mitzugeben.

 


Invoke-Command -ComputerName $fileserver -ScriptBlock {Set-FSRMQuota -Path $using:homeverzeichnis -Size $quota+"GB"}

 

Fehlermeldung


Neue Speichergrenze eingeben (Beispiel 5 GB): 10
Die Argumenttransformation für den Parameter "Size" kann nicht verarbeitet werden. Der Wert "10+GB" kann nicht in den Typ "System.UInt64" konvertiert
werden. Fehler: "Die Eingabezeichenfolge hat das falsche Format."

 

Hat jemand eine Lösung für mich?

Edited by Kuddel071089

Share this post


Link to post
Share on other sites

$($quota*1GB)


0x8004530d, Die angegebene Eigenschaft liegt außerhalb des gültigen Bereichs.

Wenn ich -size $quotaGB nehme, wird das GB als Teil der Variable und nicht als Format erkannt

Edited by Kuddel071089

Share this post


Link to post
Share on other sites

Das soll es ja.

Es sind zwei Möglichkeiten. Entweder $(...) -> Wird als eigene Variable definiert.

Das andere ist so, dass man erst das Quota umrechnet "-Scriptblock { $quotaGB..." und dann diese Variable nutzt.

 

Invoke-Command -ComputerName $fileserver -ScriptBlock {$QuotaGB = $quota*1GB ; Set-FSRMQuota -Path $using:homeverzeichnis -Size $quotaGB}

 

Share this post


Link to post
Share on other sites

Hi,

 

dein $quota+"GB" muß in Klammern, ansonsten wird der Ausdruck nicht ausgewertet sondern nur zusammengesetzt.

-Size ($quota+"GB")

Weiß aber nicht genau, ob der Parameter -Size das dann auch nimmt... weils ein String und keine Zahl ist.

 

Korrektur:

Obiges geht wohl nicht, da das Format wahrscheinlich nicht erkannt wird. Also am besten ungefähr so, wie Dukel sagt. Dabei die Berechnung in Klammern:

 

... -Size ($quota*1gb)

Edited by massaraksch

Share this post


Link to post
Share on other sites
vor 16 Minuten schrieb massaraksch:

Hi,

 

dein $quota+"GB" muß in Klammern, ansonsten wird der Ausdruck nicht ausgewertet sondern nur zusammengesetzt.


-Size ($quota+"GB")

Weiß aber nicht genau, ob der Parameter -Size das dann auch nimmt... weils ein String und keine Zahl ist.


Die Argumenttransformation für den Parameter "Size" kann nicht verarbeitet werden. Der Wert "10GB" kann nicht in den Typ "System.UInt64" konvertiert werden. Fehler: "Die
Eingabezeichenfolge hat das falsche Format."

Share this post


Link to post
Share on other sites

Wenn noch keine Quota auf dem Ordner vorhanden ist, muss erstmal eine erstellt werden ... das ist hoffentlich klar ... oder?

Bei mir funktioniert es zum Testen so:

$TestPath = "OrdnerPfad zum Testen"

[INT]$InitialQuota = Read-Host -Prompt "Initial Quota"
[UINT64]$InitialQuota = [INT]$InitialQuota * 1GB
New-FsrmQuota -Path $TestPath -Size $InitialQuota

[INT]$NewQuota = Read-Host -Prompt "Initial Quota"
[UINT64]$NewQuota = [INT]$NewQuota * 1GB
Set-FSRMQuota -Path $TestPath -Size $NewQuota

Remove-FsrmQuota -Path $TestPath -Confirm:$false

 

Edited by BOfH_666

Share this post


Link to post
Share on other sites
Am 30.11.2018 um 16:51 schrieb BOfH_666:

Wenn noch keine Quota auf dem Ordner vorhanden ist, muss erstmal eine erstellt werden ... das ist hoffentlich klar ... oder?

Bei mir funktioniert es zum Testen so:


[INT]$NewQuota = Read-Host -Prompt "Initial Quota"
[UINT64]$NewQuota = [INT]$NewQuota * 1GB
Set-FSRMQuota -Path $TestPath -Size $NewQuota

 

Damit funktioniert es. Super, vielen Dank :-)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...