Jump to content
Sign in to follow this  
DerEntwickler

Interne Domäne gleich Externe Domäne - https nicht erreichbar

Recommended Posts

Hallo,

 

wir haben einen Kunden übernommen dessen Server (Server 2016 Std.) die gleiche interne Domäne nutzt wie die externe Domäne. An sich kein Problem, allerdings möchte der Kunde gerne aus dem internen Netzwerk die externe Website (HTTPS) aufrufen, die auf der externen Domain hinterlegt ist. 

 

DNS Einträge wurden angelegt:

z.B. - A-Rekord auf www.

 

Leider ist die externe HTTPS-Website nicht aus dem lokalen Netz erreichbar. Eine ungesicherte Version (HTTP) der Website ist einwandfrei aufrufbar.

 

Mit Microsoft Edge bekomme ich folgende Fehlermeldung

 

Keine sichere Verbindung mit dieser Seite möglich
Dies liegt möglicherweise daran, dass die Website veraltete oder unsichere TLS-Sicherheitseinstellungen verwendet. Wenn das Problem wiederholt auftritt, wenden Sie sich an den Besitzer der Website.

 

Unter Firefox kommt folgende Gehlermeldung

 

Fehler: Gesicherte Verbindung fehlgeschlagen

Die Verbindung zum Server wurde zurückgesetzt, während die Seite geladen wurde.

Die Website kann nicht angezeigt werden, da die Authentizität der erhaltenen Daten nicht verifiziert werden konnte.

 

Andere HTTPS-Websiten können einwandfrei aufgerufen werden und Rechner außerhalb des lokalen Netzwerkes bekommen den Fehler nicht angezeigt und die Firmen-Website funktioniert ohne Probleme.

 

Kann mir mal jemand einen Tip geben woran das liegt bzw. was ich ändern muß ?

 

Vielen Dank im voraus

Share this post


Link to post
Share on other sites

Hört denn der oder die dcs auf https? Wenn ja wer oder was?

Achso bei https könnte das natürlich zu Zertifikatsproblemen führen. Und im Endeffekt erkläre ich solchen Kunden einfach, dass sie intern eben www davor schreiben müssen. :)

Share this post


Link to post
Share on other sites

Hallo NorbertFE,

 

die Benutzer rufen die Seite ja über z.B. www.contoso.com auf. Das Problem liegt an HTTPS. Als die Seite noch kein Zertifikat hatte war sie für die Benutzer der internen Domäne aufrufbar. Seitdem die Seite ein Zertifikat besitzt, bestehen die Probleme.

Allerdings ist die Seite von außerhalb einwandfrei aufrufbar. Eben nur nicht von PC der internen Domäne.

 

Share this post


Link to post
Share on other sites

Hallo NorbertFE

 

es erscheint wie gesagt die genannte Fehlermeldung.

 

Keine sichere Verbindung mit dieser Seite möglich
Dies liegt möglicherweise daran, dass die Website veraltete oder unsichere TLS-Sicherheitseinstellungen verwendet. Wenn das Problem wiederholt auftritt, wenden Sie sich an den Besitzer der Website.

 

Ein Ping ruft die externe IP der Website auf. Erst seit der Installation des Zertifikats erscheint der Fehler. Das ist ja der Grund warum ich es nicht verstehe. Die Domäne im Zertifikat ist auch korrekt. wäre im o.g. Beispiel "contoso.com". Somit sind alle Sub-Domains eingeschlossen. Wenn ich die Website von zu Hause aufrufe klappt alles einwandfrei.

Share this post


Link to post
Share on other sites

Was soll man denn jetzt von außenstehend dazu sagen? Schau dir halt die ssl Kommunikation an bspw. Erstmal ob du überhaupt am richtigen Server und mit dem richtigen Zertifikat ankommst. Außerdem teste ob das evtl. An clientseitiger Einstellung liegt, die nur tls 1.0 oder so zulässt der Webserver aber nur tls 1.1 oder oder oder.

Edited by NorbertFe

Share this post


Link to post
Share on other sites

Wenn es clientseitig bedingt ist, warum kann ich dann fremde HTTPS-Seiten (z.B. Https://www.google.de) aufrufen ? Muß ich das Zertifikat der Domain-Website eventuell auch explizit auf den Clients im lokalen Netzwerk installieren?

Share this post


Link to post
Share on other sites
vor 3 Minuten schrieb DerEntwickler:

Wenn es clientseitig bedingt ist, warum kann ich dann fremde HTTPS-Seiten (z.B. Https://www.google.de) aufrufen ?

Weil die anders konfiguriert sind? Woher soll ich das wissen?

 

vor 4 Minuten schrieb DerEntwickler:

Muß ich das Zertifikat der Domain-Website eventuell auch explizit auf den Clients im lokalen Netzwerk installieren?

Nein, wozu denn? Abgesehen davon, hatte ich ja oben genug Optionen der Fehlereingrenzung aufgezeigt. Welche davon hast du denn schon probiert? Oder willst du weiter raten und hier noch mehr Vorschläge bekommen, die du dann nicht abarbeitest? ;)

 

Bye

Norbert

Share this post


Link to post
Share on other sites

Hallo NorbertFE,

 

erstmal Danke für deine Antworten. Aber dein letzter Post ist ja wohl unter aller Kanone. Woher willst Du wissen ob ich nicht alle Hinweise abgearbeitet habe bzw. schon vorher das Netz sorgfältig nach Lösungen durchsucht habe. Diese Unterstellung von Dir finde ich einigermaßen unverschämt.

Außer deinem ersten Hinweis, welchen ich sehr wohl versucht habe, hast Du doch keinerlei konkreten Vorschläge gemacht sondern nur gesagt "Schau dir doch mal die Kommunikation an." Als hätte ich das nicht schon vorher getan.

Dein Ton in der letzten Antwort ist dermaßen agressiv das Ich keine Lust habe mich mit Dir in einem sinnfreien Dialog zu verzetteln und betrachte die Angelegenheit hiermit als erledigt.

Share this post


Link to post
Share on other sites

Hi,

 

Am 12.6.2018 um 10:59 schrieb DerEntwickler:

Die Domäne im Zertifikat ist auch korrekt. wäre im o.g. Beispiel "contoso.com". Somit sind alle Sub-Domains eingeschlossen. Wenn ich die Website von zu Hause aufrufe klappt alles einwandfrei.

alle Sub-Domains wären nur bei einem CN oder SAN "*.contoso.com" eingeschlossen. Wenn du von zu Hause auf https://www.<dieURLumdieesgeht>.<tld>gehst, wirst du evtl. direkt auf https://<ieURLumdieesgeht>.<tld> umgeleitet?

 

Ggfs. poste doch die Seite um die es geht.

 

Gruß

Jan

Share this post


Link to post
Share on other sites

Hallo mba,

 

danke für den Hinweis. Beim Hoster war  der A-Record für terracult.com gelöscht. Ist mittlerweile korrigiert und leitet jetzt auch auf https://www.terracult.com weiter.

 

Das hat aber nichts mit dem eigentlichen Problem zu tun. Im DNS ist eine Weiterleitung für www hinterlegt und wird auch weitergeleitet. Das heißt also die interne Domäne in der Firma heißt terracult.com, die IP ist aber nicht für terracult.com im Internet eingetragen. Die bei der DENIC registrierte IP ist die die öffentlich IP beim Hoster.

Wenn ich jetzt von einem Rechner im internen Netzwerk (192.168.0.x) www.terracult.com aufrufe zeigen Ping und Tracert auf die externe IP. nur im Browser bekomme ich einen Fehler

 

Firefox meldet dann z.B.

 

Fehler: Gesicherte Verbindung fehlgeschlagen

Die Verbindung zum Server wurde zurückgesetzt, während die Seite geladen wurde.

Die Website kann nicht angezeigt werden, da die Authentizität der erhaltenen Daten nicht verifiziert werden konnte.

 

Ich kann mir einfach nicht erklären warum, denn wenn ich die Seite von außerhalb der Firma aufrufe klappt alle einwandfrei.

Edited by DerEntwickler

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...