Jump to content

WSUS 3 Clients erhalten keine Updates


tott
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Hallo,

 

folgendes Problem:

 

nachdem ich den WSUS 3 auf einen 2003 Server aufgesetzt habe, werden meine Rechner zwar erkannt, aber sie erhalten keine Updates. Ich habe es mit dem SP3 für XP versucht. Dieses habe ich genehmigt und der Testgruppe zugewiesen.

 

Der Server hat die 192.168.6.13. Die Updates werden auch von der Windows Update Seite syncronisiert.

 

Ein anstoßen der betreffenden Maschinen zum Updateempfang mit wucault.exe /detectnow und /force funktioniert nicht. Der Testclient, lief schon 2 Tage durch.

 

Der WSUS hängt nich in einer AD, da wir Novellserver verwenden. Der Client wurde mit folgendem RegKey bestückt und neu gestartet:

 

Windows Registry Editor Version 5.00

 

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate]

"WUServer"="http://192.168.6.13:80"

"WUStatusServer"="http://192.168.6.13:80"

"ElevateNonAdmins"=dword:00000000

"TargetGroupEnabled"=dword:00000001

"AcceptTrustedPublisherCerts"=dword:00000001

 

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU]

"NoAUShutdownOption"=dword:00000001

"NoAUAsDefaultShutdownOption"=dword:00000001

"AUPowerManagement"=dword:00000001

"NoAutoUpdate"=dword:00000000

"AUOptions"=dword:00000004

"ScheduledInstallDay"=dword:00000000

"ScheduledInstallTime"=dword:00000012

"UseWUServer"=dword:00000001

"DetectionFrequencyEnabled"=dword:00000001

"DetectionFrequency"=dword:00000004

"IncludeRecommendedUpdates"=dword:00000000

"AutoInstallMinorUpdates"=dword:00000001

"NoAutoRebootWithLoggedOnUsers"=dword:00000001

"RebootRelaunchTimeoutEnabled"=dword:00000001

"RebootRelaunchTimeout"=dword:000005a0

"RebootWarningTimeoutEnabled"=dword:00000001

"RebootWarningTimeout"=dword:0000001e

"RescheduleWaitTimeEnabled"=dword:00000001

"RescheduleWaitTime"=dword:0000001e

 

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\WindowsUpdate]

"DisableWindowsUpdateAccess"=dword:00000001

 

 

Daraufhin wurde er auch ordnungsgemäß im WSUS erkannt, aber wie gesagt er zieht sich kein Update.

 

Ich habe im Forum auch schon gesucht, aber nichts gefunden. Vielleicht habe ich auch mit den falschen Suchparametern gesucht.

 

Was mache ich falsch?

 

:confused:

 

Gruß

 

tott

Sorry, falscher Thread!

 

Hab ihn nochmals unter Backoffice eingestellt!

 

Gruß

 

tott

Link to comment

nachdem ich den WSUS 3 auf einen 2003 Server aufgesetzt habe, werden meine Rechner zwar erkannt, aber sie erhalten keine Updates. Ich habe es mit dem SP3 für XP versucht. Dieses habe ich genehmigt und der Testgruppe zugewiesen.

 

OK.

 

Der Server hat die 192.168.6.13. Die Updates werden auch von der Windows Update Seite syncronisiert.

 

Sind die zur Installation freigegebenen Updates auch schon vom WSUS gedownloadet worden? Siehst Du in der Übersichtsseite: http://www.gruppenrichtlinien.de/Bilder/WSUS3_27.gif Downloadstatus.

 

Ein anstoßen der betreffenden Maschinen zum Updateempfang mit wucault.exe /detectnow und /force funktioniert nicht. Der Testclient, lief schon 2 Tage durch.

 

Mit NETSTAT kannst Du kontrollieren ob der Client eine HTTP-Verbindung zum WSUS aufgebaut hat. Probier mal von einem Client diesen Link aus: http://Dein_WSUS/selfupdate/wuident.cab Bekommst Du einen Download angeboten?

 

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate]

"WUServer"="http://192.168.6.13:80"

"WUStatusServer"="http://192.168.6.13:80"

"ElevateNonAdmins"=dword:00000000

"TargetGroupEnabled"=dword:00000001

"AcceptTrustedPublisherCerts"=dword:00000001

 

Das :80 kannst Du dir schenken, HTTP ist Port 80. TargetGroupEnabled = 1 und wo ist der Gruppenname? Und wie ist der WSUS in den Optionen dazu eingestellt? http://www.gruppenrichtlinien.de/Bilder/WSUS3_48.gif

 

Daraufhin wurde er auch ordnungsgemäß im WSUS erkannt, aber wie gesagt er zieht sich kein Update.

 

Wie die beiden anderen schon schruben, wenn das o.g. alles passt, dann wäre die WindowsUpdate.log interessant. Laufen den auch die benötigten Dienste auf dem Client? Es muß "Automatische Updates" automatisch gestartet sein, der "Intelligente Hintergrundübertragungsdienst" muß mind. auf manuell stehen. Auch kannst Du mal probieren die beiden Dienste manuell neu zu starten, nicht das Du dabei eine Fehlermeldung bekommst.

Link to comment

Hallo Tott,

 

ich habe/hatte auch dieses Problem.

 

Bei mir kam, in der WindowsUpdate.log (unter %windir% auf dem Client), die Meldung:

 

WARNING: DownloadFileInternal failed for http://<der_Server>/selfupdate/wuident.cab: error 0x80190194

 

Die Lösung war ein fehlendes virtuelles Verzeichnis.

 

Schau doch mal unter deinem Internetinformationsdienste-Manager, ob der Eintrag Selfupdate unter der Standardwebseite aufgeführt ist (ebenso ReportingWebService, ...).

 

Ich hatte einfach ein neues virtuelles Verzeichnis "Selfupdate", mit dem Pfad "C:\Programme\Update Services\Selfupdate" und Leserecht, erstellt.

 

8 PCs sind in den letzten 10 Minuten mit Statusbericht aufgeführt. Davor war es keiner.

 

Bei uns sieht es jetzt gut aus.

 

d.pabst

 

PS: Der Errorcode besteht aus 0x80190 und 194, wobei die 194 hex für 404 - file not found ist.

Link to comment
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...