Jump to content
Sign in to follow this  
wulfi

SMTP ohne Domain und ohne smart host

Recommended Posts

Hallo,

 

ich bin absolut neu hier und habe ein paar fragen zur Konfiguration eines SMTP Servers unter W2000prof. in einer Arbeitsgruppe mit ADSL Internetzugriff.

 

1. Kannn ich von dieser Maschine Mails versenden ohne Gebrauch eines Smarthostes?

2. Ist dafuer eine Domaene zwingend erforderlich?

 

Ich habe den virtuell SMTP Server installiert und "so gut ich es wusste" konfiguriert. Wenn ich nun zum Test eine Mail in den PickUp Folder verschiebe geht diese direkt in den Queue Folder und bleibt dort "stecken".

 

Ich hatte die Hoffnung das ich direkt Emails an den entsprechenden Empfaenger versenden kann. Dies scheint SO nicht zu stimmen.

 

Any help will be appreciated!

 

Vielen Dank im voraus!

Gruss aus Sydney

Wulfi

Share this post


Link to post
Share on other sites

Hallo Hubert,

 

vielen Dank fuer deine schnelle Antwort!

Wir haben hier einen Internetzugang ADSL mit einer festeingestellten IP Adresse.

Muss ich in diesem fall keinen Smathost nutzen?

 

Wenn ich das programm smtpdiag,exe laufen lassen bekomme ich eine Menge Meldungen bzgl. der Domaene bzw. DNS.

 

Hast du eine Idee was ich hier falsch mache?

 

Vielen Dank im Voraus!

Gruss

wulfi

Share this post


Link to post
Share on other sites

Hi.

 

Muss ich in diesem fall keinen Smathost nutzen?

 

Ja, wenn du ohne Domain versendest.

 

Wenn ich das programm smtpdiag,exe laufen lassen bekomme ich eine Menge Meldungen bzgl. der Domaene bzw. DNS.

 

Ohne den Fehlermeldungen werden wir dir kaum helfen können.

 

LG Günther

Share this post


Link to post
Share on other sites

Hi Guenter,

 

ersteinmal vielen Dank fuer deine Hilfe!

 

Bin erst heute im Laufe des Tages (+10h zu dem Dorf mit Straßenbahn) wieder auf der Jobsite mit dem genannten Problem und werde dann die Fehlermeldungen schicken koennen.

 

Fuer mein Verstaendnis: Mit fester IP und ohne Domaene (nur eine Arbeitsgruppe) kann ich also mit dem SMTP Virtual Server OHNE Smarthost direkt Emails an einen x-beliebigen Empfaenger versenden?

 

Ich glaube ich habe das noch nicht so ganz verstanden, deshalb nochmals diese Fragerei....

 

Vielen Dank fuer den gesendeten Link, hier ist aber auch die Rede von einer Domaene:

"SMTP Servers must have one local default domain" ...

 

Nochmals Danke

LG

wulfi

Share this post


Link to post
Share on other sites

Hallo.

 

Machen wir es doch umgekehrt. Schreibe uns doch, was du vorhast. Es ist dann wahrscheinlich wesentlich einfacher dir zu helfen.

 

LG Günther

Share this post


Link to post
Share on other sites

Hi Guenther,

 

okay, werde ich versuchen...

Wir haben eine Applikation die bei bestimmten Ereignissen eine Email versenden soll.

Der Rechner (Windows 2000prof.) ist in keiner Domaene und direkt im Internet ueber ADSL. Wir haben vom Provider eine feste IP Adresse zugeteilt bekommen.

 

Im Moment bleiben alle Emailversuche im Queue Folder haengen.

Ich habe die Logdatei bereits aktiviert, finde aber keine zeitlich passenden Eintraege...

 

Wenn ich eine Datei in den PickUp Folder verschiebe geht auch diese direkt in den Queue Folder um dort zuverweilen...

 

Wie gesagt bin ich unsicher ueber die richtige Arbeitsweise bzw. Konfiguration der ganzen Geschichte auf der SMTP Seite.

 

LG

Wulfi

Share this post


Link to post
Share on other sites

Hallo.

 

Richtig, wenn es darum geht aus einer Applikation heraus eine Benachrichtigung zu senden, dann ist die Empfehlung von goscho wesentlich besser dazu geeignet.

 

Auch wenn du eine feste IP Adresse hast, ist ohne Konfiguration einer gültigen E-Mail Domäne und den entsprechenden DNS Einträgen keine Versand möglich, da kaum ein SPAM Filter die E-Mail annehmen wird.

 

LG Günther

Share this post


Link to post
Share on other sites

Ich nehme an, die Software wird ihre Meldungen nur an einen Emfänger versenden wollen. Wenn man dort Einfluss nehmen kann und den Spam-Filter entschärft, könnte es auch, trotz geblacklisteter Sender-IP, ohne Smarthost klappen.

Share this post


Link to post
Share on other sites

Vielen Dank an ALLE!.

 

Werde mal eure Vorschlaege ausprobieren, bzw ueberdenken....

 

Ich gebe dann Bescheid, wenn es geklappt hat....

 

 

Gruss

Wulfi

Share this post


Link to post
Share on other sites

Und Wulfi, hat es geklappt? Ich habe nämlich dasselbe Problem, allerdings unter 2K3 und bekommen wir auch keine feste IP bei der ADSL-Einwahl, die einzige Domain ist zudem die lokale server.diefirma.local.

 

Als Mädchen für alles wurde mir Server-Newbie nun noch das Backup des Firmenservers aufgedrückt. Dies erledige ich per Skript, wobei am Ende eine Logdatei erstellt wird. Diese möchte ich täglich per Mail an meine reguläre E-Mail Adresse bei einem anderen Provider gesendet bekommen. Habe dazu unter Überwachung und Berichte > Serverstatusberichte einen aufgesetzt und zusätzlich zum Systemereignisprotokoll meine Logdatei ausgewählt.

 

Laut diesem wird die Mail versendet, unter Ereignisanzeige > System steht aber:

 

Die Nachrichtenübermittlung an den Host xxx.xxx.xxx.xxx ist fehlgeschlagen, während an die remotedomäne "mailprovider.tld" übermittelt wurde. Ursache: es ist ein SMTP-Protokollfehler aufgetreten.

 

Obwohl ich den Statusbericht deaktivert und den Warteschlangenordner geleert habe erscheint diese Meldung nun täglich. Keine Ahnug wo er die Mail noch zu versenden sucht. Abgesehen davon verstehe ich nicht, warum er die gar nicht versenden kann. Ich habe ein paar meiner E-Mail-Adressen bei anderen Providern versucht, in den Bounces im Drop-Ordner stand dann sowas wie:

 

Den folgenden Empfängern konnte die Nachricht nicht zugestellt werden, weil keine Verbindung mit dem Zielserver hergestellt werden konnte.

 

Dies ist eine automatisch erstellte Benachrichtigung über den Zustellstatus.

Übermittlung zu folgenden Empfängern fehlgeschlagen.

 

Der virtuelle SMTP-Server wurde von meinem Vorgänger aufgesetzt und im FirmenLAN für nichts verwendet, die User connecten also per Pop3 zum Provider. Warum kann ich nicht per SMTP direkt versenden? TIA!

Share this post


Link to post
Share on other sites

Naja, ich finde, so ne simple Funktion sollte schon ohne Extrasoftware möglich sein. Trotzdem hatte ich blat bereits probiert und bekam die Fehlermeldung:

 

The SMTP server does not like the name externer.account@provider.tld

Have you set the 'To:' field correctly, or do you need authorization (-u/-pw) ?

The SMTP server response was -> 550 5.7.1 Unable to relay for externer.account@provider.tld

Share this post


Link to post
Share on other sites

Hallo.

 

Have you set the 'To:' field correctly, or do you need authorization (-u/-pw) ?

 

Nun weißt du zumindest den Fehler, entweder korrekten Domain Namen zum versenden, oder beim Relay Host authentifizieren, was auch logisch ist.

 

LG Günther

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...