Jump to content
Sign in to follow this  
S.R.

Problem mit Zeitsynchronisation

Recommended Posts

Hallo,

 

habe hier eine komplett neue Domain aufgesetzt mit zwei W2K3 Domain-Controllern (dc1, dc2)und ein paar Clients.

 

Wenn ich auf den Client oder auf den DomainControllern "net time" eingebe, erscheint immer "Aktuelle Zeit auf \\dc1 ist .... Der Befehl wurde erfolgreich ausgeführt."

 

Damit sollte die interne Zeitsynchronisation stimmen - dies scheint auch so zu sein, denn alle angeschlossenen Geräte habe die gleiche Uhrzeit - nur eine total falsche :-)

 

Auf dem dc1 habe ich folgende Zeilen in die Kommande-Zeile eingehackt:

W32TM /CONFIG /SYNCFROMFLAGS:MANUAL /MANUALPEERLIST:"PTBTIME1.PTB.DE PTBTIME2.PTB.DE"

W32TM /CONFIG /UPDATE

NET STOP W32TIME && NET START W32TIME

 

Damit sollte doch sich dc1 die Zeit aus dem Internet holen - oder etwa nicht? Weil momentan eilt das Netzwerk mit rund 23 Minuten der Zeit vorraus - hin und wieder sinds aber auch mal wieder nur 5 Min - das wechselt.

 

In meinem alten Netzwerk hatte ich das genauso eingerichtet und da lief das einwandfrei - nur hatte ich da nur einen DC. Kann der Fehler hierdran liegen - das irgendwas in der Domain falsch eingerichtet ist.

 

Hab jetzt schon zig howtos durchgelesen, komme aber irgendwie auf keinen grünen Zweig. Weiß da jemand Rat - will mich endlich wieder auf meine Systemzeit verlassen können :-)

 

Schönes Rest-Wochenende

 

Stefan

Share this post


Link to post

Verbindlicher Zeitserver sollte der PDC sein!

 

Kann es sein, dass Deine Firewall ntp zu den PTB Servern blockt und das System deshalb keine Zeit holen kann?

Share this post


Link to post

Hi,

 

vielen Dank für deine rasche Antwort. Der Befehl

 

W32TM /CONFIG /UPDATE

 

sollte doch manuell die Zeit abholen, oder? Dieser Befehl wird auf jeden Fall einwandfrei durchgeführt und schmeißt keinen Fehler.

 

Wie kann ich sonst prüfen, ob die Firewall lieb ist? Die Firma, die die Firewall verwaltet, behauptet jedenfalls, dass der Port freigeben ist.

 

Dankend

 

Stefan

Share this post


Link to post

Lad Dir mal NetTime da siehst Du genau ob die Zeit sauber geholt wird oder nicht. Wenn der Port offen ist, dann muss nochmal die Config geprüft werden ...

 

BTW .. der Server muss natürlich NTP Client sein damit er von PTB die Zeit holen und verarbeiten kann

Share this post


Link to post

Hi,

 

vielen Dank für deine Antwort - komme leider erst jetzt zum Weiterarbeiten der Aufgabe :-)

 

Ich habe gerade gefunden, dass auf allen Servern und auch Clients der Dienst "Windows-Zeitgeber" aktiv ist. Dies sollte doch der NTP-Client sein, oder nicht? Und da dieser auch auf dem dc1 angezeigt wird, würde ich behaupten, dass er sich damit die Zeit von PTB holen kann - oder sehe ich das falsch?

 

Ich werde mir jetzt mal das vorgeschlagene Tool anschauen und berichten, wass dann kommt. Nochmals dankend

 

Stefan

Share this post


Link to post

Noch ein kleines Update:

 

habe gerade den Befehl "w32tm /resync" in die Kommandozeile des dc1 gekloppt. Danach wird die lokale Zeit auf die korrekte Zeit gesetzt. Da war ich ja schon mächtig happy - aber dann 3 bis 4 Sek. später wurde wieder die falsche Uhrzeit angezeigt.

 

Tja, war wohl was zu früh gefreut. Scheint aber so, dass das Update klappt - also die Firewall lieb ist. Aber wieso klappt das mit setzen der Uhrzeit nicht so, wie ich das will?

 

Dankend

 

Stefan

Share this post


Link to post

Hallo,

 

habe mir gerade mal voller Schock die Ereignisse angeschaut. Dort steht andauernd drin:

 

Typ: Warnung

Ereigniskennung: 50

Quelle w32Time

Kategorie: Keine

Benutzer: nicht zutreffend

Computer: dc1

 

Beschreibung:

Der Zeitdienst hat eine Zeitdifferenz von mehr als 5000 ms auf 900 Sekunden fest- gestellt. Die Zeitdifferenz wurde möglicherweise durch die Synchronisation mit einer ungenauen Zeitquelle oder durch schlechte Netzwerkbedinungen verursacht. Von nun an wird der Zeitdienst nicht mehr synchronisiert, die Zeit keinem weiteren Client mehr zur Verfügung gestellt und die Systemuhr nicht mehr synchronisiert. Sobald ein gültiger Zeitstempel von einem Zeitdienstanbieter empfangen wird, wird der Zeitdienst sich selbst korriegieren.

 

Hat da jemand n' Ahnung. Ich bin nämlich vollkommen verzweifelt. Ich schau jetzt einfach mal, was passiert, wenn ich den Zeitserver ändere... schauen wa mal :-)

 

Danke für eure Tipps.

 

bis dann

 

Stefan

Share this post


Link to post

uiuiui *g*

 

naja also ich würd das ganze einfach per Gruppenrichtline lösen.

 

Du hast eine Gruppenrichtline die nennt sich "Default Domain Controller Policy"!

In dieser Richtlinie steht die Konfig für deine DCs drinen also auch der Zeitdienst und wo er sich seine Zeit holen soll.

Unter Computerkonfiguration/Administrative Vorlagen/System/Zeitanbieter/NTP Client

kannst du diese Richtlinie aktivieren und dabei wird dir gleich mal ein Windows Zeitserver fertig eingetragen.

 

Warum über einen GPO und nicht per Command, ganz einfach weil diese Richtlinie alle DCs gleichzeitig trifft. Das Problem liegt daran, das in einer Domäne die Zeit nie mehr als ich glaub 5 min abweichen darf, weil sonst die Tickets die die Kerberos Authentifizierung verwendet ungültig sind und die DCs sich untereinadern nicht mehr replizieren oder sonstwas können. Deßhalb nehme ich an hat dein DC auch die Uhr wieder an die Domäne angepasst um sich nicht selber auszusperren. Wenn damm musst schon auf allen DCs die Systemzeit gleichzeitig ändern!

 

hth. Joe

Share this post


Link to post

Auf dem DC1 würde ich folgendes Kommando ausführen.

 

Als Zeitserver trage ich hier ptbtime1.ptb.de und ptbtime2.ptb.de ein. Voraussetzung ist hierfür halt auch das die Firewall den NTP-Port durchlässt.

 

 

net time /setsntp:time.windows.com (für einen SNTP-Server, hier das Beispiel für

windows.com) oder

net time /setsntp:”time.windows.com lancom.workgroup” (für z.B. zwei SNTP-Server)

Share this post


Link to post

Hi Leute,

 

habe eure Sachen mal alle durchprobiert aber leider läuft's immer noch nicht. Habe auch immer brav n' Tag gewartet, um zu schauen, ob sich die Lage bessert - aber sie verschlechtert sich von Tag zu Tag.

 

Die Gruppen-Richtlinien-Idee fand ich glaub ich den falschen Ansatz, wenn ich das richtig verstanden habe. Hier werden doch alle Clients mit dem Server aus dem Netz synchronisiert, oder? Aber genau das will ich ja nicht. (Der Ansatz funktioniert übrigens auch nicht - auch vergeblich getestet)

 

Mein Wunsch:

Beide DC holen sich die Zeit aus dem Netz - somit kann immer eine Kiste ausfallen und die interne Zeit ist gesichert. Die Clients holen sich die Zeit von einem DC.

 

Hin und wieder steht im Ereignis-Log drin: Der Zeitanbiter "NtpClient" empfängt momentan gültige Zeitdaten von ptbtime2.ptb.de (.....).

Das baut mich dann immer wieder auf. Aber n' Stunde oder zwei später steht dann wieder die Fehlermeldung, die ich oben schonmal gepostet hab, wieder im Log drin und ich weiß net weiter.

 

net time /setsntp:”ptbtime1.ptb.de ptbtime2.ptb.de ” hat meiner Ansicht keine Auswirkung gebracht. Bei der Eingabe von "net time /querysntp" stehen weiterhin die zwei Server drin - so wie ich es ja auch für richtig empfinde.

 

Ich war eben so mutig, und habe die Uhr per Hand am dc1 umgestellt - wurde aber ebenfalls wieder zurück gestellt.

 

Also langsam bin ich echt am Verzweifeln. Ich meine 34 Min. in der Zukunft zu leben ist zwar ganz cool - aber ich will auch mal die Gegenwart genießen :-)

 

Noch jemand Ideen auf Lager - dankend

 

Stefan

Share this post


Link to post

Hi,

 

in der letzten Nacht habe ich gegen 2:00 Uhr alle Server und Clients heruntergefahren, anschließend nur den DC1 wieder gestartet und eine Zeitsynchronisation durchgeführt - ich hatte dann die aktuelle/korrekte Zeit. Nach rund 10 Min. hatte sich die Zeit nicht verstellt und ich hab daher den DC2 aktiviert. Der holte sich brav die Zeit vom DC1. Nach weiteren 10 Minuten warten und keinen ungewünschten Zeitveränderungen, habe ich nach und nach die anderen Server wieder gestartet.

 

Bis jetzt läuft die Uhrzeit korrekt. Ich hoffe, das wird sich auch nicht ändern. Es Ich fand diese Möglichkeit zwar nicht wirklich sauber, aber in der Nacht auf einen Feiertag arbeitet keiner (außer der IT-Abteilung) im Netzwerk - daher konnten wir uns den Ausfall der Server leisten.

 

Ich hoffe, da hat sich jetzt auch gelohnt. Aber erstmal freue ich mich, dass die Server wieder in der Gegenwart leben und nicht so abgehoben in der Zukunft :-)

 

Nochmal danke für eure Hilfen.

 

Stefan

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...