Jump to content
Sign in to follow this  
Futzel

DNS einstellen(Lange Anmeldung)

Recommended Posts

Hi,

 

ich habe das Problem das sich meine XP Clienten bis zu 3 min brauchen um sich an der Domäne anzumelden. Scheint wohl ein Problem mit meinem DNS zu geben.

 

IST-Zustand:

Die Clienten haben alle eine feste IP. Als primären DNS ist der win2003 eingetragen. Als sekundären DNS ist der Router angegeben. der Gateway ist der Router.

 

Ist diese Einstellung so richtig?

Wie kann ich das Problem lösen.

 

Bin für jeden Tipp dankbar.

Share this post


Link to post

Woher weiß den der Sekundäre DNS (Router) die ADS-spezifischen Records?

Lass an den Clients den Eintrag für den Sekundären DNS frei.

Die Auflösung der Internetadressen geht sowieso über deinen primären DNS, da er ja die ROOT-DNS-Server kennt und abfragt.

Share this post


Link to post

Ist aus welchen Gründen auch immer der primäre Server nicht erreichbar, wechselt der Client zum sekundären Server. Und der kennt, wie Marka schon gesagt hat, die SRV-Ressource Records nicht. Der Client springt nicht etwa sofort wieder auf den ersten Server zurück, sondern benutzt den zweiten Server eine gewisse Zeit, bevor er wieder versucht, den primären zu kontaktieren. Und das ist der Grund, warum man keinen Router als sekundären DNS-Server konfiguriert.

Poste aber trotzdem mal die Ausgabe von IPCONFIG /ALL des Servers.

Share this post


Link to post

So hier die DAten:

 

Host Name : server1

Primary DNS suffix: orion.local

Node Type: Hybrid

IP routing Enabled: no

Wins Proxy enabled: no

DNS Suffix Swearch List: orion.local

 

 

DHCP Enabled: No

IP Adress: 192.168.123.100

Subnet Mask: 255.255.255.0

Defeault Gateway: 192.168.123.254

DNS Server: 192.168.123.100

192.168.123.254

Primary Wins Server: 192.168.123.100

Share this post


Link to post

Auf jeden Fall den sekundären DNS-Server rausnehmen, ausser es ist ein Domänen DNS-Server. Sonst sieht es okay aus. Lade Dir mal die Support Tools herunter, installiere sie, führe NETDIAG durch und überprüfe die Ausgabe, besonders hinsichtlich DNS-Registrierung. Poste bitte auch noch mal IPCONFIG /ALL eines Clients ...

Share this post


Link to post

Hier mal der Auszug aus dem netdiag:

 



C:\Documents and Settings\Administrator>netdiag

.......................................



Per interface results:

   Adapter : Local Area Connection 2

       Netcard queries test . . . : Passed

       Host Name. . . . . . . . . : server1
       IP Address . . . . . . . . : 192.168.123.100
       Subnet Mask. . . . . . . . : 255.255.255.0
       Default Gateway. . . . . . : 192.168.123.254
       Primary WINS Server. . . . : 192.168.123.100
       Dns Servers. . . . . . . . : 192.168.123.100


       AutoConfiguration results. . . . . . : Passed

       Default gateway test . . . : Passed

       NetBT name test. . . . . . : Passed
       [WARNING] At least one of the <00> 'WorkStation Service', <03> 'Messenge
r Service', <20> 'WINS' names is missing.
           No remote names have been found.

       WINS service test. . . . . : Failed
           The test failed.  We were unable to query the WINS servers.


Global results:


Domain membership test . . . . . . : Passed


NetBT transports test. . . . . . . : Passed
   List of NetBt transports currently configured:
       NetBT_Tcpip_{9905D1FF-EB5D-4C70-9E45-D0AD1AC32538}
   1 NetBt transport currently configured.


Autonet address test . . . . . . . : Passed


IP loopback ping test. . . . . . . : Passed


Default gateway test . . . . . . . : Passed


NetBT name test. . . . . . . . . . : Passed
   [WARNING] You don't have a single interface with the <00> 'WorkStation Servi
ce', <03> 'Messenger Service', <20> 'WINS' names defined.


Winsock test . . . . . . . . . . . : Passed


DNS test . . . . . . . . . . . . . : Failed
         [WARNING] Cannot find a primary authoritative DNS server for the name
           'server1.orion.local.'. [RCODE_SERVER_FAILURE]
           The name 'server1.orion.local.' may not be registered in DNS.
   [WARNING] The DNS entries for this DC are not registered correctly on DNS se
rver '192.168.123.100'. Please wait for 30 minutes for DNS server replication.
   [FATAL] No DNS servers have the DNS records for this DC registered.


Redir and Browser test . . . . . . : Passed
   List of NetBt transports currently bound to the Redir
       NetBT_Tcpip_{9905D1FF-EB5D-4C70-9E45-D0AD1AC32538}
   The redir is bound to 1 NetBt transport.

   List of NetBt transports currently bound to the browser
       NetBT_Tcpip_{9905D1FF-EB5D-4C70-9E45-D0AD1AC32538}
   The browser is bound to 1 NetBt transport.


DC discovery test. . . . . . . . . : Passed


DC list test . . . . . . . . . . . : Passed


Trust relationship test. . . . . . : Skipped


Kerberos test. . . . . . . . . . . : Passed


LDAP test. . . . . . . . . . . . . : Passed


Bindings test. . . . . . . . . . . : Passed


WAN configuration test . . . . . . : Skipped
   No active remote access connections.


Modem diagnostics test . . . . . . : Passed

IP Security test . . . . . . . . . : Skipped

   Note: run "netsh ipsec dynamic show /?" for more detailed information


The command completed successfully

C:\Documents and Settings\Administrator>

 

Den DNS des Routers habe ich in den Netzwerkeisntellungen entfernt.

 

ES scheint beim DNS Test wohl einen Fehler zu geben. wie kann ich diesen denn beheben?

 

@lefg

wo kann ich denn sehen ob es Clienten erlaubt ist sich im DNS zu registrien??

Share this post


Link to post
wo kann ich denn sehen ob es Clienten erlaubt ist sich im DNS zu registrien??
Im DNS, Forward Lookupzonen, Eigenschaften der jeweiligen Zone, Allgemein, Daten werden in Active Directory gespeichert, Dynamische Updates.

 

Aus deiner Frage muss ich schliessen, du kennst dich mit der Geschichte nicht aus, hast darüber noch keine Literatur studiert.

 

Da stellt sich für mich die Frage was ist da überhaupt installiert als DNS, Stammheinweise, was für Zonen? Wurden da etwas Weiterleitungen konfiguriert? Falls ja, wohin?

Share this post


Link to post

Wenn Du, wie Lefg geschrieben hat, die Zonen so konfiguriert hast, dass sie dynamische Updates unterstützen, dann führe auf dem Server IPCONFIG /REGISTERDNS und NETDIAG /FIX durch. Danach noch mal mit NETDIAG prüfen, ob die Einträge vorhanden sind ...

Share this post


Link to post

Hat leider nichts gebracht. ist alles noch so wie vorher auch.

 

Dynamic Updates stehen beiallen Zonen auf "Secure only"

 

Wie verfahren wir weiter?

Gibt es Howtos die beschreiben, wie so ein DNS einzurichten ist?

Oder soll ich mal Screens von den Zonen posten??

Share this post


Link to post

lt. netdiag hat sich der DC sich selbst nicht registriert.

 

-schalt die DNS-Zone orion.local mal auf " allow nonsecure and secure"

-lösch die Datei netlogon.dns

- Falls vorhanden leere die Zone _msdcs.orion.local (nicht löschen nur die Subtrees löschen)

-in der Commandline: commandline: net stop netlogon && net start netlogon && ipconfig -registerdns"

- setz die Zone wieder auf secure

 

falls es noch nicht funktioniert:

- was sagt das dns-eventlog, warum die Registrierung nicht geht?

- ist die _msdsc.orion.local Zone da

 

cu

blub

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...