Jump to content
Sign in to follow this  
thork

iis6 & php & mysql auf einem server... aber wie?

Recommended Posts

hallo,

 

ich habe die letzten 2 tage diverse internetseiten nach einer isntallation für php unter einem iss6 abgesucht. leider erfolgslos. deswegen bin ich nu hier.

 

folgende situation:

 

- ich habe einen win2k3 sp1 server standalone

- nach der installation habe ich denn iis6 installiert.

- die standardseite kann angezeigt werden über http://IP bzw. über http://localhost

- dann habe ich php 4.4.0 als installaer installiert, wie in der routine beschrieben die berechtigungen der dateien & verzeichnisse gesetzt.

eine mini index.php zeigt alles als ok an (<?php phpinfo(); ?> )

- demanch sollte doch alles ok sein, oder?

 

- dann habe ich mysql 4.1.13 als installations routine installiert

- phpmydamin 2.6.3 isntalliert und bekomme nur nach aufruf der seite folgende meldung

 

"Sie haben nicht die Berechtigung, um die Seite anzuzeigen"

 

jetzt meine frage an euch.

 

was habe ich falsch gemacht?!

 

habe überall den anweisungen der installationen gefolgt

 

gruß thork

Share this post


Link to post
Share on other sites

danke für die schenlle antwort,

 

da hab ich auch schon nachgeschaut.

 

dummerweise funktioniert der apache auch direkt,

 

leider möchte ich aber den iss ans laufen bringen.

 

ich bin jetzt soweit das ich ne fehlermeldung bekomme:

 

 

Warning: main(./libraries/grab_globals.lib.php): failed to open stream: No such file or directory in c:\inetpub\wwwroot\phpmyadmin\index.php on line 8

 

Fatal error: main(): Failed opening required './libraries/grab_globals.lib.php' (include_path='.;c:\php4\pear') in c:\inetpub\wwwroot\phpmyadmin\index.php on line 8

 

 

ich weiß leider nicht wo ich den pfad ändern kann, bei mir heißt das verzeichnis nur php, das pear gibts gar net ?!

Share this post


Link to post
Share on other sites

Hallo thork!

 

also das problem hatte ich auch auf meinem rechner da wir gerade dabei sind ein Redaktionstool mittels Typo3 auszuarbeiten!! hab es aber mit IIS5 geschafft 6 weiss ich es nicht ob es gleich funktioniert!

 

auf der folgenden Seite findest du eine genaue Anleitung wie es funktioniert! wenn du genau mit den Paketen die er zur verfügung stell installierst wirst du keine probleme haben (denk ich mal)

 

P.s. hatte genau den gleichen fehler wie du nur hab ich dann seine pakete genommen und es hat tadellos funktioniert bis auf das dass ich mich beim mysql ausgesperrt hab :D

 

http://www.thomas-peterson.de/65.0.html

 

mfg

martin

Share this post


Link to post
Share on other sites

vielen dank,

 

ich habs mir mal angeschaut,

 

habe es jetzt hinbekommen, ohne die pakete. ich bin einfach auf ne ältere mysql version gegangen. dann hats funktioniert. ?!

 

aber anstrengend ist es schon, jeder hat seine bestimmten pakete mit bestimmten, oder die anleitungen beziehen sich nur auf eine bestimmte version.

 

ich habe jetzt php 4.4.0 mit mysql 4.0.25 und phpmyadmin 2.6.3

rechte überprüft, und fertig

 

danke für eure schnelle hilfe

 

gruß thork

Share this post


Link to post
Share on other sites

MySQL hat seit der Version 4.1 eine geänderte Authentifizierung, das kann erst PHP > 5.0.

Man kann über die old_passwords Confiog Variable MySQL auch wieder auf die alte Methode umstellen. Genaueres dazu in der MySQL Doku. Würde die 4.1 empfehlen die kann ansonsten mehr (Subquerys, Unicode...)

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...