Jump to content

PIO statt DMA


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Hallo zusammen,

 

nach der erfolgreichen Installation von Win 2003 Server Standard musste ich leider feststellen das die Platten nur im PIO statt im DMA-Modus laufen.

Folgendes System ist betroffen (auf anderen Maschinen des gleichen Typs habe ich die gleichen Probs.)

 

IBM E-Server 330

2x1 GHz / 1 GB RAM / 2x 20GB IDE HD

 

Kann jemand was dazu sagen ??

 

Thx ! :confused:

Link to comment

hab hier was von einer hilfeseite:

 

Sollte dort nur PIO-Modus ausgewählt sein, und lässt sich der DMA-Modus auch nach einem Neustart nicht aktivieren, so deinstalliere den IDE-Controller und den primären sowie sekundären Kanal und starte den Server neu. Nach diesem Reboot werden die Geräte neu erkannt und die Laufwerke sollten auch wieder im UDMA-Modus laufen.

Woran liegts? Sobald Windows Übertragungsfehler feststellt, schaltet es nach insgesamt 6 Zeitüberschreitungs- oder CRC-Fehlern jeweils einen Modus herunter. Dies geht soweit bis entweder der PIO-Modus erreicht wurde oder die Übertragungsfehler nicht mehr auftreten.

 

Nur die erneute Installation des IDE-Controllers oder das manuelle Ändern einiger Registryeinträge schaffen (zeitweise) Abhilfe. Schuld an diesen Übertragungsfehlern könnte beispielsweise ein defektes Datenkabel oder der fehlerhafte IDE/ATA-Treiber des Chipsatzherstellers sein. Passiert dies nach einer gewissen Zeit wieder, so solltest du probeweise das IDE/ATA-Kabel wechseln oder den Standard-Zweikanal-PCI-IDE-Controller von Microsoft installieren.

Link to comment

Motherboard Chipsatz :

ServerWorks NB6635 Champion LE

 

Das POST zeigt keine Infos über die Platten an.

Auf dem Board ist nen SCSI Controller der aber standardmäßig nicht genutzt wird, der Server wird mit IDE Platten ausgeliefert.

 

Es kann aber auch nicht an der Hardware liegen, mit Win2000 Server oder anderen OS wird der DMA ganz normal aktiviert.

 

Es muss also ein Problem von W2003 sein.

Link to comment

Hat jemand das mal getestet ?

 

Teil 1 :

 

"Der DMA-Fehler ist bereits seit Windows 2000 bekannt und sollte sich mit folgendem Workaround ausmerzen lassen: Starten Sie den Rechner neu und drücken Sie nach dem Initialisieren der Komponenten durch das BIOS (Piep-Signal) die Taste [F8] so oft, bis der Bootvorgang von Windows XP unterbrochen und ein Auswahlmenü angezeigt wird. Dort wählen Sie ""Abgesicherter Modus"" und lassen SIe den Rechner vollständig hochfahren. In Windows starten Sie anschließend die ""Eingabeaufforderung"" (Start/ Programme/ Zubehör). Dort müssen Sie jetzt exakt u.a. Befehlsfolgen eingetippen: set devmgr_show_nonpresent_devices=1 (Enter drücken) cd\windows\system32 (Enter drücken) start devmgmt.msc (Enter drücken) Daraufhin öffnet sich der Gerätemanager, in dessen Menü ""Ansicht"" die Option ""Ausgeblendete Geräte anzeigen"" gewählt werden muß. Jetzt müssen diverse Einträge lt. u.a. Schritt-für-Schritt-Anleitung entfernt werden. ACHTUNG: STARTEN SIE IHREN RECHNER KEINES FALLS NEU, SELBST WENN SIE DAZU AUFGEFORDERT WERDEN! SCHRITT 1: Klicken Sie zuerst auf die Rubrik ""Diskettenlaufwerke"" um alle Geräte in dieser Rubrik aufzulisten und prüfen Sie, ob sich in dieser Aufstellung mehr Laufwerke befinden als im Rechner tatsächlich vorhanden. Alle überflüssigen und auch sämtliche ausgegrauten Laufwerke müssen entfernt werden. SCHRITT 2: Danach entfernen Sie in der Rubrik ""DVD/CD-ROM-Laufwerke"" das Laufwerk, das im PIO-Modus betrieben wird. Falls an dem entsprechenden IDE-Kanal, an dem dieses Laufwerk angeschlossen ist, ein zweites Drive hängt, muß es ebenfalls entfernt werden.

Link to comment

Teil 2 :

 

In Ihrem Fall müssen also alle Geräte, die am sekundären IDE-Kanal hängen, entfernt werden. SCHRITT 3: Nun entfernen Sie in der Rubrik ""IDE ATA/ATAPI-Controller"" den IDE-Kanal, an dem das Laufwerk angeschlossen ist, das im PIO-Modus angesprochen wird und das Sie zuvor gelöscht haben (in Ihrem Fall ""Sekundärer IDE-Kanal""). Sollten auch noch ausgegraute aufgeführt sein, diese ebenfalls entfernen. SCHRITT 4: Daraufhin klicken Sie auf die Rubrik ""Speichervolumes"" und löschen dort alle ausgegrauten Einträge, falls vorhanden. SCHRITT 5: Schließen Sie jetzt zuerst den Gerätemanager und dann die Eingabeaufforderung. Um anschließend den Rechner runterzufahren, klicken Sie auf ""Start/ Ausschalten/ Ausschalten"" (nicht ""Neu starten""!). SCHRITT 6: Nachdem sich der Rechner ausgeschaltet hat, öffnen Sie zunächst einmal das Gehäuse des Rechners. Falls am Flachbandkabel des sekundären IDE-Kanals lediglich das betroffene Laufwerk als ""Master"" angeschlossen ist (Stecker am Ende des Flachbandkabels), überspringen Sie die Schritte 7, 8 und 9, schließen Sie das Gehäuse und schalten Sie den Rechner wieder ein. SCHRITT 7: Sind an dem Kabel zwei Laufwerke (1x ""Master"" und 1x ""Slave"") angeschlossen, entfernen Sie den Stecker an dem als ""Slave"" betriebenen Laufwerk (Stecker in der Mitte des Flachbandkabels). Lassen Sie Ihr System geöffnet, da Sie das Laufwerk später wieder an das Flachbandkabel anschließen müssen. SCHRITT 8: Starten Sie Ihren Rechner ab jetzt wieder normal (kein ""Abgesicherter Modus"") und Windows XP sollte zuerst das Laufwerk und dann den Controller neu erkennen. Nachdem dieser Vorgang abgeschlossen wurde, werden Sie zum Neustart aufgefordert. Bestätigen Sie dies mit ""OK"" und starten Sie den Rechner neu. Im Gerätemanager sollte anschließend das Laufwerk mit dem DMA-Modus gelistet sein. SCHRITT 9: Fahren Sie Ihren Rechner wieder herunter (nicht ""Neu starten""!), schließen Sie das Kabel an dem zweiten Laufwerk an, schließen Sie Ihr Gehäuse und schalten Sie den Rechner wieder ein. Windows XP erkennt jetzt das zweite Laufwerk, frägt aber nicht mehr ob das System neu gestartet werden soll. Jetzt sollten im Gerätemanager beide Laufwerke im DMA-Modus gelistet sein (SCHRITT 10 ignorieren). SCHRITT 10: Windows XP sollte zuerst das Laufwerk und dann den Controller neu erkennen. Nachdem dieser Vorgang abgeschlossen wurde, werden Sie zum Neustart aufgefordert. Bestätigen Sie dies mit ""OK"" und starten Sie den Rechner neu. Im Gerätemanager sollte anschließend das Laufwerk m

it dem DMA-Modus gelistet sein."

Link to comment
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...