Jump to content
Sign in to follow this  
substyle

"Tote" Netzwerkkarte Entfernen ?

Recommended Posts

Hallo leute ...

 

Wie um Himmels willen bekomme ich eine "tote" Netzwerkkarte

aus meinem W2k Server ?

Mit Tot meine ich , das nachdem ich die Netzwerkkarte ausgetauscht

hatte und die alte IP für die neue Karte wieder konfigurieren wollte,

ich eine Fehlermeldung bekam das ein anderes Gerät die selbe IP benutzt .. bla bla ..

 

Vorschläge ??

 

Lars

Share this post


Link to post

Man findet die Karten unter HKLM/System/CurrentControlSet/Services. Dort erscheinen ganz oben so lange Zahlen in geschweifter Klammer, die GUIDs der Karten. Leider stehen die Karten nicht mit Namen drin, man muss in die einzelnen Werte reinschauen, um die Karten an Hand der eingetragenen IPs zu identifizieren. Diese Nummern tauchen nochmals weiter unten unter TCP/Parameters/Interfaces auf.

 

Die entsprechenden Schlüssel löschen, aber Vorsicht!!

 

grizzly999

Share this post


Link to post

Ich hatte den Fall unter 2003 noch nicht (dreimal auf Holz klopf), aber ich denke nicht, denn unter XP hatte ich so schon Kartenleichen drin :rolleyes:

 

grizzly999

Share this post


Link to post
Original geschrieben von Velius

Vor dem Rausnehmen die IP freigeben, that´s it.....

 

Kunststück wenn die Karte abka**t ohne das rechtzeitig vorher anzumelden.

 

Original geschrieben von grizzly999

Ich hatte den Fall unter 2003 noch nicht (dreimal auf Holz klopf), aber ich denke nicht, denn unter XP hatte ich so schon Kartenleichen drin

 

Dann werd ich doch morgen mal unserem ISA-Testserver eine Karte ziehen und sehen was W2K3 dazu sagt.

 

Gruss

Markus

Share this post


Link to post

Die "Leichen" kenn ich auch, aber man kann der neuen Karte dennoch die IP der "Leiche" neu vergeben !

 

@substyle: Kannst Du die Fehlermeldung bestätigen und dann die IP zuweisen ?

 

PS:

@all: Es geht um einen w2k - nicht um einen w2k3 !

Share this post


Link to post
Die "Leichen" kenn ich auch, aber man kann der neuen Karte dennoch die IP der "Leiche2 zuordnen !

Nein, genau das geht nicht, das ist ja das Problem. Da kommt er dann her und mosert, die IP sei schon in Verwendung. Spätestens dann weiß man, dass man Leichen im Reg-Keller hat :D

 

grizzly999

Share this post


Link to post

Ja, kann ich. Die IP funzt anscheinend tadelos ..

Dennoch möchte ich, bis wir hier die Server nach W2k3

migrieren, saubere Systeme haben , und da ist mir das

schon wichtig.

 

Ich werde morgen mal kurz in der Firma reinschauen ..

Naja besser in meinem "Kellerloch" .. bin in der Firma

schon als "Gollum" bekannt ..

 

Ich poste dann ..

 

Thx, subby

Share this post


Link to post

Unter W2k bekommt man solche "Leichen" auch komfortabel über den Hardware-Assistenten entfernt.

 

Den Assi starten, Gerät permant deinstallieren wählen, unter der folgenden Geräteliste das Häkchen bei "Versteckte Geräte anzeigen" setzen. Dann zeigt er alle Geräte an, auch die Leichen. Markieren und weg damit. ;)

 

Unter XP fehlt leider diese Option, oder ich hab´ sie noch nicht gefunden.:(

 

Damian

Share this post


Link to post

Also mein XP hat im Gerätemanager die Option "Versteckte Geräte anzeigen", aber bei den richtigen NIC-Leichen hilft das weder bei XP noch bei W2k, da habe ich mich nämlich schon vor Jahren, bevor XP rauskam, das erste mal durch die Registry gewühlt, bis ich die Einträge hatte.

 

grizzly999

Share this post


Link to post
Original geschrieben von Blacky_24

Kunststück wenn die Karte abka**t ohne das rechtzeitig vorher anzumelden.

 

 

Es hat niemand gesagt, dass die Karte am leben sein muss, Hauptsache, der Hardware Manager sieht noch, dass da noch was ist.

 

(Alles andere hab ich bisher noch nicht erlebt...., zum Glück)

 

 

@Damian: Die Option gibt´s!!

Share this post


Link to post

@ grizzly999

Unter W2k meinte ich den Hardware-Assistenten, nicht den Gerätemanager. Mit dem Assi bekommt man die Leichen weg.

 

Mit dem Gerätemanager klappt´s unter W2k und XP nicht richtig. Leider.

Und unter XP hat der Assi diese Option mit den versteckten Geräten nicht mehr.

 

Damian

Share this post


Link to post

Oder so:

 

http://support.microsoft.com/?id=269155

 

Click Start, click Run, type cmd.exe, and then press ENTER.

Type set devmgr_show_nonpresent_devices=1, and then press ENTER.

Type Start DEVMGMT.MSC, and then press ENTER.

Click View, and then click Show Hidden Devices.

Expand the Network Adapters tree.

Right-click the dimmed network adapter, and then click Uninstall.

 

Hatten wir schon mal irgendwo im Forum, Stichwort "Ghosted NIC"

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...