Jump to content

Exchange 2019 Fehler


Recommended Posts

Hallo Experten,

 

ich habe ein Exchange 2019 aufgesetzt.Wenn ich eine Email sende,bekomme ich die Fehlermeldung das die öffentliche IP bei spamhaus auf der PBL liste ist.Okay

wenn ich eine email von einer freemail adresse zu meinen exchange schicken,bekomme ich keine Fehlermeldung,aber es kommt auch keine Email an :shock:.

Wenn ich auf der Microsoft seite den eingehenden SMTP test mache kommt folgende Fehlermeldung:

 

Es wird versucht, eine Test-E-Mail an test.tester@tgt-*.de mithilfe von MX yob1tcuqs224*.myfritz.net zu senden.
Fehler beim Zustellen der Test-E-Mail.
 
Weitere Details
Der Server gab folgenden Statuscode zurück: -1 - Failure sending mail. Ausnahmedetails: Nachricht: Failure sending mail. Typ: System.Net.Mail.SmtpException Stapelüberwachung: at System.Net.Mail.SmtpClient.Send(MailMessage message) at Microsoft.M365.RCA.ConnectivityTests.SmtpMessageTest.PerformSmtpMessageTest(RcaTestContext parent, String mailExchangerHost, ISmtpAddress emailAddress, ContextInfo contextInfo, SmtpOptions smtpOptions) Ausnahmedetails: Nachricht: Unable to connect to the remote server Typ: System.Net.WebException Stapelüberwachung: at System.Net.ServicePoint.GetConnection(PooledStream PooledStream, Object owner, Boolean async, IPAddress& address, Socket& abortSocket, Socket& abortSocket6) at System.Net.PooledStream.Activate(Object owningObject, Boolean async, GeneralAsyncDelegate asyncCallback) at System.Net.ConnectionPool.GetConnection(Object owningObject, GeneralAsyncDelegate asyncCallback, Int32 creationTimeout) at System.Net.Mail.SmtpConnection.GetConnection(ServicePoint servicePoint) at System.Net.Mail.SmtpClient.GetConnection() at System.Net.Mail.SmtpClient.Send(MailMessage message) Ausnahmedetails: Nachricht: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 46.142.*:25 Typ: System.Net.Sockets.SocketException Stapelüberwachung: at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress) at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Exception& exception)
Link to comment

Versenden wirst du vermutlich mit deiner dynamischen ip nicht können. Da hilft nur ein entsprechender Smarthost/relay, der das für dich erledigt. Alternativ besorge dir eine statische ip.

 

an deiner FRITZ!Box musst du Port 25 an deinen Exchange weiterreichen. Ich vermute das will dir die Fehlermeldung sagen. Zukünftig solche Meldungen hier als Code formatiert reinstellen, dann ist das nicht so umständlich zu lesen.

 

bye

norbert

 

ps: keine der Fehlermeldungen stammen übrigens vom Exchange 2019. ;)

Edited by NorbertFe
Link to comment

Hallo,

 

danke erstmal für die Antworten. Zum Test habe ich mir einen SMTP anbieter rausgesucht.

Ich habe die entsprechenden DNS einstellungen vorgenommen und konnte auch mit einer SMTP test email seite eine email mit der domain verschicken und empfangen.

 

Leider funktioniert es aber nicht mit mein Exchange, also müssen die Einstellungen dort falsch sein oder ich mache einen Fehler:

 

Im Anhang sind die Einstellungen vom Sende und Empfangsconnector

 

1.png

2.png

3.png

1.1.png

2.2.png

Link to comment

Man kanns aber auch besonders unpraktisch machen. Alles in Exchange geht mehr oder weniger auch in Powershell. So dass man die Einstellungen seines Sendeconnectors relativ easy per get-sendeconnector | fl hier einkopieren könnte.

vor 20 Minuten schrieb Rocko00:

also müssen die Einstellungen dort falsch sein oder ich mache einen Fehler:

Was wohl mehr oder weniger aufs Gleiche hinausläuft.

 

Nimm mal den Haken bei Proxy über Clientzugriffsserver raus. Und schalte das Logging an. Dann kann man im Logfile sehen, was nicht funktioniert.

 

Ist dein Server denn inzwischen von extern per Port 25 erreichbar? Warum gibst du smtp.postmarkapp.com im Empfangsconnector an? Stimmt ja erstens sowieso nicht und zweitens hast du den Namen nicht mal im Zertifikat, so dass auf dem Connector dann kein TLS angeboten wird. Für einen vom Internet aus erreichbaren SMTP Connector solltest du NUR anonyme Verbindunen zulassen und da du den EHLO String angepaßt hast, solltest du dir einen eigenen Connector dafür bauen und den Default Frontend Connector auf die Remote IP ADressen deines LANs eingrenzen.

 

Bye

Norbert

Edited by NorbertFe
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...