Jump to content

Gateway zu einzelner IP - Windows verwendet Standard-Gateway


Recommended Posts

Hallo zusammen,

 

ich habe hier im Netz zwei Gateways (192.168.249.1 und 192.168.249.2). Default Gateway ist das 192.168.249.1. Nun möchte ich überprüfen, ob über das Gateway 192.168.249.2 eine Verbindung ins Internet funktioniert. Dazu möchte ich eine Test-IP anpingen (in dem Fall die 8.8.8.8). Unter Linux habe ich den Ansatz schon öfters verwendet, unter Windows klappt das aber aus mir nicht erklärlichen Gründen nicht:

- route add 8.8.8.8 mask 255.255.255.255 192.168.249.2

- ping ausführen

- route löschen

 

IPv4-Routentabelle
===========================================================================
Aktive Routen:
     Netzwerkziel    Netzwerkmaske          Gateway    Schnittstelle Metrik
          0.0.0.0          0.0.0.0    192.168.249.1   192.168.249.40    281
          8.8.8.8  255.255.255.255    192.168.249.2   192.168.249.40     26
        127.0.0.0        255.0.0.0   Auf Verbindung         127.0.0.1    331
        127.0.0.1  255.255.255.255   Auf Verbindung         127.0.0.1    331
  127.255.255.255  255.255.255.255   Auf Verbindung         127.0.0.1    331
    192.168.249.0    255.255.255.0   Auf Verbindung    192.168.249.40    281
   192.168.249.40  255.255.255.255   Auf Verbindung    192.168.249.40    281
  192.168.249.255  255.255.255.255   Auf Verbindung    192.168.249.40    281
        224.0.0.0        240.0.0.0   Auf Verbindung         127.0.0.1    331
        224.0.0.0        240.0.0.0   Auf Verbindung    192.168.249.40    281
  255.255.255.255  255.255.255.255   Auf Verbindung         127.0.0.1    331
  255.255.255.255  255.255.255.255   Auf Verbindung    192.168.249.40    281
===========================================================================
Ständige Routen:
  Netzwerkadresse          Netzmaske  Gatewayadresse  Metrik
          0.0.0.0          0.0.0.0    192.168.249.1  Standard
===========================================================================

 

Ergebnis:

tracert 8.8.8.8

Routenverfolgung zu dns.google [8.8.8.8]
über maximal 30 Hops:

  1    <1 ms    <1 ms    <1 ms  192.168.249.1
                            
...

 

Windows verwendet also trotz der spezifischen Route zum anderen Gateway offensichtlich das Standard-Gateway. Das Verhalten kann ich mir leider nicht erklären. Muss man die routing-Tabelle in Windows "aktualisieren"?

 

Danke und Grüße,

Johannes

Link to post

Hi,

 

was hast du denn am Ende vor? Bzw. warum willst du die Internetkonnektivität über Gateway 2 am Client testen?

 

Ich vermute, du solltest die Aufgabe an einem / beiden Gateways umsetzen und dort die Verbindung überwachen sowie dort dann auch ein Failover oder Loadbalancing durchführen. Hier müsste man jetzt natürlich wissen, welche Gateways zum Einsatz kommen (und was du zu lösen versuchst).

 

Gruß

Jan

Link to post

Ich denke, er will prüfen, ob er über das zweite Gateway ins Internet kommt, ohne das Default Gateway des Rechners umzustellen.

 

Die Konfiguration sieht korrekt aus. Die Route ist drin und hat eine niegrigere Metrik als die Default Route. Ich habe das so auch schon verwendet für Tests und aktuell auf einem Server 2012 R2 im Einsatz. Dort allerdings mit einer Netzwerk- und keiner Hostroute, also mit Mask 255.255.255.0. Evtl. probierst Du es mal so?

Link to post

Hallo zusammen,

 

es gibt mehrere Internetanschlüsse, die alle über einen Loadbalancing-Router zusammengefasst werden und somit den Clients/Servern eine "eindeutige" Route aufweisen. Ich möchte aber für einen Admin-PC, dass dieser unabhängig vom Loadbalancing-Router (falls da mal was ausfällt) ins Internet kommt, um im Notfall über z.B. Teamviewer auf zumindest diesen PC zuzugreifen und dann nötige Maßnahmen ergreifen zu können. Daher möchte ich testen ob die Gateways tatsächlich ins Internet kommen und dann das default-Gateway automatisch ändern.

 

Das Problem konnte ich nun identifizieren: Bei meinen Tests hab ich den Zugriff auf die 192.168.249.2 einfach komplett in der Firewall des Gateways blockiert. Somit hat Windows keine Antwort vom Gateway erhalten und dann das nächst beste (=das default-Gateway) als Route genommen. Ich hatte fälschlicherweise erwartet, dass der Ping in einen timeout läuft. Mein Script habe ich daher wie folgt angepasst: Ich prüfen zunächst ob das Gateway überhaupt erreichbar ist und erst bei Erfolg setze ich die Route und prüfe die Verbindung ins Internet.

 

Danke und Grüße,

Johannes

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...