Jump to content

Clients werden nicht angezeigt im WSUS


Recommended Posts

vor einer Stunde schrieb xnoname:

Danke für die Antwort und ja habe ich alles geprüft.

Gibt es Fehlermeldungen im Ereignisprotokoll? Was spricht die WindowsUpdate.log? Was genau hast Du schon alles unternommen?

vor einer Stunde schrieb xnoname:

Ich verstehe bloß nicht warum ich einen Server hinzufügen konnte ohne Probleme und nun klappt es nicht mit einem Windows 10 Client...

Du kannst keinen Server oder Client hinzufügen, das wäre ja dann zu einfach. Die Clients/Server finden den WSUS, oder auch nicht und zeigen sich dann in der WSUS-Konsole.

Edited by Sunny61
Link to post

Ja, weil der WSUS dumm wie Brot ist oder so ähnlich... :D

 

- Firewallfreigabe könnte noch fehlen --> entweder testweise deaktivieren oder Audit-Logging aktivieren (bevorzugt)

- Registrierung manuell anstossen (wuauclt /detectnow)

- Authorisierung neu machen (wuauclt.exe /resetauthorization danach detectnow)

- kontrollieren ob der Client evtl.noch Überrest von einer vorherigen Anmeldung hat, also die ID in der Registry löschen und anschliessend Neustart und dann detectnow

 

Link to post
vor 55 Minuten schrieb Weingeist:

weil der WSUS dumm wie Brot ist oder so ähnlich.

Dumm wie *trocken* Brot. :)

 

BTW: Wuauclt /detectnow gibt es in W10 nicht mehr. Es funktioniert nur noch ein /reportnow und ein wuauclt /resetauthorization /detectnow und natürlich noch die UsoClient.exe mit diversen Parametern. Wuauclt allerdings nur in einer administrativen Commandline.

Link to post
vor 12 Stunden schrieb Sunny61:

... natürlich noch die UsoClient.exe mit diversen Parametern. Wuauclt allerdings nur in einer administrativen Commandline.

Ist das die, welche ich bevorzugt übergehe/ausbremse/mobbe solange es noch geht? :D

 

Die UsoClient.exe mit ihrem Dienst macht normal aber eher in dem Sinne Ärger, dass evtl. unerwünschte Updates/Treiber etc. reinkommen. Da ich diese im Moment noch per GPO mobbe habe ich diese Art von Ärger allerdings nicht mehr.

Evtl. wäre es möglich, dass er darüber etwas ziehen möchte, es nicht bekommt, aber als Alternative nicht WSUS nimmt... Müsstest mal schauen ob Du in der GPO tatsächlich "übergehen" drinn hast für die Übermittlungsoptimierung. Sowie den WSUS bei allen drei Adressen eingetragen.

 

Stimmt, /Reportnow hatte glatt vergessen aufzuführen, führe eh immer beides aus. Wusste ich gar nicht, dass W10 detectnow ignoriert bzw. nur zusammen mit Resetauthorization funktioniert. Vorher wars eher so, dass ein Client erst dann in der WSUS-Konsole erschien, wenn das erste mal Reportnow durchlief. Naja eigentlich wars eh eher undurchsichtig, daher immer beides =)

Edited by Weingeist
Link to post

@NorbertFe: Verhindert aber lokalen Ärger. Ich musste sie schon eintragen damit alles zuverlässig funktioniert hat. Und ohne geht er manchmal über die Uso wo ihm egal ist welche Updates man will und welche nicht, trotz allen anderen Einstellungen. Wie das in aktuellen Builds ist, weiss ich aber nicht.

 

Also alles aus meinem vorletzten und letzten Post? Dann tippe ich entweder auf ein nicht-WSUS-Kompatibles W10 (evtl. kann Home das nicht?) oder Schadstoffbefall. Insbesondere wenn alles grün angezeigt wird in der Systemsteuerung.

Edited by Weingeist
Link to post
vor 11 Minuten schrieb Weingeist:

Verhindert aber lokalen Ärger. Ich musste sie schon eintragen damit alles zuverlässig funktioniert hat. Und ohne geht er manchmal über die Uso wo ihm egal ist welche Updates man will und welche nicht, trotz allen anderen Einstellungen. Wie das in aktuellen Builds ist, weiss ich aber nicht.

DisableDualScan ist das Zauberwort an der Stelle. Damit wird verhindert, dass der Client zu WU Online geht um Updates zu prüfen/holen. https://www.escde.net/blog/windows-update-richtlinien-und-dual-scan

Und dann kannst Du den dritten Eintrag auch mit dem WSUS füllen.

Link to post

Der müsste natürlich gehen. Wird irgendwas banales sein, das nicht auf Anhieb ersichtlich ist.

 

Weitere Möglichkeiten sind noch SSL/TSL Einstellungen. Die ganzen Protokolle müssen im System aktiviert sein. Wobei das - soweit ich mich erinnere - eher Probleme beim Download als beim anmelden macht. Neuere OS haben da evtl. nur noch SSL aktiviert, wenn der WSUS nicht umgestellt ist, kann das Ärger geben. (Gibts diverse Tuts im Netz)

 

Aber eben, Ereignislog-Meldungen sowie das Update-Log wären mal noch gut. Sonst ist das alles Kaffeesatzleserei.

Link to post
vor 20 Minuten schrieb Weingeist:

Verhindert aber lokalen Ärger. Ich musste sie schon eintragen damit alles zuverlässig funktioniert hat. Und ohne geht er manchmal über die Uso wo ihm egal ist welche Updates man will und welche nicht, trotz allen anderen Einstellungen. Wie das in aktuellen Builds ist, weiss ich aber nicht.

Hatte schon Probleme wenn man dort den wsus hinterlegt hat und den Zugriff auf Internetdienste von ms Updates unterbunden hat. Dann ließen sich diverse Updates nicht installieren. Lösung war den dritten Eintrag zu löschen. Und ja meist funktioniert es, aber das ist keine Garantie.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...