Jump to content

Windows Server 2012 R2 Update-Probleme


Go to solution Solved by testperson,

Recommended Posts

Hallo Kollegen,

ich habe bei verschiedene Kunden (jeweils ein Server pro Kunde) Probleme bei Microsoft die Windows Updates herunterzuladen.

Die Windows Updates werden automatisch, ohne WSUS oder ähnliches, heruntergeladen.

 

Das ging bis vor kurzem alles gut, aber ich habe jetzt ~ 5 Server (unterschiedliche Lokationen und unterschiedliche Infrastrukturen) mit Windows Server 2012 R2 wo diese Fehlermeldung erscheint - Code 80072EFE.

Habt Ihr das auch schon gehabt? Habt Ihr diese Probleme aktuell auch?

 

Im Internet habe ich auch schon geschaut - viele haben das Problem "gehabt", aber irgendwo eine Lösung gefunden.

 

Ich habe folgendes schon versucht:

 - Windows Komponenten zurückgesetzt (Ordner Software Distribution und catroot2)

 - DISM OnlineHealth durchgeführt

 - Trend Micro deinstalliert

 - ..

 

Ein Downloaden über WSUS Offline Tool oder das Update manuell zu installieren, klappt alles!

 

Grüße

Gipsy

Link to post
  • Solution

Hi,

vor 51 Minuten schrieb Gipsy:

Code 80072EFE

Err_6.4.5.exe 80072EFE
# for hex 0x80072efe / decimal -2147012866
  WININET_E_CONNECTION_ABORTED                                   winerror.h
# The connection with the server was terminated abnormally
# 1 matches found for "80072EFE"

 

ich vermute es liegt daran, dass deine Windows Server 2012 R2 kein TLS 1.2 mit Windows Update spricht. Daher

  • einmal IIS Crypto für Server- und Client-Protokolle in Best Practice: https://www.nartac.com/Products/IISCrypto/
  • "reg add HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\v2.0.50727 /V SchUseStrongCrypto /T REG_DWORD /D 1"
  • "reg add HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\v4.0.30319 /V SchUseStrongCrypto /T REG_DWORD /D 1"
  • "reg add HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\v2.0.50727 /V SystemDefaultTlsVersions /T REG_DWORD /D 1"
  • "reg add HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\v4.0.30319 /V SystemDefaultTlsVersions /T REG_DWORD /D 1"
  • durchboote

Bzw. in detaillierter: https://docs.microsoft.com/en-us/mem/configmgr/core/plan-design/security/enable-tls-1-2-client

 

Gruß

Jan

Link to post

Hallo Testperson,

vielen Dank für die Antwort.

 

Ich habe es bei einem Server gestestet und werde heut abend durchstarten.

 

Komisch ist aber, dass bei anderen Server das Ganze noch funktioniert, obwohl die Einstellung bei allen sehr ähnlich sind.

 

IIS Crypto war schon richtig eingestellt.

 

Grüße

Gipsy

Edited by Gipsy
Link to post

Hallo Testperson,

also deine Anleitung hat richtig gut funktioniert :-)

Den zweiten Server mache ich morgen.

 

Ich kann mir nur keinen Reim machen, warum dass nicht bei allen Servern ist.

Ich habe viele Server mit Server 2012 R2 wo die Einstellungen nicht gesetzt sind, aber es trotzdem noch funktioniert..

 

Viele Grüße

Gipsy

 

 

Link to post
  • 3 months later...
Am 26.10.2020 um 15:21 schrieb testperson:

Hi,


Err_6.4.5.exe 80072EFE
# for hex 0x80072efe / decimal -2147012866
  WININET_E_CONNECTION_ABORTED                                   winerror.h
# The connection with the server was terminated abnormally
# 1 matches found for "80072EFE"

 

ich vermute es liegt daran, dass deine Windows Server 2012 R2 kein TLS 1.2 mit Windows Update spricht. Daher

  • einmal IIS Crypto für Server- und Client-Protokolle in Best Practice: https://www.nartac.com/Products/IISCrypto/
  • "reg add HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\v2.0.50727 /V SchUseStrongCrypto /T REG_DWORD /D 1"
  • "reg add HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\v4.0.30319 /V SchUseStrongCrypto /T REG_DWORD /D 1"
  • "reg add HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\v2.0.50727 /V SystemDefaultTlsVersions /T REG_DWORD /D 1"
  • "reg add HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\v4.0.30319 /V SystemDefaultTlsVersions /T REG_DWORD /D 1"
  • durchboote

Bzw. in detaillierter: https://docs.microsoft.com/en-us/mem/configmgr/core/plan-design/security/enable-tls-1-2-client

 

Gruß

Jan

Hi!

 

Ich habe auf einem komplett neu aufgesetzen Win2008R2 Server das gleiche Problem mit der 80072EFE Fehlermeldung beim Update.

 

Habe deine oben genanten Schritte ausgeführt. Leider ohne Erfolg.

 

Kann ich irgendwie feststellen, ob die Änderung erfolgreich waren, außer Windows Update selber zu starten?

 

Oder woran es sonst leiegen kann?

 

Danke!!!

 

Gruß

Andreas

Link to post

Hi,

vor 51 Minuten schrieb ServerWinni:

Kann ich irgendwie feststellen, ob die Änderung erfolgreich waren, außer Windows Update selber zu starten?

du kannst bspw. im IE https://www.ssllabs.com/ssltest/viewMyClient.html aufrufen.

 

Ich würde "einfach" hier

vor 52 Minuten schrieb ServerWinni:

Ich habe auf einem komplett neu aufgesetzen Win2008R2 Server

ansetzen und ein aktuelleres Server OS einsetzen.

 

Gruß

Jan

Link to post
vor 20 Minuten schrieb testperson:

Hi,

du kannst bspw. im IE https://www.ssllabs.com/ssltest/viewMyClient.html aufrufen.

 

Ich würde "einfach" hier

ansetzen und ein aktuelleres Server OS einsetzen.

 

Gruß

Jan

Danke!

 

Den Link kann ich nirgends bei mir aufrufen:

 

Safarai meldet dazu:

 

"Misdirected Request

The client needs a new connection for this request as the requested host name does not match the Server Name Indication (SNI) in use for this connection."

 

Allerdings können andere 2008R2 Updates mit der gleichen Netzwerkkonfiguration machen? Diese sind allerding auf dem neuesten Stand durch Updates.

 

Und wegen alter RDP Hardware muss ich den 2008er nehmen.

 

Danke!

 

Gruß

vor 4 Minuten schrieb Nobbyaushb:

Hallo Andreas @ServerWinni bitte nicht an alte Threads anhängen, die Bedingungen können/werden anders sein

 

Und ich bin bei Jan - sogar 2012R2 ist bei MS schon fast "Alteisen"...

Was soll ich sonst machen? Neues Thema eröffnen?

 

Gruß

Link to post
vor 2 Stunden schrieb testperson:

Hi,

du kannst bspw. im IE https://www.ssllabs.com/ssltest/viewMyClient.html aufrufen.

 

Ich würde "einfach" hier

ansetzen und ein aktuelleres Server OS einsetzen.

 

Gruß

Jan

Hab soeben die Lösung gefunden!

 

Dieser Patch hat das Problem bei mir gelöst:

https://support.microsoft.com/en-us/topic/october-9-2018-kb4462923-monthly-rollup-8ccc9c0a-0fe7-f00c-c0ed-f7e5a23f42d5

 

Gruß

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...