Jump to content

Terminalserver 2012 R2 - RDP Blackscreen


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Hallo,

 

nach wochenlangen googlen und testen, leider erfolglos, muss ich nun hier im Hilfe fragen.

 

Ich betreibe einen Server 2012 R2 mit RDP Diensten.

Der Server ist via ESXi 6.0 virtualisiert. 2 verschiedene Standorte greifen via Site2Site VPN auf das Netzwerk zu und verbinden sich mit Windows 10 Clients via RDP.

Auf diesem Terminalserver sind die Rollendienste: Sitzungshost und Verbindungsbroker installiert,die Lizenzierungsdienste sind (UserCals) am DomainController installiert. Weiters sind die User via GPO eingeschränkt und ohne Admin Rechte, Ordnerumleitung für alle User auf eine LOKALE 2te Festplatte ist aktiviert.

 

Nun habe ich das Problem, dass wochenlang alles ohne Probleme läuft.

Dann plötzlich können sich Clients nicht mehr verbinden -> schwarzer Bildschirm in der RDP Sitzung, Clients welche noch verbunden sind, funktionieren weiterhin. Es kann nur keine neue Verbindung mehr aufgebaut werden! In der Ereignisanzeige des Server erschienen dann permanent Meldungen "Windows Anmeldeprozess wurde unerwartet beendet". Ein Neustarten dieses Dienstes bzw. der RDP Dienste bringt nichts. Erst nach einem kompletten Neustart funkt. wieder alles!

 

Testweise wurde alles bereits ohne Virenscanner getestet, neueste Windows Updates sind natürlich auch installiert.

 

Hat jemand eine Idee was hier die Fehlerursache sein könnte?

Oder WIE ich diesem Fehler auf die schliche kommen kann?

 

Vielen Dank!

 

MfG

Manuel Wagner

 

Link to comment

Hi,

 

gibt es auch User die ohne Site2Site VPN auf den RDS verbinden?

Was läuft ansonsten noch auf dem ESXi6 und wieviele ESXi gibt es? Wie ist der vSwitch konfiguriert und was für physikalische Switche gibt es? Welche Netzwerkkarte hat die RDS VM? Die ESXi sind auch aktuell gepatched?

 

Wöchentliche bis tägliche Reboots der Terminalserver sind definitiv keine Seltenheit. Idle- bzw. Getrennte-Sessions sind auch häufig eher hinderlich.

Tägliche Reboots ankündigen; Einen Tag vorher erinnern; Rebooten. Spätestens danach werden die User zumindest Ihre Daten speichern ;)

 

Gruß

Jan

Link to comment

Hallo,

 

ja 1n User verbindet sich auch von extern -> allerdings nicht zu den Zeiten wo die Ausfälle meistens sind.

Ich muss noch dazu sagen, dass die Standorte verschiedene Anschlüsse haben -> Kupfer, Richtfunk und einmal Glasfaser. Die MTU Werte der Standortvernetzung wurde seitens Provider angepasst/abgestimmt, da dies bei einem früherem Terminalserver schonmal zu langen "Verbindungsaufbauzeiten" geführt hat.

 

Beim ESXi habe ich mich vertan -> ESXi 5.5, 3343343 ist installiert mit vCenter 6.0.

Es ist nur 1n ESXi Server mit lokalen SAS HDDs, vCenter habe ich erst vor 2 Wochen installiert, damit ich die VM auf VM Verison 10 Upgraden konnte (da ich nicht wusste was ich sonst noch probieren kann).

Als Netzwerkkarte am Terminalserver ist die vmnet3 im Einsatz. Weiters laufen noch 2 weitere Server 2012 VMs darauf (DC und DB Server).

 

Am ESXi Host ist ein normaler vSwitch konfiguriert mit 2 Netzwerkadaptern, am Switch ist ein STATIC Lag konfiguriert und am vSwitch -> Lastausgleich anhand des IP-Hashs routen, Netzwerk Failover-Ermittlung anhand de sVerbindungstatus.

 

 

MfG

Manuel

Link to comment

Hallo,

 

ja, auf den DomainController und Datenbankserver kann man sich weiterhin verbinden. Nur auf den Terminalserver komm ich nur noch via ESXi Konsole.

 

Folgender Aufbau:

Zentrale - Standort 1: ESXi Server, Interntanbindung via Richtfunk 16 symmetrisch, + ca. 15 Arbeitsplätze via RDP

Außenstelle 1; Internetzugang via Glasfaser 16 symm.. + Switch mit 10 PCs, welche via RDP arbeiten

Außenstelle 2; Internetzugang via Kupfer 2 symm. + Switch mit 4 PCs, welche via RDP arbeiten

 

Alle Außenstellen haben eine Site2Site VPN zur Zentrale.

 

Nachtrag:

Die Mitarbeiter erklärten mir, dass ab und zu vorher alles sehr träge wird. Wie wenn das Internet kurzzeitig sehr schlecht wird und so eventuell Pakete zum RDP Server verloren gehen. Aber hier sind mit die Hände gebunden..und mir wäre nichts bekannt, dass der RDP Server mit sowas nicht umgehen kann..

Edited by elcotrade
Link to comment

Sobald dieser "Fehler" auftritt, können alle die Verbunden sind ohne Probleme weiterarbeiten. Doch eine neue Verbindungen ist nirgends mehr möglich.

Selbst vom DC weg als Administrator kommt dieser "Black Screen".

 

Nein, während der Geschäftszeiten wird kein Backup/Replica gemacht. Und der Server hängt ja nicht. Es kommen ja tatsächlich Fehlermeldungen, dass der Windows Anmeldeprozess andauernd beendet wird, jedoch via Konsole ist weiterhin ein Login usw. möglich. Der Server wird danach ganz regulär neu gestartet, ohne Abwürgen!

 

Nachtrag:

Die komplette Virtuelle Umgebung samt VMs ist erst ca. 6 Monate alt! Wir hatten nur 1nmal einen Stromausfall mit defekter USV. Möglicherweise tritt der Fehler seither vermehrt auf. CHKDSK, SFC, DISM finden auch keine Fehler....ich bin ratlos..

Edited by elcotrade
Link to comment

Sind das komplett neue Sessions? Oder passiert das bei Usern die in eine getrennte Sitzung reconnecten bzw. die ihre Session vom einen Client auf den anderen Client mitnehmen wollen?

Werden irgendwelche "außergewöhnlichen" Devices in die Session mitgenommen?

 

Evtl. findest du was mit dem RDS Diagnostic Tool: https://www.microsoft.com/en-us/download/details.aspx?id=40890 / https://support.microsoft.com/en-us/kb/2692470

Edited by testperson
Link to comment

Mir spuckt das Tool diverse Infos aus. Z.B. unter Connections könntest du mal User:<ein Problem User> eingeben und auf Start klicken. Unter Events & Traces dürfte sich auch was tun. Und einen kompletten Dump der DB gibt dir das Tool sicherlich auch aus.

 

Drucker / Laufwerke / USB Passthrough ist in der Sammlung aus oder könnten die User Geräte mit in die Session nehmen?

Die Clients erkennen die Verbindungsqualität automatisch? Ist evtl. UDP 3389 in der Firewall dicht?

 

https://support.microsoft.com/en-us/kb/2897632 bzw. https://support.microsoft.com/en-us/kb/2887595 definitiv installiert?

 

Evtl. solltest du mal ein Ticket bei MS aufmachen. Ansonsten könntest du vielleicht noch was mit dem Process Monitor oder Process Explorer rausfinden was da beim Login zum Black Screen führt.

Edited by testperson
Link to comment

Hallo,

 

unter Connections sind nur "Succees" Meldungen ersichtlich, keine Fehler!

Ja da tut sich schon was...aber für mich unmöglich da irgendetwas auszuwerten!

 

Ja, alles in der Sammlung deaktivert, hab gestern via GPO noch die Erkennung der Verb.Qualität seitens Server aktiviert. Aber auch auf den Clients ist automatische Erkennung aktiviert.

UDP 3389 ist offen, der Fehler passiert ja dann auch lokal! Muss am Server liegen, da ja sonst der Anmeldeprozess nicht abstürzen würde.

 

Jap, die KBs sind installiert...

 

jap ich mal mal ein Ticket auf...hab ich noch nie gemacht, bin gespannt wie das so läuft =)

Link to comment

auch wenn es dir nun nicht wirklich weiter hilft:

Das gleiche Problem habe\hatte ich ebenfalls, jedoch bei 2008R2. Habe auch ewig nach einer Lösung gesucht, aber nichts gefunden (bis auf den gleichen event Eintrag wie du). Seit dem ich nun Regelmäßig die Server (eine kleine Farm mit 4 TSHosts) neustarte, ist das Problem nicht mehr aufgetreten. 

Link to comment
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...